]> git.pld-linux.org Git - packages/perl-IPC-Run.git/blob - perl-IPC-Run.spec
- updated 0.80
[packages/perl-IPC-Run.git] / perl-IPC-Run.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (one test fails)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IPC
7 %define         pnam    Run
8 Summary:        IPC::Run - system() and background procs w/ piping, redirs, ptys
9 Summary(pl):    IPC::Run - uruchamianie procesów z potokami, przekierowaniami i pseudoterminalami
10 Name:           perl-IPC-Run
11 Version:        0.80
12 Release:        1
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a867e694862afd4a3c429124618fc15e
17 BuildRequires:  perl-IO-Tty >= 1.00
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _noautoreq      'perl(IO::Pty)'
24
25 %description
26 IPC::Run allows you run and interact with child processes using files,
27 pipes, and pseudo-ttys. Both system()-style and scripted usages are
28 supported and may be mixed. Likewise, functional and OO API styles are
29 both supported and may be mixed.
30
31 Various redirection operators reminiscent of those seen on common Unix
32 and DOS command lines are provided.
33
34 %description -l pl
35 IPC::Run pozwala na uruchamianie i interakcjê z procesami potomnymi
36 przy u¿yciu plików, potoków, i pseudoterminali. Obs³uguje zarówno
37 interfejs w stylu system(), jak i skryptowy; mo¿na tak¿e je mieszaæ.
38 Mo¿na stosowaæ API obiektowe i/lub proceduralne.
39
40 Udostêpniane s± ró¿ne operatory przekierowania, podobne do spotykanych
41 w linii poleceñ popularnych Uniksów i DOS-a.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes
65 %{perl_vendorlib}/IPC/Run.pm
66 %dir %{perl_vendorlib}/IPC/Run
67 %{perl_vendorlib}/IPC/Run/*
68 %{_mandir}/man3/*
This page took 0.094628 seconds and 3 git commands to generate.