]> git.pld-linux.org Git - packages/perl-IPC-Run.git/blob - perl-IPC-Run.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IPC-Run.git] / perl-IPC-Run.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (one test fails)
4 #
5 %define         pdir    IPC
6 %define         pnam    Run
7 Summary:        IPC::Run - system() and background procs w/ piping, redirs, ptys
8 Summary(pl.UTF-8):      IPC::Run - uruchamianie procesów z potokami, przekierowaniami i pseudoterminalami
9 Name:           perl-IPC-Run
10 Version:        0.90
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IPC/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fda6bbd9d5e4e738a02230923a41125b
17 URL:            http://search.cpan.org/dist/IPC-Run/
18 BuildRequires:  perl-IO-Tty >= 1.08
19 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.47}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 IPC::Run allows you run and interact with child processes using files,
27 pipes, and pseudo-ttys. Both system()-style and scripted usages are
28 supported and may be mixed. Likewise, functional and OO API styles are
29 both supported and may be mixed.
30
31 Various redirection operators reminiscent of those seen on common Unix
32 and DOS command lines are provided.
33
34 %description -l pl.UTF-8
35 IPC::Run pozwala na uruchamianie i interakcję z procesami potomnymi
36 przy użyciu plików, potoków, i pseudoterminali. Obsługuje zarówno
37 interfejs w stylu system(), jak i skryptowy; można także je mieszać.
38 Można stosować API obiektowe i/lub proceduralne.
39
40 Udostępniane są różne operatory przekierowania, podobne do spotykanych
41 w linii poleceń popularnych Uniksów i DOS-a.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes
65 %{perl_vendorlib}/IPC/Run.pm
66 %dir %{perl_vendorlib}/IPC/Run
67 %{perl_vendorlib}/IPC/Run/*.pm
68 %{_mandir}/man3/IPC::Run*.3pm*
This page took 0.081726 seconds and 4 git commands to generate.