]> git.pld-linux.org Git - packages/perl-IO-Socket-Multicast.git/blob - perl-IO-Socket-Multicast.spec
- pl, missing dir, cleanup
[packages/perl-IO-Socket-Multicast.git] / perl-IO-Socket-Multicast.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    IO
8 %define         pnam    Socket-Multicast
9 Summary:        IO::Socket::Multicast - send and receive multicast messages
10 Summary(pl):    IO::Socket::Multicast - wysy³anie i odbieranie komunikatów multicastowych
11 Name:           perl-IO-Socket-Multicast
12 Version:        1.04
13 Release:        0.1
14 # "same as perl"
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  c433622d7ca5149faf90c21107223e1f
19 URL:            http://search.cpan.org/dist/IO-Socket-Multicast/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with autodeps} || %{with tests}
23 BuildRequires:  perl-IO-Interface >= 0.94
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The IO::Socket::Multicast module subclasses IO::Socket::INET to enable
29 you to manipulate multicast groups. With this module (and an operating
30 system that supports multicasting), you will be able to receive
31 incoming multicast transmissions and generate your own outgoing
32 multicast packets.
33
34 %description -l pl
35 Modu³ IO::Socket::Multicast jest podklas± IO::Socket::INET pozwalaj±c±
36 na manipulowanie grupami multicastowymi. Przy u¿yciu tego modu³u (i
37 systemu operacyjnego obs³uguj±cego multicasty) mo¿na odbieraæ
38 przychodz±c± transmisjê multicastow± i generowaæ w³asne wychodz±ce
39 pakiety multicastowe.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47
48 %{__make} \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 install examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorarch}/IO/Socket/Multicast.pm
68 %dir %{perl_vendorarch}/auto/IO/Socket/Multicast
69 %{perl_vendorarch}/auto/IO/Socket/Multicast/Multicast.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Socket/Multicast/Multicast.so
71 %{_examplesdir}/%{name}-%{version}
72 %{_mandir}/man3/*
This page took 0.195183 seconds and 4 git commands to generate.