]> git.pld-linux.org Git - packages/perl-IO-Socket-Multicast.git/blob - perl-IO-Socket-Multicast.spec
perl 5.38.0 rebuild
[packages/perl-IO-Socket-Multicast.git] / perl-IO-Socket-Multicast.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    IO
7 %define         pnam    Socket-Multicast
8 Summary:        IO::Socket::Multicast - send and receive multicast messages
9 Summary(pl.UTF-8):      IO::Socket::Multicast - wysyłanie i odbieranie komunikatów multicastowych
10 Name:           perl-IO-Socket-Multicast
11 Version:        1.12
12 Release:        15
13 # "same as perl"
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c96e6cbb367b1d11ffe7bb9fbd833540
18 URL:            http://search.cpan.org/dist/IO-Socket-Multicast/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-IO-Interface >= 0.94
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The IO::Socket::Multicast module subclasses IO::Socket::INET to enable
28 you to manipulate multicast groups. With this module (and an operating
29 system that supports multicasting), you will be able to receive
30 incoming multicast transmissions and generate your own outgoing
31 multicast packets.
32
33 %description -l pl.UTF-8
34 Moduł IO::Socket::Multicast jest podklasą IO::Socket::INET pozwalającą
35 na manipulowanie grupami multicastowymi. Przy użyciu tego modułu (i
36 systemu operacyjnego obsługującego multicasty) można odbierać
37 przychodzącą transmisję multicastową i generować własne wychodzące
38 pakiety multicastowe.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 install examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %dir %{perl_vendorarch}/auto/IO/Socket
68 %{perl_vendorarch}/IO/Socket/Multicast.pm
69 %dir %{perl_vendorarch}/auto/IO/Socket/Multicast
70 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Socket/Multicast/Multicast.so
71 %{_examplesdir}/%{name}-%{version}
72 %{_mandir}/man3/*
This page took 0.166506 seconds and 4 git commands to generate.