]> git.pld-linux.org Git - packages/perl-IO-Interface.git/blob - perl-IO-Interface.spec
- x32 rebuild
[packages/perl-IO-Interface.git] / perl-IO-Interface.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    Interface
8 Summary:        IO::Interface - Perl extension to access interface information
9 Summary(pl.UTF-8):      IO::Interface - rozszerzenie Perla do dostępu do informacji o interfejsach
10 Name:           perl-IO-Interface
11 Version:        1.06
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7d77d0f23ee7f577109fc5f0e67e0a4b
18 URL:            http://search.cpan.org/dist/IO-Interface/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 IO::Interface adds methods to IO::Socket objects that allows them to
25 be used to retrieve and change information about the network
26 interfaces on your system.  In addition to the object-oriented access
27 methods, you can use a function-oriented style.
28
29 %description -l pl.UTF-8
30 IO::Interface dodaje do obiektów IO::Socket metody pozwalające na
31 używanie ich do pobierania i zmiany informacji o interfejsach
32 sieciowych w systemie. Oprócz metod zorientowanych obiektowo można
33 używać także wywołań zorientowanych na funkce.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/IO/Interface.pm
61 %dir %{perl_vendorarch}/IO/Interface
62 %{perl_vendorarch}/IO/Interface/Simple.pm
63 %dir %{perl_vendorarch}/auto/IO/Interface
64 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Interface/*.so
65 %{perl_vendorarch}/auto/IO/Interface/autosplit.ix
66 %{_mandir}/man3/*
This page took 0.06507 seconds and 3 git commands to generate.