]> git.pld-linux.org Git - packages/perl-IO-Interface.git/blob - perl-IO-Interface.spec
perl 5.38.0 rebuild
[packages/perl-IO-Interface.git] / perl-IO-Interface.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    IO
6 %define         pnam    Interface
7 Summary:        IO::Interface - Perl extension to access interface information
8 Summary(pl.UTF-8):      IO::Interface - rozszerzenie Perla do dostępu do informacji o interfejsach
9 Name:           perl-IO-Interface
10 Version:        1.09
11 Release:        5
12 License:        Artistic v2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  806f97aff5a7361b6f54cd494f4cc9fd
16 URL:            https://metacpan.org/release/IO-Interface
17 BuildRequires:  perl-ExtUtils-CBuilder
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 IO::Interface adds methods to IO::Socket objects that allows them to
26 be used to retrieve and change information about the network
27 interfaces on your system.  In addition to the object-oriented access
28 methods, you can use a function-oriented style.
29
30 %description -l pl.UTF-8
31 IO::Interface dodaje do obiektów IO::Socket metody pozwalające na
32 używanie ich do pobierania i zmiany informacji o interfejsach
33 sieciowych w systemie. Oprócz metod zorientowanych obiektowo można
34 używać także wywołań zorientowanych na funkce.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Build.PL \
41         --config optimize='%{rpmcflags}' \
42         --installdirs=vendor
43
44 ./Build
45
46 %{?with_tests:./Build test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 ./Build install \
52         --destdir $RPM_BUILD_ROOT
53
54 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/IO/Interface/*.bs
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README.md
62 %{perl_vendorarch}/IO/Interface.pm
63 %dir %{perl_vendorarch}/IO/Interface
64 %{perl_vendorarch}/IO/Interface/Simple.pm
65 %dir %{perl_vendorarch}/auto/IO/Interface
66 %attr(755,root,root) %{perl_vendorarch}/auto/IO/Interface/Interface.so
67 %{_mandir}/man3/IO::Interface*.3pm*
This page took 0.111109 seconds and 4 git commands to generate.