]> git.pld-linux.org Git - packages/perl-IO-Async.git/blob - perl-IO-Async.spec
- up to 0.39
[packages/perl-IO-Async.git] / perl-IO-Async.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    IO
7 %define pnam    Async
8 Summary:        IO::Async - perform asynchronous filehandle IO and other operations
9 Summary(pl.UTF-8):      IO::Async - asynchroniczne operacje we/wy na plikach i inne
10 Name:           perl-IO-Async
11 Version:        0.39
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/IO/PEVANS/IO-Async-%{version}.tar.gz
17 # Source0-md5:  084f8f925827db81c64036afb05be9fb
18 URL:            http://search.cpan.org/dist/IO-Async/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Async-MergePoint
23 BuildRequires:  perl-CPS
24 BuildRequires:  perl-Heap >= 0.80
25 BuildRequires:  perl-Socket-GetAddrInfo >= 0.18
26 BuildRequires:  perl-Storable
27 BuildRequires:  perl-Time-HiRes
28 BuildRequires:  perl-Test-Exception
29 BuildRequires:  perl-Test-Fatal
30 BuildRequires:  perl-Test-Identity
31 BuildRequires:  perl-Test-Refcount
32 BuildRequires:  perl-Test-Warn
33 %endif
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 This collection of modules allows programs to be written that perform
39 asynchronous filehandle IO operations. A typical program using them
40 would consist of a single subclass of IO::Async::Loop to act as a
41 container of other objects, which perform the actual IO work required
42 by the program. As well as IO handles, the loop also supports timers
43 and signal handlers, and includes more higher-level functionallity
44 built on top of these basic parts.
45
46 %description -l pl.UTF-8
47 Zestaw modułów umożliwiających pisanie programów wykonywanie
48 asynchroncznych operacji we/wy na uchwytach plików. Typowy program
49 wykonujący je składa się z pojedynczej podklasy IO::Async::Loop
50 pełniącej rolę kontenera innych obiektów, wykonujących właściwe
51 operacje we/wy wymagane przez program. Oprócz obsługi we/wy pętla
52 obsługuje także stopery i sygnały, a także zawiera nieco funkcji
53 wyższego poziomu stworzonych w oparciu o te podstawowe elementy.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Build.PL \
60         destdir=$RPM_BUILD_ROOT \
61         installdirs=vendor
62 ./Build
63
64 %{?with_tests:./Build test}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 ./Build install
70
71 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes README
80 %{perl_vendorlib}/IO/Async.pm
81 %{perl_vendorlib}/IO/Async
82 %{_mandir}/man3/IO::Async*.3pm*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.107897 seconds and 3 git commands to generate.