]> git.pld-linux.org Git - packages/perl-IO-Async.git/blob - perl-IO-Async.spec
- don't run resolver test
[packages/perl-IO-Async.git] / perl-IO-Async.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    IO
6 %define pnam    Async
7 Summary:        IO::Async - perform asynchronous filehandle IO and other operations
8 Summary(pl.UTF-8):      IO::Async - asynchroniczne operacje we/wy na plikach i inne
9 Name:           perl-IO-Async
10 Version:        0.74
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/PEVANS/IO-Async-%{version}.tar.gz
16 # Source0-md5:  cf5f6a54c07f1d6f0ca484cac057bb6b
17 URL:            http://search.cpan.org/dist/IO-Async/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Async-MergePoint
23 BuildRequires:  perl-CPS
24 BuildRequires:  perl-Future
25 BuildRequires:  perl-Heap >= 0.80
26 BuildRequires:  perl-Socket-GetAddrInfo >= 0.18
27 BuildRequires:  perl-Storable
28 BuildRequires:  perl-Struct-Dumb
29 BuildRequires:  perl-Time-HiRes
30 BuildRequires:  perl-Test-Exception
31 BuildRequires:  perl-Test-Fatal
32 BuildRequires:  perl-Test-Identity
33 BuildRequires:  perl-Test-Refcount
34 BuildRequires:  perl-Test-Warn
35 %endif
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This collection of modules allows programs to be written that perform
41 asynchronous filehandle IO operations. A typical program using them
42 would consist of a single subclass of IO::Async::Loop to act as a
43 container of other objects, which perform the actual IO work required
44 by the program. As well as IO handles, the loop also supports timers
45 and signal handlers, and includes more higher-level functionallity
46 built on top of these basic parts.
47
48 %description -l pl.UTF-8
49 Zestaw modułów umożliwiających pisanie programów wykonywanie
50 asynchroncznych operacji we/wy na uchwytach plików. Typowy program
51 wykonujący je składa się z pojedynczej podklasy IO::Async::Loop
52 pełniącej rolę kontenera innych obiektów, wykonujących właściwe
53 operacje we/wy wymagane przez program. Oprócz obsługi we/wy pętla
54 obsługuje także stopery i sygnały, a także zawiera nieco funkcji
55 wyższego poziomu stworzonych w oparciu o te podstawowe elementy.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 # No resolver / network on builders
61 %{__rm} t/50resolver.t
62
63 %build
64 %{__perl} Build.PL \
65         destdir=$RPM_BUILD_ROOT \
66         installdirs=vendor
67 ./Build
68
69 %{?with_tests:./Build test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 ./Build install
75
76 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc Changes README
85 %{perl_vendorlib}/IO/Async.pm
86 %{perl_vendorlib}/IO/Async
87 %{_mandir}/man3/IO::Async*.3pm*
88 %{_examplesdir}/%{name}-%{version}
This page took 0.070506 seconds and 4 git commands to generate.