]> git.pld-linux.org Git - packages/perl-File-Type.git/blob - perl-File-Type.spec
use generic url
[packages/perl-File-Type.git] / perl-File-Type.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    File
6 %define pnam    Type
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        File::Type - determine file type using magic
9 Summary(pl.UTF-8):      File::Type - określenie typu pliku za pomocą liczb magicznych
10 Name:           perl-File-Type
11 Version:        0.22
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4be3b0b7000b325c60351fcc8a04815d
18 URL:            http://search.cpan.org/dist/File-Type/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 File::Type uses magic numbers (typically at the start of a file) to
26 determine the MIME type of that file.
27
28 File::Type can use either a filename, or file contents, to determine
29 the type of a file.
30
31 %description -l pl.UTF-8
32 File::Type służy do określania typu MIME pliku za pomocą liczb
33 magicznych (zazwyczaj zawartych na początku pliku).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes
57 %{perl_vendorlib}/File/*.pm
58 %{perl_vendorlib}/File/Type
59 %{_mandir}/man3/*
This page took 0.14218 seconds and 3 git commands to generate.