]> git.pld-linux.org Git - packages/perl-File-Type.git/blob - perl-File-Type.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-File-Type.git] / perl-File-Type.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    File
6 %define pnam    Type
7 Summary:        File::Type - determine file type using magic
8 Summary(pl.UTF-8):      File::Type - określenie typu pliku za pomocą liczb magicznych
9 Name:           perl-File-Type
10 Version:        0.22
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  4be3b0b7000b325c60351fcc8a04815d
17 URL:            http://search.cpan.org/dist/File-Type/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 File::Type uses magic numbers (typically at the start of a file) to
25 determine the MIME type of that file.
26
27 File::Type can use either a filename, or file contents, to determine
28 the type of a file.
29
30 %description -l pl.UTF-8
31 File::Type służy do określania typu MIME pliku za pomocą liczb
32 magicznych (zazwyczaj zawartych na początku pliku).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorlib}/File/*.pm
57 %{perl_vendorlib}/File/Type
58 %{_mandir}/man3/*
This page took 0.198399 seconds and 4 git commands to generate.