]> git.pld-linux.org Git - packages/perl-FFI-CheckLib.git/blob - perl-FFI-CheckLib.spec
- up to 0.31
[packages/perl-FFI-CheckLib.git] / perl-FFI-CheckLib.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    FFI
6 %define         pnam    CheckLib
7 Summary:        FFI::CheckLib - Check that a library is available for FFI
8 Summary(pl.UTF-8):      FFI::CheckLib - sprawdzanie, czy biblioteka jest dostępna dla FFI
9 Name:           perl-FFI-CheckLib
10 Version:        0.31
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/FFI/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ffc8e61bb686dd631bed3ddf102af41c
17 URL:            https://metacpan.org/release/FFI-CheckLib
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl(Test2::API) >= 1.302015
23 BuildRequires:  perl-Test2-Suite >= 0.000060
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module checks whether a particular dynamic library is available
30 for FFI to use. It is modeled heavily on Devel::CheckLib, but will
31 find dynamic libraries even when development packages are not
32 installed. It also provides a find_lib function that will return the
33 full path to the found dynamic library, which can be feed directly
34 into FFI::Platypus or another FFI system.
35
36 %description -l pl.UTF-8
37 Ten moduł sprawdza, czy pewna biblioteka dynamiczna jest dostępna do
38 użycia przez FFI. Jest wzorowana w dużym stopniu na Devel::CheckLib,
39 ale znajduje biblioteki dynamiczne nawet jeśli pakiety programistyczne
40 nie są zainstalowane. Udostępnia także funkcję find_lib, zwracającą
41 pełną ścieżkę do znalezionej biblioteki dynamicznej, którą można
42 bezpośrednio przekazać do FFI::Platypus lub innego systemu FFI.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes
69 %dir %{perl_vendorlib}/FFI
70 %{perl_vendorlib}/FFI/CheckLib.pm
71 %{_mandir}/man3/FFI::CheckLib.3pm*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.690468 seconds and 3 git commands to generate.