]> git.pld-linux.org Git - packages/perl-FFI-CheckLib.git/blame - perl-FFI-CheckLib.spec
- up to 0.31
[packages/perl-FFI-CheckLib.git] / perl-FFI-CheckLib.spec
CommitLineData
cc528961
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir FFI
6%define pnam CheckLib
7Summary: FFI::CheckLib - Check that a library is available for FFI
8Summary(pl.UTF-8): FFI::CheckLib - sprawdzanie, czy biblioteka jest dostępna dla FFI
9Name: perl-FFI-CheckLib
6011ce88 10Version: 0.31
cc528961
JB
11Release: 1
12# same as perl 5
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/FFI/%{pdir}-%{pnam}-%{version}.tar.gz
6011ce88 16# Source0-md5: ffc8e61bb686dd631bed3ddf102af41c
cc528961
JB
17URL: https://metacpan.org/release/FFI-CheckLib
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRequires: rpmbuild(macros) >= 1.745
21%if %{with tests}
22BuildRequires: perl(Test2::API) >= 1.302015
23BuildRequires: perl-Test2-Suite >= 0.000060
24%endif
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29This module checks whether a particular dynamic library is available
30for FFI to use. It is modeled heavily on Devel::CheckLib, but will
31find dynamic libraries even when development packages are not
32installed. It also provides a find_lib function that will return the
33full path to the found dynamic library, which can be feed directly
34into FFI::Platypus or another FFI system.
35
36%description -l pl.UTF-8
37Ten moduł sprawdza, czy pewna biblioteka dynamiczna jest dostępna do
38użycia przez FFI. Jest wzorowana w dużym stopniu na Devel::CheckLib,
39ale znajduje biblioteki dynamiczne nawet jeśli pakiety programistyczne
40nie są zainstalowane. Udostępnia także funkcję find_lib, zwracającą
41pełną ścieżkę do znalezionej biblioteki dynamicznej, którą można
42bezpośrednio przekazać do FFI::Platypus lub innego systemu FFI.
43
44%prep
45%setup -q -n %{pdir}-%{pnam}-%{version}
46
47%build
48%{__perl} Makefile.PL \
49 INSTALLDIRS=vendor
50%{__make}
51
52%{?with_tests:%{__make} test}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57%{__make} pure_install \
58 DESTDIR=$RPM_BUILD_ROOT
59
60install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc Changes
d6894617 69%dir %{perl_vendorlib}/FFI
cc528961
JB
70%{perl_vendorlib}/FFI/CheckLib.pm
71%{_mandir}/man3/FFI::CheckLib.3pm*
72%{_examplesdir}/%{name}-%{version}
This page took 1.875652 seconds and 4 git commands to generate.