]> git.pld-linux.org Git - packages/perl-Email-Abstract.git/blob - perl-Email-Abstract.spec
ver. 3.008
[packages/perl-Email-Abstract.git] / perl-Email-Abstract.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Email
7 %define         pnam    Abstract
8 Summary:        Unified interface to mail representations
9 Summary(pl.UTF-8):      Zunifikiowany interfejs do reprezentacji listów
10 Name:           perl-Email-Abstract
11 Version:        3.008
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  dbfc069ffb5f8c96989bf62f0df5d756
18 URL:            http://search.cpan.org/dist/Email-Abstract/
19 BuildRequires:  perl-Email-Simple >= 1:1.91
20 BuildRequires:  perl-Module-Pluggable >= 1.5
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Email::Abstract provides module writers with the ability to write
28 representation-independent mail handling code. For instance, in the
29 cases of Mail::Thread or Mail::ListDetector, a key part of the code
30 involves reading the headers from a mail object. Where previously one
31 would either have to specify the mail class required, or to build a
32 new object from scratch, Email::Abstract can be used to perform
33 certain simple operations on an object regardless of its underlying
34 representation.
35
36 Email::Abstract currently supports Mail::Internet, MIME::Entity,
37 Mail::Message, Email::Simple and Email::MIME. Other representations
38 are encouraged to create their own Email::Abstract::* class by copying
39 Email::Abstract::EmailSimple. All modules installed under the
40 Email::Abstract hierarchy will be automatically picked up and used.
41
42 %description -l pl.UTF-8
43 Email::Abstract dostarcza piszącym moduły możliwość pisania kodu
44 obsługującego listy elektroniczne niezależnie od reprezentacji. Na
45 przykład w przypadku Mail::Thread lub Mail::ListDetector znacząca
46 część kodu dotyczy czytania nagłówków z obiektu listu. Tam, gdzie
47 poprzednio trzeba było podać wymaganą nazwę klasy lub zbudować nowy
48 obiekt od początku, można użyć Email::Abstract do wykonania pewnych
49 prostych operacji na obiekcie niezależnie od jego reprezentacji.
50
51 Email::Abstract aktualnie obsługuje Mail::Internet, MIME::Entity,
52 Mail::Message, Email::Simple oraz Email::MIME. Dla innych
53 reprezentacji zaleca się stworzyć własną klasę Email::Abstract::*
54 poprzez skopiowanie Email::Abstract::EmailSimple. Wszystkie moduły
55 zainstalowane w hierarchii Email::Abstract są automatycznie używane.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63
64 %{__make}
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc Changes
80 %{perl_vendorlib}/Email/Abstract.pm
81 %{perl_vendorlib}/Email/Abstract
82 %{_mandir}/man3/*
This page took 0.042025 seconds and 3 git commands to generate.