]> git.pld-linux.org Git - packages/perl-Email-Abstract.git/blob - perl-Email-Abstract.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Email-Abstract.git] / perl-Email-Abstract.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Email
6 %define         pnam    Abstract
7 Summary:        Unified interface to mail representations
8 Summary(pl.UTF-8):      Zunifikiowany interfejs do reprezentacji listów
9 Name:           perl-Email-Abstract
10 Version:        3.008
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  dbfc069ffb5f8c96989bf62f0df5d756
17 URL:            http://search.cpan.org/dist/Email-Abstract/
18 BuildRequires:  perl-Email-Simple >= 1:1.91
19 BuildRequires:  perl-Module-Pluggable >= 1.5
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Email::Abstract provides module writers with the ability to write
27 representation-independent mail handling code. For instance, in the
28 cases of Mail::Thread or Mail::ListDetector, a key part of the code
29 involves reading the headers from a mail object. Where previously one
30 would either have to specify the mail class required, or to build a
31 new object from scratch, Email::Abstract can be used to perform
32 certain simple operations on an object regardless of its underlying
33 representation.
34
35 Email::Abstract currently supports Mail::Internet, MIME::Entity,
36 Mail::Message, Email::Simple and Email::MIME. Other representations
37 are encouraged to create their own Email::Abstract::* class by copying
38 Email::Abstract::EmailSimple. All modules installed under the
39 Email::Abstract hierarchy will be automatically picked up and used.
40
41 %description -l pl.UTF-8
42 Email::Abstract dostarcza piszącym moduły możliwość pisania kodu
43 obsługującego listy elektroniczne niezależnie od reprezentacji. Na
44 przykład w przypadku Mail::Thread lub Mail::ListDetector znacząca
45 część kodu dotyczy czytania nagłówków z obiektu listu. Tam, gdzie
46 poprzednio trzeba było podać wymaganą nazwę klasy lub zbudować nowy
47 obiekt od początku, można użyć Email::Abstract do wykonania pewnych
48 prostych operacji na obiekcie niezależnie od jego reprezentacji.
49
50 Email::Abstract aktualnie obsługuje Mail::Internet, MIME::Entity,
51 Mail::Message, Email::Simple oraz Email::MIME. Dla innych
52 reprezentacji zaleca się stworzyć własną klasę Email::Abstract::*
53 poprzez skopiowanie Email::Abstract::EmailSimple. Wszystkie moduły
54 zainstalowane w hierarchii Email::Abstract są automatycznie używane.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes
79 %{perl_vendorlib}/Email/Abstract.pm
80 %{perl_vendorlib}/Email/Abstract
81 %{_mandir}/man3/*
This page took 0.05999 seconds and 4 git commands to generate.