]> git.pld-linux.org Git - packages/perl-Directory-Scratch.git/blob - perl-Directory-Scratch.spec
- added missing %dir in %files section
[packages/perl-Directory-Scratch.git] / perl-Directory-Scratch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Directory
7 %define pnam    Scratch
8 Summary:        Directory::Scratch - Easy-to-use self-cleaning scratch space
9 Summary(pl.UTF-8):      Directory::Scratch - łatwa w użyciu samoczyszcząca przestrzeń robocza
10 Name:           perl-Directory-Scratch
11 Version:        0.14
12 Release:        2
13 License:        Perl
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Directory/Directory-Scratch-%{version}.tar.gz
16 # Source0-md5:  3e759c3a5ff8c678725aad99e80a5c14
17 URL:            http://search.cpan.org/dist/Directory-Scratch/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-File-Slurp >= 9999.12
22 # version is just because it failed on 0.12 here, even if makefile doesn't specify minimum version
23 BuildRequires:  perl-Path-Class > 0.12
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Directory::Scratch - Easy-to-use self-cleaning scratch space.
30
31 %description -l pl.UTF-8
32 Directory::Scratch - łatwa w użyciu samoczyszcząca przestrzeń robocza.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36 mv t/os/win32.t{,.off}
37 mv t/os/mac.t{,.off}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %dir %{perl_vendorlib}/Directory
62 %{perl_vendorlib}/Directory/*.pm
63 %{_mandir}/man3/*
64 %{_examplesdir}/%{name}-%{version}
This page took 0.237536 seconds and 4 git commands to generate.