]> git.pld-linux.org Git - packages/perl-Directory-Scratch.git/blob - perl-Directory-Scratch.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Directory-Scratch.git] / perl-Directory-Scratch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Directory
6 %define pnam    Scratch
7 Summary:        Directory::Scratch - Easy-to-use self-cleaning scratch space
8 Summary(pl.UTF-8):      Directory::Scratch - łatwa w użyciu samoczyszcząca przestrzeń robocza
9 Name:           perl-Directory-Scratch
10 Version:        0.18
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Directory/Directory-Scratch-%{version}.tar.gz
16 # Source0-md5:  66ea2b47c1bb184b08ba562d14727fb4
17 URL:            http://search.cpan.org/dist/Directory-Scratch/
18 BuildRequires:  perl-Module-Build-Tiny
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-File-Slurp >= 9999.12
23 # version is just because it failed on 0.12 here, even if makefile doesn't specify minimum version
24 BuildRequires:  perl-Path-Class > 0.12
25 BuildRequires:  perl-Path-Tiny >= 0.060
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Directory::Scratch - Easy-to-use self-cleaning scratch space.
32
33 %description -l pl.UTF-8
34 Directory::Scratch - łatwa w użyciu samoczyszcząca przestrzeń robocza.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %{__mv} t/os/win32.t{,.off}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %dir %{perl_vendorlib}/Directory
63 %{perl_vendorlib}/Directory/Scratch.pm
64 %{_mandir}/man3/Directory::Scratch.3pm*
65 %{_examplesdir}/%{name}-%{version}
This page took 0.10911 seconds and 4 git commands to generate.