]> git.pld-linux.org Git - packages/perl-Digest-GOST.git/blob - perl-Digest-GOST.spec
- generic Source URL, added tests
[packages/perl-Digest-GOST.git] / perl-Digest-GOST.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Digest
7 %define         pnam    GOST
8 Summary:        Digest::GOST - Perl interface to the GOST R 34.11-94 digest algorithm
9 Summary(pl.UTF-8):      Digest::GOST - implementacja algorytmu skrótu GOST R 34.11-94
10 Name:           perl-Digest-GOST
11 Version:        0.06
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d91904e56300d08956ea5f1e174863f3
18 URL:            http://search.cpan.org/dist/Digest-GOST/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple >= 0.82
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Digest::GOST module provides an interface to the GOST R 34.11-94
28 message digest algorithm. This interface follows the conventions set
29 forth by the Digest module. To use the CryptoPro parameters, use
30 Digest::GOST::CryptoPro.
31
32 %description -l pl.UTF-8
33 Moduł Digest::GOST implementuje algorytm skrótu GOST R 34.11-94.
34 Interfejs programistyczny jest zgodny z konwencją przyjętą przez
35 moduł Digest. W przypadku wykorzystywania parametrów CryptoPro
36 należy użyć modułu Digest::GOST::CryptoPro.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README Changes
62 %{perl_vendorarch}/Digest/GOST.pm
63 %{perl_vendorarch}/Digest/GOST
64 %dir %{perl_vendorarch}/auto/Digest/GOST
65 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/GOST/GOST.so
66 %{_mandir}/man3/Digest::GOST.3pm*
67 %{_mandir}/man3/Digest::GOST::CryptoPro.3pm*
This page took 0.093164 seconds and 3 git commands to generate.