]> git.pld-linux.org Git - packages/perl-Digest-GOST.git/blob - perl-Digest-GOST.spec
perl 5.38.0 rebuild
[packages/perl-Digest-GOST.git] / perl-Digest-GOST.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Digest
6 %define         pnam    GOST
7 Summary:        Digest::GOST - Perl interface to the GOST R 34.11-94 digest algorithm
8 Summary(pl.UTF-8):      Digest::GOST - implementacja algorytmu skrótu GOST R 34.11-94
9 Name:           perl-Digest-GOST
10 Version:        0.06
11 Release:        10
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d91904e56300d08956ea5f1e174863f3
17 URL:            https://metacpan.org/release/Digest-GOST
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.82
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Digest::GOST module provides an interface to the GOST R 34.11-94
28 message digest algorithm. This interface follows the conventions set
29 forth by the Digest module. To use the CryptoPro parameters, use
30 Digest::GOST::CryptoPro.
31
32 %description -l pl.UTF-8
33 Moduł Digest::GOST implementuje algorytm skrótu GOST R 34.11-94.
34 Interfejs programistyczny jest zgodny z konwencją przyjętą przez
35 moduł Digest. W przypadku wykorzystywania parametrów CryptoPro
36 należy użyć modułu Digest::GOST::CryptoPro.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README Changes
62 %{perl_vendorarch}/Digest/GOST.pm
63 %{perl_vendorarch}/Digest/GOST
64 %dir %{perl_vendorarch}/auto/Digest/GOST
65 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/GOST/GOST.so
66 %{_mandir}/man3/Digest::GOST.3pm*
67 %{_mandir}/man3/Digest::GOST::CryptoPro.3pm*
This page took 0.098286 seconds and 4 git commands to generate.