]> git.pld-linux.org Git - packages/perl-Devel-Trace.git/blob - perl-Devel-Trace.spec
- up to 0.11
[packages/perl-Devel-Trace.git] / perl-Devel-Trace.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Devel
7 %define         pnam    Trace
8 Summary:        Devel::Trace - print out each line before it is executed (like `sh -x')
9 Summary(pl.UTF-8):      Devel::Trace - wypisywanie każdej linii przed wykonaniem (jak `sh -x')
10 Name:           perl-Devel-Trace
11 Version:        0.11
12 Release:        1
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1138fe5d16b446dca3d55ccea37d8b96
17 URL:            http://www.plover.com/~mjd/perl/Trace/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 If you run your program with `perl -d:Trace program', this module will
25 print a message to standard error just before each line is executed.
26 This is is something like the shell's `-x' option.
27
28 %description -l pl.UTF-8
29 Jeśli uruchomi się program poprzez `perl -d:Trace program', ten moduł
30 będzie wypisywał na standardowe wyjście diagnostyczne komunikat przed
31 wykonaniem każdej linii. Jest to coś w rodzaju opcji `-x' powłoki.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %{__perl} -pi -e 's@<STDIN>;@#<STDIN>;@' test.pl
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{perl_vendorlib}/Devel/Trace.pm
58 %{_mandir}/man3/*
This page took 0.10115 seconds and 4 git commands to generate.