]> git.pld-linux.org Git - packages/perl-Devel-Trace.git/blob - perl-Devel-Trace.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Devel-Trace.git] / perl-Devel-Trace.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    Trace
7 Summary:        Devel::Trace - print out each line before it is executed (like `sh -x')
8 Summary(pl.UTF-8):      Devel::Trace - wypisywanie każdej linii przed wykonaniem (jak `sh -x')
9 Name:           perl-Devel-Trace
10 Version:        0.11
11 Release:        1
12 License:        unknown
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  1138fe5d16b446dca3d55ccea37d8b96
16 URL:            http://www.plover.com/~mjd/perl/Trace/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 If you run your program with `perl -d:Trace program', this module will
24 print a message to standard error just before each line is executed.
25 This is is something like the shell's `-x' option.
26
27 %description -l pl.UTF-8
28 Jeśli uruchomi się program poprzez `perl -d:Trace program', ten moduł
29 będzie wypisywał na standardowe wyjście diagnostyczne komunikat przed
30 wykonaniem każdej linii. Jest to coś w rodzaju opcji `-x' powłoki.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %{__perl} -pi -e 's@<STDIN>;@#<STDIN>;@' test.pl
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/Devel/Trace.pm
57 %{_mandir}/man3/*
This page took 0.116522 seconds and 4 git commands to generate.