]> git.pld-linux.org Git - packages/perl-Date-Manip.git/blob - perl-Date-Manip.spec
- up to 6.48
[packages/perl-Date-Manip.git] / perl-Date-Manip.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Date
7 %define         pnam    Manip
8 Summary:        Date::Manip - date manipulation routines
9 Summary(pl.UTF-8):      Date::Manip - procedury do operowania na datach
10 Name:           perl-Date-Manip
11 Version:        6.48
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Date/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  fc1629f119072fa723ff89133d6f9a2d
18 URL:            http://search.cpan.org/dist/Date-Manip/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Inter
23 BuildRequires:  perl-YAML-Syck
24 %endif
25 Obsoletes:      perl-DateManip
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Perl module Date::Manip contains a set of routines designed to make
31 any common date/time manipulation easy to do. Operations such as
32 comparing two times, calculating a time a given amount of time from
33 another, or parsing international times are all easily done.
34
35 %description -l pl.UTF-8
36 Moduł Perla Date::Manip zawiera zbiór procedur zaprojektowanych, aby
37 ułatwić często wykonywane operacje na datach/czasie. Operacje takie
38 jak porównywanie dwóch czasów, obliczanie czasu następującego po
39 zadanej ilości czasu od innego czasu, analiza czasów z podaną strefą
40 czasową - wszystkie łatwo wykonać.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Date/{Manip,Manip/*,Manip/Lang/*}.pod
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes LICENSE README.first
66 %attr(755,root,root) %{_bindir}/dm_date
67 %attr(755,root,root) %{_bindir}/dm_zdump
68 %{perl_vendorlib}/Date/Manip.pm
69 %dir %{perl_vendorlib}/Date/Manip
70 %{perl_vendorlib}/Date/Manip/*.pm
71 %dir %{perl_vendorlib}/Date/Manip/Lang
72 %{perl_vendorlib}/Date/Manip/Lang/*.pm
73 %dir %{perl_vendorlib}/Date/Manip/Offset
74 %{perl_vendorlib}/Date/Manip/Offset/*.pm
75 %dir %{perl_vendorlib}/Date/Manip/TZ
76 %{perl_vendorlib}/Date/Manip/TZ/*.pm
77 %{_mandir}/man1/dm_date.1p.gz
78 %{_mandir}/man1/dm_zdump.1p.gz
79 %{_mandir}/man3/Date::Manip*.3pm*
This page took 0.115583 seconds and 4 git commands to generate.