]> git.pld-linux.org Git - packages/perl-Date-Manip.git/blob - perl-Date-Manip.spec
- updated URL and macros
[packages/perl-Date-Manip.git] / perl-Date-Manip.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Date
6 %define         pnam    Manip
7 Summary:        Date::Manip - date manipulation routines
8 Summary(pl.UTF-8):      Date::Manip - procedury do operowania na datach
9 Name:           perl-Date-Manip
10 Version:        6.89
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Date/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f9fe372c7abaf90e9da2ee7c3a4d32ff
17 URL:            https://metacpan.org/dist/Date-Manip
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.30
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Inter
24 BuildRequires:  perl-YAML-Syck
25 %endif
26 Obsoletes:      perl-DateManip
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Perl module Date::Manip contains a set of routines designed to make
32 any common date/time manipulation easy to do. Operations such as
33 comparing two times, calculating a time a given amount of time from
34 another, or parsing international times are all easily done.
35
36 %description -l pl.UTF-8
37 Moduł Perla Date::Manip zawiera zbiór procedur zaprojektowanych, aby
38 ułatwić często wykonywane operacje na datach/czasie. Operacje takie
39 jak porównywanie dwóch czasów, obliczanie czasu następującego po
40 zadanej ilości czasu od innego czasu, analiza czasów z podaną strefą
41 czasową - wszystkie łatwo wykonać.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Date/{Manip,Manip/*,Manip/Lang/*}.pod
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes LICENSE README.first
67 %attr(755,root,root) %{_bindir}/dm_date
68 %attr(755,root,root) %{_bindir}/dm_zdump
69 %{perl_vendorlib}/Date/Manip.pm
70 %dir %{perl_vendorlib}/Date/Manip
71 %{perl_vendorlib}/Date/Manip/*.pm
72 %dir %{perl_vendorlib}/Date/Manip/Lang
73 %{perl_vendorlib}/Date/Manip/Lang/*.pm
74 %dir %{perl_vendorlib}/Date/Manip/Offset
75 %{perl_vendorlib}/Date/Manip/Offset/*.pm
76 %dir %{perl_vendorlib}/Date/Manip/TZ
77 %{perl_vendorlib}/Date/Manip/TZ/*.pm
78 %{_mandir}/man1/dm_date.1*
79 %{_mandir}/man1/dm_zdump.1*
80 %{_mandir}/man3/Date::Manip*.3pm*
This page took 0.190294 seconds and 4 git commands to generate.