]> git.pld-linux.org Git - packages/perl-Crypt-SSLeay.git/blob - perl-Crypt-SSLeay.spec
perl 5.36.0 rebuild
[packages/perl-Crypt-SSLeay.git] / perl-Crypt-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    SSLeay
7 Summary:        Crypt::SSLeay - OpenSSL glue that provides LWP HTTPS support
8 Summary(cs.UTF-8):      Crypt::SSLeay - spojení OpenSSL, které poskytuje podporu HTTPS pro LWP
9 Summary(da.UTF-8):      Crypt::SSLeay - OpenSSL-klister som giver understøttelse for LWP HTTPS
10 Summary(de.UTF-8):      Crypt::SSLeay - OpenSSL Elemente für LWP HTTPS Support
11 Summary(es.UTF-8):      Crypt::SSLeay - Enlace OpenSSL que proporciona soporte HTTPS LWP
12 Summary(fr.UTF-8):      Crypt::SSLeay - colle OpenSSL fournissant une prise en charge LWP HTTPS
13 Summary(it.UTF-8):      Crypt::SSLeay - OpenSSL glue che fornisce supporto per LWP HTTPS
14 Summary(ja.UTF-8):      Crypt::SSLeay - LWP HTTPSのサポートを提供するOpenSSL glue
15 Summary(ko.UTF-8):      Crypt::SSLeay - LWP HTTPS 지원을 제공하는 OpenSSL 접착(glue) 입니다
16 Summary(pl.UTF-8):      Crypt::SSLeay - obsługa HTTPS dla LWP przez połączenie z OpenSSL
17 Summary(pt.UTF-8):      Crypt::SSLeay - a interface de OpenSSL que oferece o suporte em LWP de HTTPS
18 Summary(pt_BR.UTF-8):   Crypt::SSLeay - a interface de OpenSSL que oferece o suporte em LWP de HTTPS
19 Summary(sv.UTF-8):      Crypt::SSLeay - OpenSSL-klister som gör stöd för LWP HTTPS
20 Summary(tr.UTF-8):      Crypt::SSLeay - LWP HTTPS desteği sağlayan OpenSSL bağlantısı
21 Summary(zh_CN.UTF-8):   Crypt::SSLeay - 提供 LWP HTTPS 支持的 OpenSSL 胶水
22 Summary(zh_TW.UTF-8):   Crypt::SSLeay - 提供 LWP HTTPS 支援的 OpenSSL glue。
23 Name:           perl-Crypt-SSLeay
24 Version:        0.72
25 Release:        15
26 # same as perl
27 License:        GPL v1+ or Artistic
28 Group:          Development/Languages/Perl
29 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
30 # Source0-md5:  77d955c9056dbb12413d95d8852a9cdf
31 Patch0:         no-dot-in-inc.patch
32 Patch1:         openssl.patch
33 URL:            http://search.cpan.org/dist/Crypt-SSLeay/
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  perl-ExtUtils-CBuilder >= 0.280205
36 BuildRequires:  perl-Path-Class >= 0.35
37 %if %{with tests}
38 BuildRequires:  perl-Test-Simple >= 0.88
39 BuildRequires:  perl-Try-Tiny >= 0.19
40 %endif
41 BuildRequires:  perl-devel >= 1:5.8.0
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 Conflicts:      perl-LWP-Protocol-https < 6.02
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 This perl module provides support for the HTTPS protocol under LWP,
48 so that a LWP::UserAgent can make HTTPS GET & HEAD & POST requests.
49
50 The Crypt::SSLeay package contains Net::SSL, which is automatically
51 loaded by LWP::Protocol::https on HTTPS requests, and provides the
52 necessary SSL glue for that module to work.
53
54 %description -l cs.UTF-8
55 Tento modul Perlu nabízí podporu pro protokol HTTPS pod LWP, takže
56 LWP::UserAgent může provádět HTTPS požadavky GET & HEAD & POST. Pro
57 informace o požadavcích POST si prosím přečtěte perldoc LWP.
58
59 Balíček Crypt::SSLeay obsahuje Net::SSL, který je automaticky nahrán
60 LWP::Protocol::https při požadavcích HTTPS, a nabízí potřebné spojení
61 SSL, aby tento modul fungoval.
62
63 %description -l da.UTF-8
64 Dette perlmodul giver understøttelse for protokollen HTTPS under LWP,
65 så en LWP::UserAgent kan lave HTTPS-forespørgslerne GET & HEAD & POST.
66 Se perldoc LWP for mere information om POST-forespørgsler.
67
68 Pakken Crypt::SSLeay indeholder Net::SSL som automatisk læses ind af
69 LWP::Protocol::https ved HTTPS-forespørgsler, og giver det nødvendige
70 SSL-klister til at det modul kan fungere.
71
72 %description -l de.UTF-8
73 Dieses Perl-Modul liefert Support für das HTTPS-Protokoll unter LWP,
74 so dass ein LWP::UserAgent HTTPS GET & HEAD & POST Anfragen ausführen
75 kann. Weitere Informationen über POST-Anfragen sindin perldoc LWP
76 enthalten.
77
78 Das Crypt::SSLeay Paket enthält Net::SSL, das bei HTTPS-Anfragen
79 automatisch von LWP::Protocol::https geladen wird, und bietet die
80 erforderlichen SSL-Elemente für das Modul.
81
82 %description -l es.UTF-8
83 Este módulo perl proporciona soporte para el protocolo HTTPS bajo LWP,
84 de manera que LWP::UserAgent pueda crear peticiones GET & HEAD & POST.
85 Consulte perldoc LWP para más información sobre las peticiones POST.
86
87 El paquete Crypt::SSLeay contiene Net::SSL, que se descarga
88 automáticamente por LWP::Protocol::https en las peticiones HTTPS y
89 proporciona los elementos necesarios SSL para que funcione el módulo.
90
91 %description -l fr.UTF-8
92 Le module perl fournit un support pour le protocole HTTPS sous LWP, de
93 manière à ce qu'un LWP::UserAgent puisse exécuter les requêtes GET &
94 HEAD & POST. Veuillez consulter perldoc LWP pour obtenir de plus
95 amples informations concernant les requêtes POST.
96
97 Le paquetage Crypt::SSLeay contient Net::SSL, qui est chargé
98 automatiquement par LWP::Protocol::https sur les requêtes HTTPS, et
99 fournit la colle SSL nécessaire pour faire fonctionner ce module.
100
101 %description -l it.UTF-8
102 Questo modulo di perl supporta il protocollo HTTPS in LWP, in modo che
103 un LWP::UserAgent possa effettuare richieste GET & HEAD & POST HTTP.
104 Consultare perldoc LWP per ulteriori informazioni sulle richieste
105 POST.
106
107 Il pacchetto Crypt::SSLeay contiene Net::SSL, che viene caricato
108 automaticamente da LWP::Protocol::https sulle richieste HTTP e
109 fornisce la colla SSL necessaria per far funzionare quel modulo.
110
111 %description -l ja.UTF-8
112 この perlモジュールは、LWPの元でHTTPSプロトコル用のサポートを提供しま
113 す。ですから、LWP::UserAgent は HTTPS GET & HEAD & POSTリクエストを
114 作成できます。 POSTリクエストの詳細については perldoc LWPを
115 御覧下さい。 理 末スト Crypt::SSLeayパッケージには、hリクエストにより
116 LWP::Protocol::https で自動的にロードされるNet::SSLを含んでいます。そ
117 して、モジュールが動作するよう に 必要なSSL glueを提供します。
118
119 %description -l ko.UTF-8
120 이 perl 모듈은 LWP::UserAgent가 HTTPS GET, HEAD, POST 요청을 생성할 수
121 있도록 LWP 하에서 HTTPS 프로토콜에 대한 지원을 제공합니다. POST 요청에
122 대한 보다 많은 정보를 원하시면, perldoc LWP를 참조하시기 바랍니다.
123
124 Crypt::SSLeay 패키지에는 HTTPS 요청에 따라 LWP::Protocol::https에 의해
125 자동으로 로딩되는 Net::SSL가 포함되어 있으며, 해당 모듈이 작동하는데
126 필요한 SSL 접착 (glue)을 제공합니다.
127
128 %description -l pl.UTF-8
129 Ten moduł Perla dostarcza obsługę protokołu HTTPS dla LWP, dzięki
130 czemu LWP::UserAgent może wykonywać zapytania GET i POST po HTTPS.
131
132 Pakiet Crypt::SSLeay zawiera moduł Net::SSL, automatycznie ładowany
133 przez LWP::Protocol::https w przypadku zapytań HTTPS, oraz dostarcza
134 niezbędnych do jego działania składników.
135
136 %description -l pt.UTF-8
137 Este módulo de Perl providencia o suporte para o protocolo HTTP em
138 LWP, de modo a que um LWP::UserAgent possa fazer pedidos de HTTPS de
139 GET & HEAD & POST. Veja o LWP do 'perldoc' para mais informações sobre
140 os pedidos de POST.
141
142 O pacote Crypt::SSLeay contém o Net::SSL, que é carregado
143 automaticamente pelo LWP::Protocol::https nos pedidos de HTTPS, e que
144 fornece a lógica de interacção com o SSL necessária para o módulo
145 funcionar.
146
147 %description -l pt_BR.UTF-8
148 Este módulo de Perl providencia o suporte para o protocolo HTTP em
149 LWP, de modo a que um LWP::UserAgent possa fazer pedidos de HTTPS de
150 GET & HEAD & POST. Veja o LWP do 'perldoc' para mais informações sobre
151 os pedidos de POST.
152
153 O pacote Crypt::SSLeay contém o Net::SSL, que é carregado
154 automaticamente pelo LWP::Protocol::https nos pedidos de HTTPS, e que
155 fornece a lógica de interacção com o SSL necessária para o módulo
156 funcionar.
157
158 %description -l sv.UTF-8
159 Denna perlmodul ger stöd för protokollet HTTPS under LWP, så att en
160 LWP::UserAgent kan göra HTTPS-begäran GET & HEAD & POST.  Se perldoc
161 LWP för mer information om POST-begäran.
162
163 Paketet Crypt::SSLeay innehåller Net::SSL som automatiskt läses in av
164 LWP::Protocol::https vid HTTPS-begäran, och ger det nödvändiga
165 SSL-klistret för att den mudulen skall fungera.
166
167 %description -l zh_CN.UTF-8
168 该 Perl 模块提供对 LWP 下的 HTTPS 协议的支持,因此
169  LWP::UserAgent 能够进行HTTPS GET & HEAD & POST
170 请求。请参阅 perldoc LWP 来获取关于 POST 请求的详
171 细信息。
172
173 Crypt::SSLeay 软件包包含 Net::SSL(它在 HTTPS 请求时
174 被 LWP::Protocol::https 自动载入),并且为该模块的运行
175 提供了必要的 SSL 胶水。
176
177 %prep
178 %setup -q -n %{pdir}-%{pnam}-%{version}
179 %patch0 -p1
180 %patch1 -p1
181
182 %build
183 yes "" | %{__perl} Makefile.PL \
184         INSTALLDIRS=vendor
185 %{__make} \
186         CC="%{__cc}" \
187         OPTIMIZE="%{rpmcflags}"
188
189 %{?with_tests:%{__make} test}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193
194 %{__make} install \
195         DESTDIR=$RPM_BUILD_ROOT
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %files
201 %defattr(644,root,root,755)
202 %doc Changes TODO
203 %{perl_vendorarch}/Crypt/SSLeay.pm
204 %{perl_vendorarch}/Crypt/SSLeay
205 %{perl_vendorarch}/Net/SSL.pm
206 %dir %{perl_vendorarch}/auto/Crypt/SSLeay
207 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/SSLeay/SSLeay.so
208 %{_mandir}/man3/Crypt::SSLeay*.3pm*
209 %{_mandir}/man3/Net::SSL.3pm*
This page took 0.085143 seconds and 3 git commands to generate.