]> git.pld-linux.org Git - packages/perl-Crypt-SSLeay.git/blob - perl-Crypt-SSLeay.spec
- macros for perl macros included
[packages/perl-Crypt-SSLeay.git] / perl-Crypt-SSLeay.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    SSLeay
7 Summary:        Crypt::SSLeay - OpenSSL glue that provides LWP HTTPS support
8 Summary(cs.UTF-8):      Crypt::SSLeay - spojení OpenSSL, které poskytuje podporu HTTPS pro LWP
9 Summary(da.UTF-8):      Crypt::SSLeay - OpenSSL-klister som giver understøttelse for LWP HTTPS
10 Summary(de.UTF-8):      Crypt::SSLeay - OpenSSL Elemente für LWP HTTPS Support
11 Summary(es.UTF-8):      Crypt::SSLeay - Enlace OpenSSL que proporciona soporte HTTPS LWP
12 Summary(fr.UTF-8):      Crypt::SSLeay - colle OpenSSL fournissant une prise en charge LWP HTTPS
13 Summary(it.UTF-8):      Crypt::SSLeay - OpenSSL glue che fornisce supporto per LWP HTTPS
14 Summary(ja.UTF-8):      Crypt::SSLeay - LWP HTTPSのサポートを提供するOpenSSL glue
15 Summary(ko.UTF-8):      Crypt::SSLeay - LWP HTTPS 지원을 제공하는 OpenSSL 접착(glue) 입니다
16 Summary(pl.UTF-8):      Crypt::SSLeay - obsługa HTTPS dla LWP przez połączenie z OpenSSL
17 Summary(pt.UTF-8):      Crypt::SSLeay - a interface de OpenSSL que oferece o suporte em LWP de HTTPS
18 Summary(pt_BR.UTF-8):   Crypt::SSLeay - a interface de OpenSSL que oferece o suporte em LWP de HTTPS
19 Summary(sv.UTF-8):      Crypt::SSLeay - OpenSSL-klister som gör stöd för LWP HTTPS
20 Summary(tr.UTF-8):      Crypt::SSLeay - LWP HTTPS desteği sağlayan OpenSSL bağlantısı
21 Summary(zh_CN.UTF-8):   Crypt::SSLeay - 提供 LWP HTTPS 支持的 OpenSSL 胶水
22 Summary(zh_TW.UTF-8):   Crypt::SSLeay - 提供 LWP HTTPS 支援的 OpenSSL glue。
23 Name:           perl-Crypt-SSLeay
24 Version:        0.72
25 Release:        16
26 # same as perl
27 License:        GPL v1+ or Artistic
28 Group:          Development/Languages/Perl
29 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
30 # Source0-md5:  77d955c9056dbb12413d95d8852a9cdf
31 Patch0:         no-dot-in-inc.patch
32 Patch1:         openssl.patch
33 URL:            http://search.cpan.org/dist/Crypt-SSLeay/
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  perl-ExtUtils-CBuilder >= 0.280205
36 BuildRequires:  perl-Path-Class >= 0.35
37 %if %{with tests}
38 BuildRequires:  perl-Test-Simple >= 0.88
39 BuildRequires:  perl-Try-Tiny >= 0.19
40 %endif
41 BuildRequires:  perl-devel >= 1:5.8.0
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 BuildRequires:  rpmbuild(macros) >= 1.745
44 Conflicts:      perl-LWP-Protocol-https < 6.02
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 This perl module provides support for the HTTPS protocol under LWP,
49 so that a LWP::UserAgent can make HTTPS GET & HEAD & POST requests.
50
51 The Crypt::SSLeay package contains Net::SSL, which is automatically
52 loaded by LWP::Protocol::https on HTTPS requests, and provides the
53 necessary SSL glue for that module to work.
54
55 %description -l cs.UTF-8
56 Tento modul Perlu nabízí podporu pro protokol HTTPS pod LWP, takže
57 LWP::UserAgent může provádět HTTPS požadavky GET & HEAD & POST. Pro
58 informace o požadavcích POST si prosím přečtěte perldoc LWP.
59
60 Balíček Crypt::SSLeay obsahuje Net::SSL, který je automaticky nahrán
61 LWP::Protocol::https při požadavcích HTTPS, a nabízí potřebné spojení
62 SSL, aby tento modul fungoval.
63
64 %description -l da.UTF-8
65 Dette perlmodul giver understøttelse for protokollen HTTPS under LWP,
66 så en LWP::UserAgent kan lave HTTPS-forespørgslerne GET & HEAD & POST.
67 Se perldoc LWP for mere information om POST-forespørgsler.
68
69 Pakken Crypt::SSLeay indeholder Net::SSL som automatisk læses ind af
70 LWP::Protocol::https ved HTTPS-forespørgsler, og giver det nødvendige
71 SSL-klister til at det modul kan fungere.
72
73 %description -l de.UTF-8
74 Dieses Perl-Modul liefert Support für das HTTPS-Protokoll unter LWP,
75 so dass ein LWP::UserAgent HTTPS GET & HEAD & POST Anfragen ausführen
76 kann. Weitere Informationen über POST-Anfragen sindin perldoc LWP
77 enthalten.
78
79 Das Crypt::SSLeay Paket enthält Net::SSL, das bei HTTPS-Anfragen
80 automatisch von LWP::Protocol::https geladen wird, und bietet die
81 erforderlichen SSL-Elemente für das Modul.
82
83 %description -l es.UTF-8
84 Este módulo perl proporciona soporte para el protocolo HTTPS bajo LWP,
85 de manera que LWP::UserAgent pueda crear peticiones GET & HEAD & POST.
86 Consulte perldoc LWP para más información sobre las peticiones POST.
87
88 El paquete Crypt::SSLeay contiene Net::SSL, que se descarga
89 automáticamente por LWP::Protocol::https en las peticiones HTTPS y
90 proporciona los elementos necesarios SSL para que funcione el módulo.
91
92 %description -l fr.UTF-8
93 Le module perl fournit un support pour le protocole HTTPS sous LWP, de
94 manière à ce qu'un LWP::UserAgent puisse exécuter les requêtes GET &
95 HEAD & POST. Veuillez consulter perldoc LWP pour obtenir de plus
96 amples informations concernant les requêtes POST.
97
98 Le paquetage Crypt::SSLeay contient Net::SSL, qui est chargé
99 automatiquement par LWP::Protocol::https sur les requêtes HTTPS, et
100 fournit la colle SSL nécessaire pour faire fonctionner ce module.
101
102 %description -l it.UTF-8
103 Questo modulo di perl supporta il protocollo HTTPS in LWP, in modo che
104 un LWP::UserAgent possa effettuare richieste GET & HEAD & POST HTTP.
105 Consultare perldoc LWP per ulteriori informazioni sulle richieste
106 POST.
107
108 Il pacchetto Crypt::SSLeay contiene Net::SSL, che viene caricato
109 automaticamente da LWP::Protocol::https sulle richieste HTTP e
110 fornisce la colla SSL necessaria per far funzionare quel modulo.
111
112 %description -l ja.UTF-8
113 この perlモジュールは、LWPの元でHTTPSプロトコル用のサポートを提供しま
114 す。ですから、LWP::UserAgent は HTTPS GET & HEAD & POSTリクエストを
115 作成できます。 POSTリクエストの詳細については perldoc LWPを
116 御覧下さい。 理 末スト Crypt::SSLeayパッケージには、hリクエストにより
117 LWP::Protocol::https で自動的にロードされるNet::SSLを含んでいます。そ
118 して、モジュールが動作するよう に 必要なSSL glueを提供します。
119
120 %description -l ko.UTF-8
121 이 perl 모듈은 LWP::UserAgent가 HTTPS GET, HEAD, POST 요청을 생성할 수
122 있도록 LWP 하에서 HTTPS 프로토콜에 대한 지원을 제공합니다. POST 요청에
123 대한 보다 많은 정보를 원하시면, perldoc LWP를 참조하시기 바랍니다.
124
125 Crypt::SSLeay 패키지에는 HTTPS 요청에 따라 LWP::Protocol::https에 의해
126 자동으로 로딩되는 Net::SSL가 포함되어 있으며, 해당 모듈이 작동하는데
127 필요한 SSL 접착 (glue)을 제공합니다.
128
129 %description -l pl.UTF-8
130 Ten moduł Perla dostarcza obsługę protokołu HTTPS dla LWP, dzięki
131 czemu LWP::UserAgent może wykonywać zapytania GET i POST po HTTPS.
132
133 Pakiet Crypt::SSLeay zawiera moduł Net::SSL, automatycznie ładowany
134 przez LWP::Protocol::https w przypadku zapytań HTTPS, oraz dostarcza
135 niezbędnych do jego działania składników.
136
137 %description -l pt.UTF-8
138 Este módulo de Perl providencia o suporte para o protocolo HTTP em
139 LWP, de modo a que um LWP::UserAgent possa fazer pedidos de HTTPS de
140 GET & HEAD & POST. Veja o LWP do 'perldoc' para mais informações sobre
141 os pedidos de POST.
142
143 O pacote Crypt::SSLeay contém o Net::SSL, que é carregado
144 automaticamente pelo LWP::Protocol::https nos pedidos de HTTPS, e que
145 fornece a lógica de interacção com o SSL necessária para o módulo
146 funcionar.
147
148 %description -l pt_BR.UTF-8
149 Este módulo de Perl providencia o suporte para o protocolo HTTP em
150 LWP, de modo a que um LWP::UserAgent possa fazer pedidos de HTTPS de
151 GET & HEAD & POST. Veja o LWP do 'perldoc' para mais informações sobre
152 os pedidos de POST.
153
154 O pacote Crypt::SSLeay contém o Net::SSL, que é carregado
155 automaticamente pelo LWP::Protocol::https nos pedidos de HTTPS, e que
156 fornece a lógica de interacção com o SSL necessária para o módulo
157 funcionar.
158
159 %description -l sv.UTF-8
160 Denna perlmodul ger stöd för protokollet HTTPS under LWP, så att en
161 LWP::UserAgent kan göra HTTPS-begäran GET & HEAD & POST.  Se perldoc
162 LWP för mer information om POST-begäran.
163
164 Paketet Crypt::SSLeay innehåller Net::SSL som automatiskt läses in av
165 LWP::Protocol::https vid HTTPS-begäran, och ger det nödvändiga
166 SSL-klistret för att den mudulen skall fungera.
167
168 %description -l zh_CN.UTF-8
169 该 Perl 模块提供对 LWP 下的 HTTPS 协议的支持,因此
170  LWP::UserAgent 能够进行HTTPS GET & HEAD & POST
171 请求。请参阅 perldoc LWP 来获取关于 POST 请求的详
172 细信息。
173
174 Crypt::SSLeay 软件包包含 Net::SSL(它在 HTTPS 请求时
175 被 LWP::Protocol::https 自动载入),并且为该模块的运行
176 提供了必要的 SSL 胶水。
177
178 %prep
179 %setup -q -n %{pdir}-%{pnam}-%{version}
180 %patch0 -p1
181 %patch1 -p1
182
183 %build
184 yes "" | %{__perl} Makefile.PL \
185         INSTALLDIRS=vendor
186 %{__make} \
187         CC="%{__cc}" \
188         OPTIMIZE="%{rpmcflags}"
189
190 %{?with_tests:%{__make} test}
191
192 %install
193 rm -rf $RPM_BUILD_ROOT
194
195 %{__make} install \
196         DESTDIR=$RPM_BUILD_ROOT
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %files
202 %defattr(644,root,root,755)
203 %doc Changes TODO
204 %{perl_vendorarch}/Crypt/SSLeay.pm
205 %{perl_vendorarch}/Crypt/SSLeay
206 %{perl_vendorarch}/Net/SSL.pm
207 %dir %{perl_vendorarch}/auto/Crypt/SSLeay
208 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/SSLeay/SSLeay.so
209 %{_mandir}/man3/Crypt::SSLeay*.3pm*
210 %{_mandir}/man3/Net::SSL.3pm*
This page took 0.17926 seconds and 4 git commands to generate.