]> git.pld-linux.org Git - packages/perl-Crypt-RIPEMD160.git/blob - perl-Crypt-RIPEMD160.spec
- add CC to %{__make}
[packages/perl-Crypt-RIPEMD160.git] / perl-Crypt-RIPEMD160.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    RIPEMD160
8 Summary:        Crypt::RIPEMD160 Perl module - RIPEMD160 message digest algorithm
9 Summary(pl.UTF-8):      Moduł Perla Crypt::RIPEMD160 - algorytm skrótu RIPEMD160
10 Name:           perl-Crypt-RIPEMD160
11 Version:        0.04
12 Release:        5
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  132c1b74deabd6511726945373308699
18 Patch0:         %{name}-types.patch
19 URL:            http://search.cpan.org/dist/Crypt-RIPEMD160/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Crypt::RIPEMD160 module allows you to use the RIPEMD160 Message
26 Digest algorithm from within Perl programs. RIPEMD-160 is a 160-bit
27 cryptographic hash function, designed by Hans Dobbertin, Antoon
28 Bosselaers, and Bart Preneel. It is intended to be used as a secure
29 replacement for the 128-bit hash functions MD4, MD5, and RIPEMD.
30
31 %description -l pl.UTF-8
32 Moduł Crypt::RIPEMD160 pozwala na używanie algorytmu skrótu RIPEMD160
33 z poziomu programów w Perlu. RIPEMD-160 jest 160-bitową
34 kryptograficzną funkcją mieszającą, opracowaną przez Hansa Dobbertina,
35 Antoona Bosselaersa i Barta Preneela. Ma być bezpiecznym zamiennikiem
36 128-bitowych funkcji mieszających MD4, MD5 i RIPEMD.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README rmd160/doc/*.html
63 %{perl_vendorarch}/Crypt/RIPEMD160.pm
64 %{perl_vendorarch}/Crypt/RIPEMD160
65 %dir %{perl_vendorarch}/auto/Crypt/RIPEMD160
66 %{perl_vendorarch}/auto/Crypt/RIPEMD160/autosplit.ix
67 %{perl_vendorarch}/auto/Crypt/RIPEMD160/*.bs
68 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/RIPEMD160/*.so
69 %{_mandir}/man3/*
This page took 0.075505 seconds and 3 git commands to generate.