]> git.pld-linux.org Git - packages/perl-Crypt-RIPEMD160.git/blob - perl-Crypt-RIPEMD160.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-RIPEMD160.git] / perl-Crypt-RIPEMD160.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    RIPEMD160
7 Summary:        Crypt::RIPEMD160 Perl module - RIPEMD160 message digest algorithm
8 Summary(pl.UTF-8):      Moduł Perla Crypt::RIPEMD160 - algorytm skrótu RIPEMD160
9 Name:           perl-Crypt-RIPEMD160
10 Version:        0.06
11 Release:        6
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f37eae17af81b230104f9d0aca1b2327
17 Patch0:         %{name}-types.patch
18 URL:            http://search.cpan.org/dist/Crypt-RIPEMD160/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Crypt::RIPEMD160 module allows you to use the RIPEMD160 Message
25 Digest algorithm from within Perl programs. RIPEMD-160 is a 160-bit
26 cryptographic hash function, designed by Hans Dobbertin, Antoon
27 Bosselaers, and Bart Preneel. It is intended to be used as a secure
28 replacement for the 128-bit hash functions MD4, MD5, and RIPEMD.
29
30 %description -l pl.UTF-8
31 Moduł Crypt::RIPEMD160 pozwala na używanie algorytmu skrótu RIPEMD160
32 z poziomu programów w Perlu. RIPEMD-160 jest 160-bitową
33 kryptograficzną funkcją mieszającą, opracowaną przez Hansa Dobbertina,
34 Antoona Bosselaersa i Barta Preneela. Ma być bezpiecznym zamiennikiem
35 128-bitowych funkcji mieszających MD4, MD5 i RIPEMD.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README rmd160/doc/*.html
62 %{perl_vendorarch}/Crypt/RIPEMD160.pm
63 %{perl_vendorarch}/Crypt/RIPEMD160
64 %dir %{perl_vendorarch}/auto/Crypt/RIPEMD160
65 %{perl_vendorarch}/auto/Crypt/RIPEMD160/autosplit.ix
66 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/RIPEMD160/*.so
67 %{_mandir}/man3/*
This page took 0.302287 seconds and 4 git commands to generate.