]> git.pld-linux.org Git - packages/perl-Crypt-RC6.git/blob - perl-Crypt-RC6.spec
- rel. 3
[packages/perl-Crypt-RC6.git] / perl-Crypt-RC6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    RC6
8 Summary:        Crypt::RC6 Perl module - RC6 block cipher encryption
9 Summary(pl):    Modu³ Perla Crypt::RC6 - szyfr blokowy RC6
10 Name:           perl-Crypt-RC6
11 Version:        1.0
12 Release:        3
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6cd523b2ebfea33c66fc5f4252e88ce7
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Crypt::CBC compliant RC6 block cipher encryption module. RC6 is an
23 evolutionary improvement of RC5, designed to meet the requirements of
24 the Advanced Encryption Standard (AES). This implementation requires
25 the use of a 16-, 24-, or 32-byte key and 16-byte blocks for
26 encryption/decryption. Twenty rounds are performed.
27
28 %description -l pl
29 Modu³ jest zgodn± z Crypt::CBC implementacj± szyfru blokowego RC6. RC6
30 jest ewolucyjnym rozszerzeniem RC5, opracowanym na potrzeby AES
31 (Advanced Security Standard - standardu zaawansowanego
32 bezpieczeñstwa). Ta implementacja wymaga u¿ycia 16, 24, lub
33 32-bajtowego klucza i 16-bajtowych bloków do kodowania i dekodowania.
34 Wykonywane jest dwadzie¶cia kroków.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc CHANGES README
59 %{perl_vendorarch}/Crypt/RC6.pm
60 %dir %{perl_vendorarch}/auto/Crypt/RC6
61 %{perl_vendorarch}/auto/Crypt/RC6/*.bs
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/RC6/*.so
63 %{_mandir}/man3/*
This page took 0.043417 seconds and 4 git commands to generate.