]> git.pld-linux.org Git - packages/perl-Crypt-MySQL.git/blob - perl-Crypt-MySQL.spec
- new bconds
[packages/perl-Crypt-MySQL.git] / perl-Crypt-MySQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Crypt
7 %define pnam    MySQL
8 Summary:        Crypt::MySQL - emulate MySQL PASSWORD() function
9 Summary(pl):    Crypt::MySQL - emulacja funkcji MySQL PASSWORD()
10 Name:           perl-Crypt-MySQL
11 Version:        0.02
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  dfaf418d37f4f690f8e69a2e03e74371
18 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.32}
19 BuildRequires:  perl-devel >= 5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Crypt::MySQL emulates MySQL PASSWORD() SQL function, without
25 libmysqlclient. You can compare encrypted passwords, without real
26 MySQL environment.
27
28 %description -l pl
29 Crypt::MySQL emuluje funkcjê SQL PASSWORD() z MySQL bez
30 libmysqlclient. Pozwala porównywaæ zaszyfrowane has³a bez prawdziwego
31 ¶rodowiska MySQL.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39
40 %{__make} OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorarch}/Crypt/MySQL.pm
57 %dir %{perl_vendorarch}/auto/Crypt/MySQL
58 %{perl_vendorarch}/auto/Crypt/MySQL/autosplit.ix
59 %{perl_vendorarch}/auto/Crypt/MySQL/MySQL.bs
60 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/MySQL/MySQL.so
61 %{_mandir}/man3/*
This page took 0.064942 seconds and 3 git commands to generate.