]> git.pld-linux.org Git - packages/perl-Crypt-MySQL.git/blob - perl-Crypt-MySQL.spec
perl 5.38.0 rebuild
[packages/perl-Crypt-MySQL.git] / perl-Crypt-MySQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    MySQL
7 Summary:        Crypt::MySQL - emulate MySQL PASSWORD() function
8 Summary(pl.UTF-8):      Crypt::MySQL - emulacja funkcji MySQL PASSWORD()
9 Name:           perl-Crypt-MySQL
10 Version:        0.04
11 Release:        16
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e9a2d1e7f478fe8c90a15c47de37c0ae
17 URL:            http://search.cpan.org/dist/Crypt-MySQL/
18 %if %{with tests}
19 BuildRequires:  perl-DBD-mysql
20 BuildRequires:  perl-Digest-SHA1
21 BuildRequires:  perl-Test-Simple >= 0.32}
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Crypt::MySQL emulates MySQL PASSWORD() SQL function, without
29 libmysqlclient. You can compare encrypted passwords, without real
30 MySQL environment.
31
32 %description -l pl.UTF-8
33 Crypt::MySQL emuluje funkcję SQL PASSWORD() z MySQL bez
34 libmysqlclient. Pozwala porównywać zaszyfrowane hasła bez prawdziwego
35 środowiska MySQL.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorarch}/Crypt/MySQL.pm
62 %{perl_vendorarch}/Crypt/MySQL.xs
63 %dir %{perl_vendorarch}/auto/Crypt/MySQL
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/MySQL/MySQL.so
65 %{_mandir}/man3/*
This page took 0.066116 seconds and 4 git commands to generate.