]> git.pld-linux.org Git - packages/perl-Crypt-MySQL.git/blob - perl-Crypt-MySQL.spec
- release 2
[packages/perl-Crypt-MySQL.git] / perl-Crypt-MySQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    MySQL
8 Summary:        Crypt::MySQL - emulate MySQL PASSWORD() function
9 Summary(pl.UTF-8):      Crypt::MySQL - emulacja funkcji MySQL PASSWORD()
10 Name:           perl-Crypt-MySQL
11 Version:        0.04
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e9a2d1e7f478fe8c90a15c47de37c0ae
18 URL:            http://search.cpan.org/dist/Crypt-MySQL/
19 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.32}
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Crypt::MySQL emulates MySQL PASSWORD() SQL function, without
26 libmysqlclient. You can compare encrypted passwords, without real
27 MySQL environment.
28
29 %description -l pl.UTF-8
30 Crypt::MySQL emuluje funkcję SQL PASSWORD() z MySQL bez
31 libmysqlclient. Pozwala porównywać zaszyfrowane hasła bez prawdziwego
32 środowiska MySQL.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes
58 %{perl_vendorarch}/Crypt/MySQL.pm
59 %{perl_vendorarch}/Crypt/MySQL.xs
60 %dir %{perl_vendorarch}/auto/Crypt/MySQL
61 %{perl_vendorarch}/auto/Crypt/MySQL/MySQL.bs
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/MySQL/MySQL.so
63 %{_mandir}/man3/*
This page took 0.056155 seconds and 3 git commands to generate.