]> git.pld-linux.org Git - packages/openssh.git/blob - openssh.spec
- 5.4 partial update
[packages/openssh.git] / openssh.spec
1 # Conditional build:
2 %bcond_with     gnome           # with gnome-askpass (GNOME 1.x) utility
3 %bcond_without  gtk             # without GTK+ (2.x)
4 %bcond_without  ldap            # with ldap support
5 %bcond_without  libedit         # without libedit (editline/history support in sftp client)
6 %bcond_without  kerberos5       # without kerberos5 support
7 %bcond_without  selinux         # build without SELinux support
8 %bcond_with     hpn             # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
9
10 # gtk2-based gnome-askpass means no gnome1-based
11 %{?with_gtk:%undefine with_gnome}
12
13 Summary:        OpenSSH free Secure Shell (SSH) implementation
14 Summary(de.UTF-8):      OpenSSH - freie Implementation der Secure Shell (SSH)
15 Summary(es.UTF-8):      Implementación libre de SSH
16 Summary(fr.UTF-8):      Implémentation libre du shell sécurisé OpenSSH (SSH)
17 Summary(it.UTF-8):      Implementazione gratuita OpenSSH della Secure Shell
18 Summary(pl.UTF-8):      Publicznie dostępna implementacja bezpiecznego shella (SSH)
19 Summary(pt.UTF-8):      Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
20 Summary(pt_BR.UTF-8):   Implementação livre do SSH
21 Summary(ru.UTF-8):      OpenSSH - свободная реализация протокола Secure Shell (SSH)
22 Summary(uk.UTF-8):      OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
23 Name:           openssh
24 Version:        5.4p1
25 Release:        1
26 Epoch:          2
27 License:        BSD
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
30 # Source0-md5:  da10af8a789fa2e83e3635f3a1b76f5e
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  66943d481cc422512b537bcc2c7400d1
33 Source2:        %{name}d.init
34 Source3:        %{name}d.pamd
35 Source4:        %{name}.sysconfig
36 Source5:        ssh-agent.sh
37 Source6:        ssh-agent.conf
38 Source7:        %{name}-lpk.schema
39 Patch0:         %{name}-no_libnsl.patch
40 Patch2:         %{name}-pam_misc.patch
41 Patch3:         %{name}-sigpipe.patch
42 # http://code.google.com/p/openssh-lpk/
43 Patch4:         %{name}-lpk.patch
44 Patch5:         %{name}-config.patch
45 Patch7:         %{name}-selinux.patch
46 # High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
47 # http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
48 Patch9:         %{name}-5.2p1-hpn13v6.diff
49 Patch10:        %{name}-include.patch
50 Patch11:        %{name}-chroot.patch
51 # http://people.debian.org/~cjwatson/%{name}-blacklist.diff
52 Patch12:        %{name}-blacklist.diff
53 URL:            http://www.openssh.com/
54 BuildRequires:  %{__perl}
55 BuildRequires:  autoconf
56 BuildRequires:  automake
57 %{?with_gnome:BuildRequires:    gnome-libs-devel}
58 %{?with_gtk:BuildRequires:      gtk+2-devel}
59 %{?with_kerberos5:BuildRequires:        heimdal-devel >= 0.7}
60 %{?with_libedit:BuildRequires:  libedit-devel}
61 %{?with_selinux:BuildRequires:  libselinux-devel}
62 BuildRequires:  libwrap-devel
63 %{?with_ldap:BuildRequires:     openldap-devel}
64 BuildRequires:  openssl-devel >= 0.9.7d
65 BuildRequires:  pam-devel
66 %{?with_gtk:BuildRequires:      pkgconfig}
67 BuildRequires:  rpmbuild(macros) >= 1.318
68 BuildRequires:  zlib-devel
69 Requires:       filesystem >= 3.0-11
70 Requires:       pam >= 0.99.7.1
71 Suggests:       openssh-blacklist
72 Suggests:       xorg-app-xauth
73 Obsoletes:      ssh
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/ssh
77 %define         _libexecdir     %{_libdir}/%{name}
78 %define         _privsepdir     /usr/share/empty
79 %define         schemadir       /usr/share/openldap/schema
80
81 %description
82 Ssh (Secure Shell) a program for logging into a remote machine and for
83 executing commands in a remote machine. It is intended to replace
84 rlogin and rsh, and provide secure encrypted communications between
85 two untrusted hosts over an insecure network. X11 connections and
86 arbitrary TCP/IP ports can also be forwarded over the secure channel.
87
88 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
89 it up to date in terms of security and features, as well as removing
90 all patented algorithms to seperate libraries (OpenSSL).
91
92 This package includes the core files necessary for both the OpenSSH
93 client and server. To make this package useful, you should also
94 install openssh-clients, openssh-server, or both.
95 %if %{with hpn}
96 This release includes High Performance SSH/SCP patches from
97 http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed
98 to increase throughput on fast connections with high RTT (20-150 msec).
99 See the website for '-w' values for your connection and /proc/sys TCP
100 values. BTW. in a LAN you have got generally RTT < 1 msec.
101 %endif
102
103 %description -l de.UTF-8
104 OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
105 ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
106 verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
107 über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
108 andere TCP/IP Ports können ebenso über den sicheren Channel
109 weitergeleitet werden.
110
111 %description -l es.UTF-8
112 SSH es un programa para accesar y ejecutar órdenes en computadores
113 remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
114 seguro entre dos servidores en una red insegura. Conexiones X11 y
115 puertas TCP/IP arbitrárias también pueden ser usadas por el canal
116 seguro.
117
118 OpenSSH es el resultado del trabajo del equipo de OpenBSD para
119 continuar la última versión gratuita de SSH, actualizándolo en
120 términos de seguridad y recursos,así también eliminando todos los
121 algoritmos patentados y colocándolos en bibliotecas separadas
122 (OpenSSL).
123
124 Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
125 también el paquete openssh-clients u openssh-server o ambos.
126
127 %description -l fr.UTF-8
128 OpenSSH (Secure Shell) fournit un accès à un système distant. Il
129 remplace telnet, rlogin, rexec et rsh, tout en assurant des
130 communications cryptées securisées entre deux hôtes non fiabilisés sur
131 un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
132 arbitraires peuvent également être transmis sur le canal sécurisé.
133
134 %description -l it.UTF-8
135 OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
136 Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
137 sicure e crittate tra due host non fidati su una rete non sicura. Le
138 connessioni X11 ad una porta TCP/IP arbitraria possono essere
139 inoltrate attraverso un canale sicuro.
140
141 %description -l pl.UTF-8
142 Ssh (Secure Shell) to program służący do logowania się na zdalną
143 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
144 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
145 pomiędzy dwoma hostami.
146
147 Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
148 klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
149 co najmniej jeden z pakietów: openssh-clients lub openssh-server.
150 %if %{with hpn}
151 Ta wersja zawiera łaty z projektu High Performance SSH/SCP
152 http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
153 zwiększenie przepustowości transmisji dla szybkich połączeń
154 z dużym RTT (20-150 msec). Na stronie projektu znaleźć można
155 odpowednie dla danego połączenia wartości parametru '-w' oraz
156 opcje /proc/sys dla TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
157 %endif
158
159 %description -l pt.UTF-8
160 OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
161 telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
162 cifradas entre duas máquinas sem confiança mútua sobre uma rede
163 insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
164 reenviados pelo canal seguro.
165
166 %description -l pt_BR.UTF-8
167 SSH é um programa para acessar e executar comandos em máquinas
168 remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
169 seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
170 TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
171
172 OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
173 última versão gratuita do SSH, atualizando-o em termos de segurança e
174 recursos, assim como removendo todos os algoritmos patenteados e
175 colocando-os em bibliotecas separadas (OpenSSL).
176
177 Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
178 também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
179
180 %description -l ru.UTF-8
181 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
182 машину и для выполнения команд на удаленной машине. Она предназначена
183 для замены rlogin и rsh и обеспечивает безопасную шифрованную
184 коммуникацию между двумя хостами в сети, являющейся небезопасной.
185 Соединения X11 и любые порты TCP/IP могут также быть проведены через
186 безопасный канал.
187
188 OpenSSH - это переделка командой разработчиков OpenBSD последней
189 свободной версии SSH, доведенная до современного состояния в терминах
190 уровня безопасности и поддерживаемых возможностей. Все патентованные
191 алгоритмы вынесены в отдельные библиотеки (OpenSSL).
192
193 Этот пакет содержит файлы, необходимые как для клиента, так и для
194 сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
195 openssh-server, или оба пакета.
196
197 %description -l uk.UTF-8
198 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
199 машини та для виконання команд на віддаленій машині. Вона призначена
200 для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
201 між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
202 довільні порти TCP/IP можуть також бути проведені через безпечний
203 канал.
204
205 OpenSSH - це переробка командою розробників OpenBSD останньої вільної
206 версії SSH, доведена до сучасного стану в термінах рівня безпеки та
207 підтримуваних можливостей. Всі патентовані алгоритми винесені до
208 окремих бібліотек (OpenSSL).
209
210 Цей пакет містить файли, необхідні як для клієнта, так і для сервера
211 OpenSSH. Вам потрібно буде ще встановити openssh-clients,
212 openssh-server, чи обидва пакети.
213
214 %package clients
215 Summary:        OpenSSH Secure Shell protocol clients
216 Summary(es.UTF-8):      Clientes de OpenSSH
217 Summary(pl.UTF-8):      Klienci protokołu Secure Shell
218 Summary(pt_BR.UTF-8):   Clientes do OpenSSH
219 Summary(ru.UTF-8):      OpenSSH - клиенты протокола Secure Shell
220 Summary(uk.UTF-8):      OpenSSH - клієнти протоколу Secure Shell
221 Group:          Applications/Networking
222 Requires:       %{name}
223 Provides:       ssh-clients
224 Obsoletes:      ssh-clients
225
226 %description clients
227 Ssh (Secure Shell) a program for logging into a remote machine and for
228 executing commands in a remote machine. It is intended to replace
229 rlogin and rsh, and provide secure encrypted communications between
230 two untrusted hosts over an insecure network. X11 connections and
231 arbitrary TCP/IP ports can also be forwarded over the secure channel.
232
233 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
234 it up to date in terms of security and features, as well as removing
235 all patented algorithms to seperate libraries (OpenSSL).
236
237 This package includes the clients necessary to make encrypted
238 connections to SSH servers.
239
240 %description clients -l es.UTF-8
241 Este paquete incluye los clientes que se necesitan para hacer
242 conexiones codificadas con servidores SSH.
243
244 %description clients -l pl.UTF-8
245 Ssh (Secure Shell) to program służący do logowania się na zdalną
246 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
247 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
248 pomiędzy dwoma hostami.
249
250 Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
251
252 %description clients -l pt_BR.UTF-8
253 Esse pacote inclui os clientes necessários para fazer conexões
254 encriptadas com servidores SSH.
255
256 %description clients -l ru.UTF-8
257 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
258 машину и для выполнения команд на удаленной машине.
259
260 Этот пакет содержит программы-клиенты, необходимые для установления
261 зашифрованных соединений с серверами SSH.
262
263 %description clients -l uk.UTF-8
264 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
265 машини та для виконання команд на віддаленій машині.
266
267 Цей пакет містить програми-клієнти, необхідні для встановлення
268 зашифрованих з'єднань з серверами SSH.
269
270 %package clients-agent-profile_d
271 Summary:        OpenSSH Secure Shell agent init script
272 Summary(pl.UTF-8):      Skrypt startowy agenta OpenSSH
273 Group:          Applications/Networking
274 Requires:       %{name}-clients = %{epoch}:%{version}-%{release}
275
276 %description clients-agent-profile_d
277 profile.d scripts for starting SSH agent.
278
279 %description clients-agent-profile_d -l pl.UTF-8
280 Skrypty profile.d do uruchamiania agenta SSH.
281
282 %package clients-agent-xinitrc
283 Summary:        OpenSSH Secure Shell agent init script
284 Summary(pl.UTF-8):      Skrypt inicjujący agenta ssh przez xinitrc
285 Group:          Applications/Networking
286 Requires:       %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
287 Requires:       xinitrc
288
289 %description clients-agent-xinitrc
290 xinitrc scripts for starting SSH agent.
291
292 %description clients-agent-xinitrc -l pl.UTF-8
293 Skrypty xinitrc do uruchamiania agenta SSH.
294
295 %package server
296 Summary:        OpenSSH Secure Shell protocol server (sshd)
297 Summary(de.UTF-8):      OpenSSH Secure Shell Protocol-Server (sshd)
298 Summary(es.UTF-8):      Servidor OpenSSH para comunicaciones codificadas
299 Summary(fr.UTF-8):      Serveur de protocole du shell sécurisé OpenSSH (sshd)
300 Summary(it.UTF-8):      Server OpenSSH per il protocollo Secure Shell (sshd)
301 Summary(pl.UTF-8):      Serwer protokołu Secure Shell (sshd)
302 Summary(pt.UTF-8):      Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
303 Summary(pt_BR.UTF-8):   Servidor OpenSSH para comunicações encriptadas
304 Summary(ru.UTF-8):      OpenSSH - сервер протокола Secure Shell (sshd)
305 Summary(uk.UTF-8):      OpenSSH - сервер протоколу Secure Shell (sshd)
306 Group:          Networking/Daemons
307 Requires(post): chkconfig >= 0.9
308 Requires(post): grep
309 Requires(post,preun):   /sbin/chkconfig
310 Requires(postun):       /usr/sbin/userdel
311 Requires(pre):  /bin/id
312 Requires(pre):  /usr/sbin/useradd
313 Requires:       %{name} = %{epoch}:%{version}-%{release}
314 Requires:       pam >= 0.99.7.1
315 Requires:       rc-scripts >= 0.4.1.23
316 Requires:       util-linux
317 Suggests:       /bin/login
318 Provides:       ssh-server
319 Provides:       user(sshd)
320
321 %description server
322 Ssh (Secure Shell) a program for logging into a remote machine and for
323 executing commands in a remote machine. It is intended to replace
324 rlogin and rsh, and provide secure encrypted communications between
325 two untrusted hosts over an insecure network. X11 connections and
326 arbitrary TCP/IP ports can also be forwarded over the secure channel.
327
328 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
329 it up to date in terms of security and features, as well as removing
330 all patented algorithms to seperate libraries (OpenSSL).
331
332 This package contains the secure shell daemon. The sshd is the server
333 part of the secure shell protocol and allows ssh clients to connect to
334 your host.
335
336 %description server -l de.UTF-8
337 Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
338
339 %description server -l es.UTF-8
340 Este paquete contiene el servidor SSH. sshd es la parte servidor del
341 protocolo secure shell y permite que clientes ssh se conecten a su
342 servidor.
343
344 %description server -l fr.UTF-8
345 Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
346
347 %description server -l it.UTF-8
348 Questo pacchetto installa sshd, il server di OpenSSH.
349
350 %description server -l pl.UTF-8
351 Ssh (Secure Shell) to program służący do logowania się na zdalną
352 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
353 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
354 pomiędzy dwoma hostami.
355
356 Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
357 ssh).
358
359 %description server -l pt.UTF-8
360 Este pacote intala o sshd, o servidor do OpenSSH.
361
362 %description server -l pt_BR.UTF-8
363 Esse pacote contém o servidor SSH. O sshd é a parte servidor do
364 protocolo secure shell e permite que clientes ssh se conectem ao seu
365 host.
366
367 %description server -l ru.UTF-8
368 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
369 машину и для выполнения команд на удаленной машине.
370
371 Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
372 часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
373 вашим хостом.
374
375 %description server -l uk.UTF-8
376 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
377 машини та для виконання команд на віддаленій машині.
378
379 Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
380 частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
381 з вашим хостом.
382
383 %package gnome-askpass
384 Summary:        OpenSSH GNOME passphrase dialog
385 Summary(de.UTF-8):      OpenSSH GNOME Passwort-Dialog
386 Summary(es.UTF-8):      Diálogo para introducción de passphrase para GNOME
387 Summary(fr.UTF-8):      Dialogue pass-phrase GNOME d'OpenSSH
388 Summary(it.UTF-8):      Finestra di dialogo GNOME per la frase segreta di OpenSSH
389 Summary(pl.UTF-8):      Odpytywacz hasła OpenSSH dla GNOME
390 Summary(pt.UTF-8):      Diálogo de pedido de senha para GNOME do OpenSSH
391 Summary(pt_BR.UTF-8):   Diálogo para entrada de passphrase para GNOME
392 Summary(ru.UTF-8):      OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
393 Summary(uk.UTF-8):      OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
394 Group:          Applications/Networking
395 Requires:       %{name} = %{epoch}:%{version}-%{release}
396 Obsoletes:      openssh-askpass
397 Obsoletes:      ssh-askpass
398 Obsoletes:      ssh-extras
399
400 %description gnome-askpass
401 Ssh (Secure Shell) a program for logging into a remote machine and for
402 executing commands in a remote machine. It is intended to replace
403 rlogin and rsh, and provide secure encrypted communications between
404 two untrusted hosts over an insecure network. X11 connections and
405 arbitrary TCP/IP ports can also be forwarded over the secure channel.
406
407 OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
408 it up to date in terms of security and features, as well as removing
409 all patented algorithms to seperate libraries (OpenSSL).
410
411 This package contains the GNOME passphrase dialog.
412
413 %description gnome-askpass -l es.UTF-8
414 Este paquete contiene un programa que abre una caja de diálogo para
415 entrada de passphrase en GNOME.
416
417 %description gnome-askpass -l pl.UTF-8
418 Ssh (Secure Shell) to program służący do logowania się na zdalną
419 maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
420 zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
421 pomiędzy dwoma hostami.
422
423 Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
424
425 %description gnome-askpass -l pt_BR.UTF-8
426 Esse pacote contém um programa que abre uma caixa de diálogo para
427 entrada de passphrase no GNOME.
428
429 %description gnome-askpass -l ru.UTF-8
430 Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
431 машину и для выполнения команд на удаленной машине.
432
433 Этот пакет содержит диалог ввода ключевой фразы для использования под
434 GNOME.
435
436 %description gnome-askpass -l uk.UTF-8
437 Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
438 машини та для виконання команд на віддаленій машині.
439
440 Цей пакет містить діалог вводу ключової фрази для використання під
441 GNOME.
442
443 %package -n openldap-schema-openssh-lpk
444 Summary:        OpenSSH LDAP Public Key schema
445 Summary(pl.UTF-8):      Schemat klucza publicznego LDAP dla OpenSSH
446 Group:          Networking/Daemons
447 Requires(post,postun):  sed >= 4.0
448 Requires:       openldap-servers
449
450 %description -n openldap-schema-openssh-lpk
451 This package contains OpenSSH LDAP Public Key schema for openldap.
452
453 %description -n openldap-schema-openssh-lpk -l pl.UTF-8
454 Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
455 openldap-a.
456
457 %prep
458 %setup -q
459 %patch0 -p1
460 %patch2 -p1
461 %patch3 -p1
462 %{?with_ldap:%patch4 -p1}
463 %patch5 -p1
464 %patch7 -p1
465 %{?with_hpn:%patch9 -p1}
466 %patch10 -p1
467 %patch11 -p1
468 %patch12 -p1
469
470 %build
471 cp /usr/share/automake/config.sub .
472 %{__aclocal}
473 %{__autoconf}
474 CPPFLAGS="-DCHROOT"
475 %configure \
476         PERL=%{__perl} \
477         --with-dns \
478         --with-pam \
479         --with-mantype=man \
480         --with-md5-passwords \
481         --with-ipaddr-display \
482         %{?with_libedit:--with-libedit} \
483         --with-4in6 \
484         --disable-suid-ssh \
485         --with-tcp-wrappers \
486         %{?with_ldap:--with-libs="-lldap -llber"} \
487         %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
488         %{?with_kerberos5:--with-kerberos5=/usr} \
489         --with-privsep-path=%{_privsepdir} \
490         --with-pid-dir=%{_localstatedir}/run \
491         --with-xauth=/usr/bin/xauth \
492         --enable-utmpx \
493         --enable-wtmpx
494
495 echo '#define LOGIN_PROGRAM                "/bin/login"' >>config.h
496
497 %{__make}
498
499 cd contrib
500 %if %{with gnome}
501 %{__make} gnome-ssh-askpass1 \
502         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
503 %endif
504 %if %{with gtk}
505 %{__make} gnome-ssh-askpass2 \
506         CC="%{__cc} %{rpmldflags} %{rpmcflags}"
507 %endif
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig,security,env.d}} \
512         $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
513 install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
514
515 %{__make} install \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
519
520 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
521 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
522 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
523 install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
524 ln -sf  /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
525 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
526 install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
527
528 %if %{with gnome}
529 install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
530 %endif
531 %if %{with gtk}
532 install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
533 %endif
534 %if %{with gnome} || %{with gtk}
535 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
536 #GNOME_SSH_ASKPASS_GRAB_SERVER="true"
537 EOF
538 cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
539 #GNOME_SSH_ASKPASS_GRAB_POINTER="true"
540 EOF
541 ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
542 %endif
543
544 install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
545 install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
546
547 rm -f   $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
548 echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
549
550 touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
551
552 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
553 #SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
554 EOF
555
556 rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
557 rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
558
559 %clean
560 rm -rf $RPM_BUILD_ROOT
561
562 %post clients
563 %env_update
564
565 %postun clients
566 %env_update
567
568 %post gnome-askpass
569 %env_update
570
571 %postun gnome-askpass
572 %env_update
573
574 %pre server
575 %useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
576
577 %post server
578 /sbin/chkconfig --add sshd
579 %service sshd reload "openssh daemon"
580 if ! grep -qs ssh /etc/security/passwd.conf ; then
581         umask 022
582         echo "ssh" >> /etc/security/passwd.conf
583 fi
584
585 %preun server
586 if [ "$1" = "0" ]; then
587         %service sshd stop
588         /sbin/chkconfig --del sshd
589 fi
590
591 %postun server
592 if [ "$1" = "0" ]; then
593         %userremove sshd
594 fi
595
596 %post -n openldap-schema-openssh-lpk
597 %openldap_schema_register %{schemadir}/openssh-lpk.schema
598 %service -q ldap restart
599
600 %postun -n openldap-schema-openssh-lpk
601 if [ "$1" = "0" ]; then
602         %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
603         %service -q ldap restart
604 fi
605
606 %files
607 %defattr(644,root,root,755)
608 %doc *.RNG TODO README OVERVIEW CREDITS Change*
609 %attr(755,root,root) %{_bindir}/ssh-key*
610 %attr(755,root,root) %{_bindir}/ssh-vulnkey*
611 %{_mandir}/man1/ssh-key*.1*
612 %{_mandir}/man1/ssh-vulnkey*.1*
613 %dir %{_sysconfdir}
614 %dir %{_libexecdir}
615
616 %files clients
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/ssh
619 %attr(755,root,root) %{_bindir}/slogin
620 %attr(755,root,root) %{_bindir}/sftp
621 %attr(755,root,root) %{_bindir}/ssh-agent
622 %attr(755,root,root) %{_bindir}/ssh-add
623 %attr(755,root,root) %{_bindir}/ssh-copy-id
624 %attr(755,root,root) %{_bindir}/scp
625 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
626 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
627 %{_mandir}/man1/scp.1*
628 %{_mandir}/man1/ssh.1*
629 %{_mandir}/man1/slogin.1*
630 %{_mandir}/man1/sftp.1*
631 %{_mandir}/man1/ssh-agent.1*
632 %{_mandir}/man1/ssh-add.1*
633 %{_mandir}/man1/ssh-copy-id.1*
634 %{_mandir}/man5/ssh_config.5*
635 %lang(it) %{_mandir}/it/man1/ssh.1*
636 %lang(it) %{_mandir}/it/man5/ssh_config.5*
637 %lang(pl) %{_mandir}/pl/man1/scp.1*
638 %lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
639
640 # for host-based auth (suid required for accessing private host key)
641 #%attr(4755,root,root) %{_libexecdir}/ssh-keysign
642 #%{_mandir}/man8/ssh-keysign.8*
643
644 %files clients-agent-profile_d
645 %defattr(644,root,root,755)
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
647 %attr(755,root,root) /etc/profile.d/ssh-agent.sh
648
649 %files clients-agent-xinitrc
650 %defattr(644,root,root,755)
651 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
652
653 %files server
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_sbindir}/sshd
656 %attr(755,root,root) %{_libexecdir}/sftp-server
657 %attr(755,root,root) %{_libexecdir}/ssh-keysign
658 %{_mandir}/man8/sshd.8*
659 %{_mandir}/man8/sftp-server.8*
660 %{_mandir}/man8/ssh-keysign.8*
661 %{_mandir}/man5/sshd_config.5*
662 %{_mandir}/man5/moduli.5*
663 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
664 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
665 %attr(640,root,root) %{_sysconfdir}/moduli
666 %attr(754,root,root) /etc/rc.d/init.d/sshd
667 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
668 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
669
670 %if %{with gnome} || %{with gtk}
671 %files gnome-askpass
672 %defattr(644,root,root,755)
673 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
674 %dir %{_libexecdir}/ssh
675 %attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
676 %attr(755,root,root) %{_libexecdir}/ssh-askpass
677 %endif
678
679 %if %{with ldap}
680 %files -n openldap-schema-openssh-lpk
681 %defattr(644,root,root,755)
682 %{schemadir}/openssh-lpk.schema
683 %endif
This page took 1.6705 seconds and 4 git commands to generate.