]> git.pld-linux.org Git - packages/openssh.git/commitdiff
- 5.4 partial update
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 8 Mar 2010 13:51:46 +0000 (13:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    openssh-chroot.patch -> 1.12
    openssh-config.patch -> 1.9
    openssh-lpk.patch -> 1.3
    openssh-sigpipe.patch -> 1.12
    openssh.spec -> 1.327

openssh-chroot.patch
openssh-config.patch
openssh-lpk.patch
openssh-sigpipe.patch
openssh.spec

index e8f21f74e22983329d6bacd061c5e441fcfc5853..92af31d037f6ef9b9a17ea55ec2f53e3a6ad20ee 100644 (file)
                }
  
 +
- #ifdef HAVE_SETPCRED
-               if (setpcred(pw->pw_name, (char **)NULL) == -1)
-                       fatal("Failed to set process credentials");
+ #ifdef HAVE_LOGIN_CAP
+               if (setusercontext(lc, pw, pw->pw_uid, LOGIN_SETUSER) < 0) {
+                       perror("unable to set user context (setuser)");
 --- openssh-3.7.1p2/sshd_config        2003-09-02 14:51:18.000000000 +0200
 +++ openssh-3.7.1p2.pius/sshd_config   2003-10-07 20:49:08.000000000 +0200
 @@ -91,6 +91,10 @@
index c3066dedc785e346694a0c59124875ceb6633872..e124f108bca35c92b4268fa6f6f4c11b5abaf705 100644 (file)
@@ -75,9 +75,9 @@
  #   CheckHostIP yes
  #   AddressFamily any
 @@ -42,3 +45,19 @@
- #   TunnelDevice any:any
  #   PermitLocalCommand no
  #   VisualHostKey no
+ #   ProxyCommand ssh -q -W %h:%p gateway.example.com
 +
 +Host *
 +      GSSAPIAuthentication yes
index 62997f8799b0adaa561912fc8616112795c06e7f..6972dcb47951f9597e703713b2b0f56ed9b78e44 100644 (file)
@@ -1205,15 +1205,15 @@ diff -Nuar --exclude '*.orig' --exclude '*.rej' openssh-5.1p1.orig/lpk-user-exam
 diff -Nuar --exclude '*.orig' --exclude '*.rej' openssh-5.1p1.orig/Makefile.in openssh-5.1p1+lpk/Makefile.in
 --- openssh-5.1p1.orig/Makefile.in     2008-07-08 07:21:12.000000000 -0700
 +++ openssh-5.1p1+lpk/Makefile.in      2008-08-23 15:02:47.000000000 -0700
-@@ -88,7 +88,7 @@
-       auth2-gss.o gss-serv.o gss-serv-krb5.o \
-       loginrec.o auth-pam.o auth-shadow.o auth-sia.o md5crypt.o \
-       audit.o audit-bsm.o platform.o sftp-server.o sftp-common.o \
--      roaming_common.o
-+      roaming_common.o ldapauth.o
+@@ -78,7 +78,7 @@
  
- MANPAGES      = moduli.5.out scp.1.out ssh-add.1.out ssh-agent.1.out ssh-keygen.1.out ssh-keyscan.1.out ssh.1.out sshd.8.out sftp-server.8.out sftp.1.out ssh-rand-helper.8.out ssh-keysign.8.out sshd_config.5.out ssh_config.5.out
- MANPAGES_IN   = moduli.5 scp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 ssh.1 sshd.8 sftp-server.8 sftp.1 ssh-rand-helper.8 ssh-keysign.8 sshd_config.5 ssh_config.5
+ SSHOBJS= ssh.o readconf.o clientloop.o sshtty.o \
+       sshconnect.o sshconnect1.o sshconnect2.o mux.o \
+-      roaming_common.o roaming_client.o
++      roaming_common.o roaming_client.o ldapauth.o
+ SSHDOBJS=sshd.o auth-rhosts.o auth-passwd.o auth-rsa.o auth-rh-rsa.o \
+       sshpty.o sshlogin.o servconf.o serverloop.o \
 diff -Nuar --exclude '*.orig' --exclude '*.rej' openssh-5.1p1.orig/openssh-lpk_openldap.schema openssh-5.1p1+lpk/openssh-lpk_openldap.schema
 --- openssh-5.1p1.orig/openssh-lpk_openldap.schema     1969-12-31 16:00:00.000000000 -0800
 +++ openssh-5.1p1+lpk/openssh-lpk_openldap.schema      2008-08-23 15:02:47.000000000 -0700
@@ -1548,9 +1548,9 @@ diff -Nuar --exclude '*.orig' --exclude '*.rej' openssh-5.1p1.orig/servconf.c op
  static void add_one_listen_addr(ServerOptions *, char *, int);
  
 @@ -127,6 +131,25 @@
-       options->adm_forced_command = NULL;
-       options->chroot_directory = NULL;
        options->zero_knowledge_password_authentication = -1;
+       options->revoked_keys_file = NULL;
+       options->trusted_user_ca_keys = NULL;
 +#ifdef WITH_LDAP_PUBKEY
 +      /* XXX dirty */
 +      options->lpk.ld = NULL;
index 8d38197be55c2541f392c8fd16472f3b6baf219c..22a0de2ea601bc0a2c022c637fefdd5df106ceef 100644 (file)
@@ -78,8 +78,8 @@ diff -urN openssh-3.9p1.org/ssh.0 openssh-3.9p1/ssh.0
  
   again:
        while ((opt = getopt(ac, av, "1246ab:c:e:fgi:kl:m:no:p:qstvx"
--          "ACD:F:I:KL:MNO:PR:S:TVw:XYy")) != -1) {
-+          "ABCD:F:I:KL:MNO:PR:S:TVw:XYy")) != -1) {
+-          "ACD:F:I:KL:MNO:PR:S:TVw:W:XYy")) != -1) {
++          "ABCD:F:I:KL:MNO:PR:S:TVw:W:XYy")) != -1) {
                switch (opt) {
                case '1':
                        options.protocol = SSH_PROTO_1;
index 32d347c042b3942e7e3ea96e1c27c2194db928e6..6d073be6da2dea45f60abeda7cb40eddd9e6d45e 100644 (file)
@@ -21,13 +21,13 @@ Summary(pt_BR.UTF-8):       Implementação livre do SSH
 Summary(ru.UTF-8):     OpenSSH - свободная реализация протокола Secure Shell (SSH)
 Summary(uk.UTF-8):     OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
 Name:          openssh
-Version:       5.3p1
-Release:       2
+Version:       5.4p1
+Release:       1
 Epoch:         2
 License:       BSD
 Group:         Applications/Networking
 Source0:       ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
-# Source0-md5: 13563dbf61f36ca9a1e4254260131041
+# Source0-md5: da10af8a789fa2e83e3635f3a1b76f5e
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 66943d481cc422512b537bcc2c7400d1
 Source2:       %{name}d.init
This page took 0.254049 seconds and 4 git commands to generate.