]> git.pld-linux.org Git - packages/nginx.git/commitdiff
- rel 3; when nginx is stuck and has oldbin and current bin for hours/days then log... auto/th/nginx-1.15.8-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 14 Feb 2019 08:10:24 +0000 (09:10 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 14 Feb 2019 08:10:24 +0000 (09:10 +0100)
nginx.init
nginx.spec

index 5ac987bfe0ddff6dd5bbc116bc24733bdf4f8fa7..f209fc06a855779ad8130418cf3ef5865dee7f77 100755 (executable)
@@ -152,6 +152,13 @@ upgrade() {
 # Tell nginx to reopen logs
 # http://nginx.org/en/docs/control.html#logs
 reopen_logs() {
+       local oldbin_pidfile="${pidfile}.oldbin"
+
+       if [ -f $oldbin_pidfile ]; then
+               show "Reopening $svname (oldbin) logs"
+               killproc -p $oldbin_pidfile $prog -USR1
+       fi
+
        show "Reopening $svname logs"
        killproc -p $pidfile $prog -USR1
 }
index ccf0ff7f60e165b3cc3dfae245d901a3a40c8bc0..a43813c4303d420c25ed77d73136731dd37116c2 100644 (file)
@@ -42,7 +42,7 @@ Summary(pl.UTF-8):    Serwer HTTP i odwrotne proxy o wysokiej wydajności
 # - mainline: production quality but API can change
 Name:          nginx
 Version:       1.15.8
-Release:       2
+Release:       3
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
This page took 0.145836 seconds and 4 git commands to generate.