]> git.pld-linux.org Git - packages/nginx.git/commitdiff
- rel 2; stop now works even if we are in middle of binary upgrade (via force-reload... auto/th/nginx-1.15.8-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Feb 2019 14:48:50 +0000 (15:48 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 6 Feb 2019 14:48:50 +0000 (15:48 +0100)
nginx.init
nginx.spec

index ef12b5733d5c6419db613751b9261b453560c3d5..5ac987bfe0ddff6dd5bbc116bc24733bdf4f8fa7 100755 (executable)
@@ -88,8 +88,14 @@ start() {
 }
 
 stop() {
+       local oldbin_pidfile="${pidfile}.oldbin"
+
        # Stop daemons.
        if [ -f $lockfile ]; then
+               if [ -f $oldbin_pidfile ] && [ -f $pidfile ]; then
+                       msg_stopping "$svname (old process)"
+                       killproc -p $oldbin_pidfile $prog -TERM
+               fi
                msg_stopping "$svname"
                killproc -p $pidfile $prog
                RETVAL=$?
index 91e57036a3ae3b0bd49c0d92939672c2bc452e80..ccf0ff7f60e165b3cc3dfae245d901a3a40c8bc0 100644 (file)
@@ -42,7 +42,7 @@ Summary(pl.UTF-8):    Serwer HTTP i odwrotne proxy o wysokiej wydajności
 # - mainline: production quality but API can change
 Name:          nginx
 Version:       1.15.8
-Release:       1
+Release:       2
 License:       BSD-like
 Group:         Networking/Daemons/HTTP
 Source0:       http://nginx.org/download/%{name}-%{version}.tar.gz
This page took 0.067257 seconds and 4 git commands to generate.