]> git.pld-linux.org Git - packages/mysql.git/blob - mysql.spec
- remove wrong mysqld.conf, template is back
[packages/mysql.git] / mysql.spec
1 # TODO:
2 # - trigger that prepares system from pre-cluster into cluster
3 # - trigger /etc/mysqld.conf into /etc/mysql/mysqld.conf. Solve possible 
4 #   conflict with /var/lib/mysql/mysqld.conf
5 #
6 # Conditional build:
7 %bcond_with     bdb     # Berkeley DB support
8 #
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        MySQL: a very fast and reliable SQL database engine
11 Summary(fr):    MySQL: un serveur SQL rapide et fiable
12 Summary(pl):    MySQL: bardzo szybka i niezawodna baza danych (SQL)
13 Summary(pt_BR): MySQL: Um servidor SQL rápido e confiável
14 Summary(ru):    MySQL - ÂÙÓÔÒÙÊ SQL-ÓÅÒ×ÅÒ
15 Summary(uk):    MySQL - Û×ÉÄËÉÊ SQL-ÓÅÒ×ÅÒ
16 Summary(zh_CN): MySQLÊý¾Ý¿â·þÎñÆ÷
17 Name:           mysql
18 Group:          Applications/Databases
19 Version:        4.0.20
20 Release:        2.5
21 License:        GPL
22 Source0:        http://mysql.linux.cz/Downloads/MySQL-4.0/mysql-%{version}.tar.gz
23 # Source0-md5:  7c75ac74e23396bd228dbc2c2d1131df
24 Source1:        %{name}.init
25 Source2:        %{name}.sysconfig
26 Source3:        %{name}.logrotate
27 Source4:        %{name}d.conf
28 Source5:        %{name}-clusters.conf
29 Source6:        %{name}.monitrc
30 Patch0:         %{name}-libs.patch
31 Patch1:         %{name}-libwrap.patch
32 Patch2:         %{name}-c++.patch
33 Patch3:         %{name}-_r-link.patch
34 Patch4:         %{name}-info.patch
35 Patch5:         %{name}-dump_quote_db_names.patch
36 Patch7:         %{name}-sql-cxx-pic.patch
37 Patch8:         %{name}-noproc.patch
38 Patch9:         %{name}-fix_privilege_tables.patch
39 Patch10:        %{name}-nptl.patch
40 Icon:           mysql.gif
41 URL:            http://www.mysql.com/
42 #BuildRequires: ORBit-devel
43 BuildRequires:  /bin/ps
44 BuildRequires:  autoconf
45 BuildRequires:  automake
46 %{?with_bdb:BuildRequires:      db3-devel}
47 BuildRequires:  libstdc++-devel >= 5:3.0
48 BuildRequires:  libtool
49 BuildRequires:  libwrap-devel
50 BuildRequires:  ncurses-devel >= 4.2
51 BuildRequires:  openssl-devel >= 0.9.7d
52 BuildRequires:  perl-DBI
53 BuildRequires:  perl-devel >= 1:5.6.1
54 BuildRequires:  readline-devel >= 4.2
55 BuildRequires:  rpm-perlprov >= 4.1-13
56 BuildRequires:  texinfo
57 BuildRequires:  zlib-devel
58 PreReq:         rc-scripts >= 0.2.0
59 Requires(pre):  /usr/bin/getgid
60 Requires(pre):  /bin/id
61 Requires(pre):  /usr/sbin/groupadd
62 Requires(pre):  /usr/sbin/useradd
63 Requires(postun):       /usr/sbin/userdel
64 Requires(postun):       /usr/sbin/groupdel
65 Requires(post,preun):   /sbin/chkconfig
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       /usr/bin/setsid
68 Provides:       MySQL-server
69 Provides:       msqlormysql
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71 Obsoletes:      MySQL
72 Obsoletes:      mysql-server
73
74 %define         _libexecdir     %{_sbindir}
75 %define         _localstatedir  /var/lib/mysql
76 %define         _mysqlhome      /home/services/mysql
77
78 %define         _noautoreqdep   'perl(DBD::mysql)'
79 # workaround for buggy gcc 3.3.1
80 %define         specflags_alpha  -mno-explicit-relocs 
81
82 %description
83 MySQL is a true multi-user, multi-threaded SQL (Structured Query
84 Language) database server. SQL is the most popular database language
85 in the world. MySQL is a client/server implementation that consists of
86 a server daemon mysqld and many different client programs/libraries.
87
88 The main goals of MySQL are speed, robustness and easy to use. MySQL
89 was originally developed because we at Tcx needed a SQL server that
90 could handle very big databases with magnitude higher speed than what
91 any database vendor could offer to us. We have now been using MySQL
92 since 1996 in a environment with more than 40 databases, 10,000
93 tables, of which more than 500 have more than 7 million rows. This is
94 about 50G of mission critical data.
95
96 The base upon which MySQL is built is a set of routines that have been
97 used in a highly demanding production environment for many years.
98 While MySQL is still in development, it already offers a rich and
99 highly useful function set.
100
101 %description -l fr
102 MySQL est un serveur de bases de donnees SQL vraiment multi-usagers et
103 multi-taches. Le langage SQL est le langage de bases de donnees le
104 plus populaire au monde. MySQL est une implementation client/serveur
105 qui consiste en un serveur (mysqld) et differents
106 programmes/bibliotheques clientes.
107
108 Les objectifs principaux de MySQL sont: vitesse, robustesse et
109 facilite d'utilisation. MySQL fut originalement developpe parce que
110 nous, chez Tcx, avions besoin d'un serveur SQL qui pouvait gerer de
111 tres grandes bases de donnees avec une vitesse d'un ordre de magnitude
112 superieur a ce que n'importe quel vendeur pouvait nous offrir. Nous
113 utilisons MySQL depuis 1996 dans un environnement avec plus de 40
114 bases de donnees, 10000 tables, desquelles plus de 500 ont plus de 7
115 millions de lignes. Ceci represente environ 50G de donnees critiques.
116
117 A la base de la conception de MySQL, on retrouve une serie de routines
118 qui ont ete utilisees dans un environnement de production pendant
119 plusieurs annees. Meme si MySQL est encore en developpement, il offre
120 deja une riche et utile serie de fonctions.
121
122 %description -l pl
123 MySQL to prawdziwie wielou¿ytkownikowy, wielow±tkowy serwer baz danych
124 SQL. SQL jest najpopularniejszym na ¶wiecie jêzykiem u¿ywanym do baz
125 danych. MySQL to implementacja klient/serwer sk³adaj±ca siê z demona
126 mysqld i wielu ró¿nych programów i bibliotek klienckich.
127
128 G³ównymi celami MySQL-a s± szybko¶æ, potêga i ³atwo¶æ u¿ytkowania.
129 MySQL oryginalnie by³ tworzony, poniewa¿ autorzy w Tcx potrzebowali
130 serwera SQL do obs³ugi bardzo du¿ych baz danych z szybko¶ci± o wiele
131 wiêksz±, ni¿ mogli zaoferowaæ inni producenci baz danych. U¿ywaj± go
132 od 1996 roku w ¶rodowisku z ponad 40 bazami danych, 10 000 tabel,
133 z których ponad 500 zawiera ponad 7 milionów rekordów - w sumie oko³o
134 50GB krytycznych danych.
135
136 Baza, na której oparty jest MySQL, sk³ada siê ze zbioru procedur,
137 które by³y u¿ywane w bardzo wymagaj±cym ¶rodowisku produkcyjnym przez
138 wiele lat. Pomimo, ¿e MySQL jest ci±gle rozwijany, ju¿ oferuje bogaty
139 i u¿yteczny zbiór funkcji.
140
141 %description -l pt_BR
142 O MySQL é um servidor de banco de dados SQL realmente multiusuário e
143 multi-tarefa. A linguagem SQL é a mais popular linguagem para banco de
144 dados no mundo. O MySQL é uma implementação cliente/servidor que
145 consiste de um servidor chamado mysqld e diversos
146 programas/bibliotecas clientes. Os principais objetivos do MySQL são:
147 velocidade, robustez e facilidade de uso. O MySQL foi originalmente
148 desenvolvido porque nós na Tcx precisávamos de um servidor SQL que
149 pudesse lidar com grandes bases de dados e com uma velocidade muito
150 maior do que a que qualquer vendedor podia nos oferecer. Estamos
151 usando o MySQL desde 1996 em um ambiente com mais de 40 bases de dados
152 com 10.000 tabelas, das quais mais de 500 têm mais de 7 milhões de
153 linhas. Isto é o equivalente a aproximadamente 50G de dados críticos.
154 A base da construção do MySQL é uma série de rotinas que foram usadas
155 em um ambiente de produção com alta demanda por muitos anos. Mesmo o
156 MySQL estando ainda em desenvolvimento, ele já oferece um conjunto de
157 funções muito ricas e úteis. Veja a documentação para maiores
158 informações.
159
160 %description -l ru
161 MySQL - ÜÔÏ SQL (Structured Query Language) ÓÅÒ×ÅÒ ÂÁÚÙ ÄÁÎÎÙÈ. MySQL
162 ÂÙÌÁ ÎÁÐÉÓÁÎÁ Michael'ÏÍ (monty) Widenius'ÏÍ. óÍ. ÆÁÊÌ CREDITS ×
163 ÄÉÓÔÒÉÂÕÔÉ×Å ÎÁ ÐÒÅÄÍÅÔ ÄÒÕÇÉÈ ÕÞÁÓÔÎÉËÏ× ÐÒÏÅËÔÁ É ÐÒÏÞÅÊ ÉÎÆÏÒÍÁÃÉÉ
164 Ï MySQL.
165
166 %description -l uk
167 MySQL - ÃÅ SQL (Structured Query Language) ÓÅÒ×ÅÒ ÂÁÚÉ ÄÁÎÉÈ. MySQL
168 ÂÕÌÏ ÎÁÐÉÓÁÎÏ Michael'ÏÍ (monty) Widenius'ÏÍ. äÉ×. ÆÁÊÌ CREDITS ×
169 ÄÉÓÔÒÉÂÕÔÉצ ÄÌÑ ¦ÎÆÏÒÍÁ槠ÐÒÏ ¦ÎÛÉÈ ÕÞÁÓÎÉ˦נÐÒÏÅËÔÕ ÔÁ ¦ÎÛϧ
170 ¦ÎÆÏÒÍÁæ§.
171
172 %package extras
173 Summary:        MySQL additional utilities
174 Summary(pl):    Dodatkowe narzêdzia do MySQL
175 Group:          Applications/Databases
176 Requires:       %{name}-libs = %{version}-%{release}
177
178 %description extras
179 MySQL additional utilities except Perl scripts (they may be found in
180 %{name}-extras-perl package).
181
182 %description extras -l pl
183 Dodatkowe narzêdzia do MySQL - z wyj±tkiem skryptów Perla (które s± w
184 pakiecie %{name}-extras-perl).
185
186 %package extras-perl
187 Summary:        MySQL additional utilities written in Perl
188 Summary(pl):    Dodatkowe narzêdzia do MySQL napisane w Perlu
189 Group:          Applications/Databases
190 Requires:       %{name}-extras = %{version}-%{release}
191 Requires:       perl(DBD::mysql)
192
193 %description extras-perl
194 MySQL additional utilities written in Perl.
195
196 %description extras-perl -l pl
197 Dodatkowe narzêdzia do MySQL napisane w Perlu.
198
199 %package client
200 Summary:        MySQL - Client
201 Summary(pl):    MySQL - Klient
202 Summary(pt):    MySQL - Cliente
203 Summary(ru):    MySQL ËÌÉÅÎÔ
204 Summary(uk):    MySQL Ë̦¤ÎÔ
205 Group:          Applications/Databases
206 Requires:       %{name}-libs = %{version}-%{release}
207 Obsoletes:      MySQL-client
208
209 %description client
210 This package contains the standard MySQL clients.
211
212 %description client -l fr
213 Ce package contient les clients MySQL standards.
214
215 %description client -l pl
216 Standardowe programy klienckie MySQL.
217
218 %description client -l pt_BR
219 Este pacote contém os clientes padrão para o MySQL.
220
221 %description client -l ru
222 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÔÏÌØËÏ ËÌÉÅÎÔ MySQL.
223
224 %description client -l uk
225 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ Ô¦ÌØËÉ Ë̦¤ÎÔÁ MySQL.
226
227 %package libs
228 Summary:        Shared libraries for MySQL
229 Summary(pl):    Biblioteki dzielone MySQL
230 Group:          Applications/Databases
231 Obsoletes:      libmysql10
232
233 %description libs
234 Shared libraries for MySQL.
235
236 %description libs -l pl
237 Biblioteki dzielone MySQL.
238
239 %package devel
240 Summary:        MySQL - Development header files and libraries
241 Summary(pl):    MySQL - Pliki nag³ówkowe i biblioteki dla programistów
242 Summary(pt):    MySQL - Medições de desempenho
243 Summary(ru):    MySQL - ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ
244 Summary(uk):    MySQL - ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ
245 Group:          Development/Libraries
246 Requires:       %{name}-libs = %{version}-%{release}
247 Requires:       openssl-devel
248 Requires:       zlib-devel
249 Obsoletes:      MySQL-devel
250 Obsoletes:      libmysql10-devel
251
252 %description devel
253 This package contains the development header files and libraries
254 necessary to develop MySQL client applications.
255
256 %description devel -l fr
257 Ce package contient les fichiers entetes et les librairies de
258 developpement necessaires pour developper des applications clientes
259 MySQL.
260
261 %description devel -l pl
262 Pliki nag³ówkowe i biblioteki konieczne do kompilacji aplikacji
263 klienckich MySQL.
264
265 %description devel -l pt_BR
266 Este pacote contém os arquivos de cabeçalho (header files) e
267 bibliotecas necessárias para desenvolver aplicações clientes do MySQL.
268
269 %description devel -l ru
270 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ
271 ÒÁÚÒÁÂÏÔËÉ ËÌÉÅÎÔÓËÉÈ ÐÒÉÌÏÖÅÎÉÊ.
272
273 %description devel -l uk
274 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ, ÎÅÏÂȦÄΦ ÄÌÑ
275 ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ-Ë̦¤ÎÔ¦×.
276
277 %package static
278 Summary:        MySQL static libraries
279 Summary(pl):    Biblioteki statyczne MySQL
280 Summary(ru):    MySQL - ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ
281 Summary(uk):    MySQL - ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ
282 Group:          Development/Libraries
283 Requires:       %{name}-devel = %{version}-%{release}
284 Obsoletes:      MySQL-static
285
286 %description static
287 MySQL static libraries.
288
289 %description static -l pl
290 Biblioteki statyczne MySQL.
291
292 %description static -l ru
293 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ, ÎÅÏÂÈÏÄÉÍÙÅ
294 ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ËÌÉÅÎÔÓËÉÈ ÐÒÉÌÏÖÅÎÉÊ.
295
296 %description static -l uk
297 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ, ÎÅÏÂȦÄΦ ÄÌÑ
298 ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ-Ë̦¤ÎÔ¦×.
299
300 %package bench
301 Summary:        MySQL - Benchmarks
302 Summary(pl):    MySQL - Programy testuj±ce szybko¶æ dzia³ania bazy
303 Summary(pt):    MySQL - Medições de desempenho
304 Summary(ru):    MySQL - ÂÅÎÞÍÁÒËÉ
305 Summary(uk):    MySQL - ÂÅÎÞÍÁÒËÉ
306 Group:          Applications/Databases
307 Requires:       %{name} = %{version}-%{release}
308 Requires:       %{name}-client
309 Requires:       perl(DBD::mysql)
310 Obsoletes:      MySQL-bench
311
312 %description bench
313 This package contains MySQL benchmark scripts and data.
314
315 %description bench -l pl
316 Programy testuj±ce szybko¶æ serwera MySQL.
317
318 %description bench -l pt_BR
319 Este pacote contém medições de desempenho de scripts e dados do MySQL.
320
321 %description bench -l ru
322 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓËÒÉÐÔÙ É ÄÁÎÎÙÅ ÄÌÑ ÏÃÅÎËÉ ÐÒÏÉÚ×ÏÄÉÔÅÌØÎÏÓÔÉ
323 MySQL.
324
325 %description bench -l uk
326 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓËÒÉÐÔÉ ÔÁ ÄÁΦ ÄÌÑ ÏæÎËÉ ÐÒÏÄÕËÔÉ×ÎÏÓÔ¦ MySQL.
327
328 %package doc
329 Summary:        MySQL manual
330 Summary(pl):    Podrêcznik u¿ytkownika MySQL
331 Group:          Applications/Databases
332
333 %description doc
334 This package contains manual in HTML format.
335
336 %description doc -l pl
337 Podrêcznik MySQL-a w formacie HTML. 
338
339 %prep
340 %setup -q
341 %patch0 -p1
342 %patch1 -p1
343 %patch2 -p1
344 %patch3 -p1
345 %patch4 -p1
346 #%patch5 -p1
347 %ifarch alpha
348 # this is strange: mysqld functions for UDF modules are not explicitly defined,
349 # so -rdynamic is used; in such case gcc3+ld on alpha doesn't like C++ vtables
350 # in objects compiled without -fPIC
351 %patch7 -p1
352 %endif
353 %patch8 -p1
354 %patch9 -p1
355 %patch10 -p1
356
357 %{__perl} -pi -e 's@/lib/libpthread@/%{_lib}/libpthread@' configure.in
358
359 %build
360 %{__libtoolize}
361 %{__aclocal}
362 %{__automake}
363 %{__autoconf}
364 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions %{!?debug:-fomit-frame-pointer}"
365 CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
366 %configure \
367         PS='/bin/ps' \
368         FIND_PROC='/bin/ps p $$PID' \
369         KILL='/bin/kill' \
370         CHECK_PID='/bin/kill -0 $$PID' \
371         -C \
372         --enable-assembler \
373         --enable-shared \
374         --enable-static \
375         --enable-thread-safe-client \
376         %{?with_bdb:--with-berkeley-db} \
377         --with-comment="PLD Linux Distribution MySQL RPM" \
378         --with%{!?debug:out}-debug \
379         --with-embedded-server \
380         --with-extra-charsets=all \
381         --with-libwrap \
382         --with-low-memory \
383         --with-mysqld-user=mysql \
384         --with-named-curses-libs="-lncurses" \
385         --with-openssl \
386         --with-pthread \
387         --with-raid \
388         --with-unix-socket-path=/var/lib/mysql/mysql.sock \
389         --with-vio \
390         --without-readline \
391         --without-docs
392 #       --with-mysqlfs
393
394 echo -e "all:\ninstall:\nclean:\nlink_sources:\n" > libmysqld/examples/Makefile
395
396 %{__make} benchdir=$RPM_BUILD_ROOT%{_datadir}/sql-bench
397 %{__make} -C Docs mysql.info
398
399 %install
400 rm -rf $RPM_BUILD_ROOT
401 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,mysql,monit} \
402            $RPM_BUILD_ROOT/var/{log/{archiv,}/mysql,lib/mysql} \
403            $RPM_BUILD_ROOT{%{_infodir},%{_mysqlhome}}
404
405 %if %{with bdb}
406 install -d $RPM_BUILD_ROOT/var/lib/mysql/bdb/{log,tmp}
407 %endif
408
409 # Make install
410 %{__make} install \
411         DESTDIR=$RPM_BUILD_ROOT \
412         benchdir=%{_datadir}/sql-bench \
413         libsdir=/tmp
414 # libsdir is to avoid installing innodb static libs in $RPM_BUILD_ROOT../libs
415
416 install Docs/mysql.info $RPM_BUILD_ROOT%{_infodir}
417
418 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql
419 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/mysql
420 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mysql
421 # This is template for configuration file which is created after 'service mysql init'
422 install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/mysql/mysqld.conf
423 install %{SOURCE5} $RPM_BUILD_ROOT/etc/mysql/clusters.conf
424 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit
425 touch $RPM_BUILD_ROOT/var/log/mysql/{err,log,update,isamlog.log}
426
427 # remove mysqld's *.po files
428 find . $RPM_BUILD_ROOT%{_datadir}/%{name} -name \*.txt | xargs -n 100 rm -f
429 mv -f $RPM_BUILD_ROOT%{_libdir}/mysql/lib* $RPM_BUILD_ROOT%{_libdir}
430 %{__perl} -pi -e 's,%{_libdir}/mysql,%{_libdir},;' $RPM_BUILD_ROOT%{_libdir}/libmysqlclient.la
431
432 rm -rf $RPM_BUILD_ROOT%{_prefix}/mysql-test
433
434 %clean
435 rm -rf $RPM_BUILD_ROOT
436
437 %pre
438 if [ -n "`getgid mysql`" ]; then
439         if [ "`getgid mysql`" != "89" ]; then
440                 echo "Error: group mysql doesn't have gid=89. Correct this before installing mysql." 1>&2
441                 exit 1
442         fi
443 else
444         /usr/sbin/groupadd -g 89 -r -f mysql
445 fi
446 if [ -n "`id -u mysql 2>/dev/null`" ]; then
447         if [ "`id -u mysql`" != "89" ]; then
448                 echo "Error: user mysql doesn't have uid=89. Correct this before installing mysql." 1>&2
449                 exit 1
450         fi
451 else
452         /usr/sbin/useradd -M -o -r -u 89 \
453                         -d %{_mysqlhome} -s /bin/sh -g mysql \
454                         -c "MySQL Server" mysql 1>&2
455 fi
456
457 %post
458 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
459 /sbin/chkconfig --add mysql
460 if [ -f /var/lock/subsys/mysql ]; then
461         /etc/rc.d/init.d/mysql restart >&2
462 else
463         echo "Run \"/etc/rc.d/init.d/mysql start\" to start mysql." >&2
464 fi
465
466 %preun
467 if [ "$1" = "0" ]; then
468         if [ -f /var/lock/subsys/mysql ]; then
469                 /etc/rc.d/init.d/mysql stop
470         fi
471         /sbin/chkconfig --del mysql
472 fi
473
474 %postun
475 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
476 if [ "$1" = "0" ]; then
477         /usr/sbin/userdel mysql
478         /usr/sbin/groupdel mysql
479 fi
480
481 %post   libs -p /sbin/ldconfig
482 %postun libs -p /sbin/ldconfig
483
484 %triggerpostun -- mysql <= 4.0.20-2
485 # For clusters in /etc/mysql/clusters.conf
486 if [ -f "/etc/sysconfig/mysql" ]; then
487         . /etc/sysconfig/mysql
488         if [ "$MYSQL_DB_CLUSTERS" ]; then
489                 for i in "$MYSQL_DB_CLUSTERS"; do
490                         echo "$i/mysqld.conf=$i" >> /etc/mysql/clusters.conf
491                 done
492                 echo "# Do not use **obsolete** option MYSQL_DB_CLUSTERS" >> /etc/sysconfig/mysql
493                 echo "# USE /etc/mysql/clusters.conf instead" >> /etc/sysconfig/mysql
494                 echo "Converted clusters from MYSQL_DB_CLUSTERS to /etc/mysql/clusters.conf"
495                 echo "Take a look at that"
496         fi
497 fi
498
499 %files
500 %defattr(644,root,root,755)
501 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/logrotate.d/mysql
502 %attr(754,root,root) /etc/rc.d/init.d/mysql
503 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/mysql
504 %attr(751,root,root) %dir /etc/mysql
505 %attr(640,root,mysql) %config(noreplace) %verify(not md5 size mtime) /etc/mysql/clusters.conf
506 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/monit/*.monitrc
507 %attr(755,root,root) %{_bindir}/isamchk
508 %attr(755,root,root) %{_bindir}/isamlog
509 %attr(755,root,root) %{_bindir}/myisamchk
510 %attr(755,root,root) %{_bindir}/myisamlog
511 %attr(755,root,root) %{_bindir}/myisampack
512 %attr(755,root,root) %{_bindir}/pack_isam
513 %attr(755,root,root) %{_sbindir}/mysqld
514 %{_mandir}/man1/isamchk.1*
515 %{_mandir}/man1/isamlog.1*
516 %{_mandir}/man1/mysqld.1*
517
518 %attr(700,mysql,mysql) %{_mysqlhome}
519 # root:root is proper here for AC mysql.rpm while mysql:mysql is potential security hole
520 %attr(751,root,root) /var/lib/mysql
521 %attr(750,mysql,mysql) %dir /var/log/mysql
522 %attr(750,mysql,mysql) %dir /var/log/archiv/mysql
523 %attr(640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysql/*
524
525 %{_infodir}/mysql.info*
526 %dir %{_datadir}/mysql
527 # This is template for configuration file which is created after 'service mysql init'
528 %{_datadir}/mysql/mysqld.conf
529 %{_datadir}/mysql/charsets
530 %{_datadir}/mysql/english
531 %lang(cs) %{_datadir}/mysql/czech
532 %lang(da) %{_datadir}/mysql/danish
533 %lang(de) %{_datadir}/mysql/german
534 %lang(el) %{_datadir}/mysql/greek
535 %lang(es) %{_datadir}/mysql/spanish
536 %lang(et) %{_datadir}/mysql/estonian
537 %lang(fr) %{_datadir}/mysql/french
538 %lang(hu) %{_datadir}/mysql/hungarian
539 %lang(it) %{_datadir}/mysql/italian
540 %lang(ja) %{_datadir}/mysql/japanese
541 %lang(ko) %{_datadir}/mysql/korean
542 %lang(nl) %{_datadir}/mysql/dutch
543 %lang(nb) %{_datadir}/mysql/norwegian
544 %lang(nn) %{_datadir}/mysql/norwegian-ny
545 %lang(pl) %{_datadir}/mysql/polish
546 %lang(pt) %{_datadir}/mysql/portuguese
547 %lang(ro) %{_datadir}/mysql/romanian
548 %lang(ru) %{_datadir}/mysql/russian
549 %lang(sk) %{_datadir}/mysql/slovak
550 %lang(sv) %{_datadir}/mysql/swedish
551 %lang(uk) %{_datadir}/mysql/ukrainian
552
553 %files extras
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/msql2mysql
556 %attr(755,root,root) %{_bindir}/mysql_fix_privilege_tables
557 %attr(755,root,root) %{_bindir}/perror
558 %attr(755,root,root) %{_bindir}/my_print_defaults
559 %attr(755,root,root) %{_bindir}/replace
560 %attr(755,root,root) %{_bindir}/resolveip
561 %{_mandir}/man1/mysql_fix_privilege_tables.1*
562 %{_mandir}/man1/perror.1*
563 %{_mandir}/man1/replace.1*
564
565 %files extras-perl
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_bindir}/mysql_convert_table_format
568 %attr(755,root,root) %{_bindir}/mysqldumpslow
569 %attr(755,root,root) %{_bindir}/mysqlhotcopy
570 %attr(755,root,root) %{_bindir}/mysql_setpermission
571 %attr(755,root,root) %{_bindir}/mysql_zap
572 %attr(755,root,root) %{_bindir}/mysql_find_rows
573 %attr(755,root,root) %{_bindir}/mysqlaccess
574 %{_mandir}/man1/mysql_zap.1*
575 %{_mandir}/man1/mysqlaccess.1*
576
577 %files client
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_bindir}/mysql
580 %attr(755,root,root) %{_bindir}/mysqlbug
581 %attr(755,root,root) %{_bindir}/mysqldump
582 %attr(755,root,root) %{_bindir}/mysqlimport
583 %attr(755,root,root) %{_bindir}/mysqlmanager*
584 %attr(755,root,root) %{_bindir}/mysqlshow
585 %attr(755,root,root) %{_bindir}/mysqlbinlog
586 %attr(755,root,root) %{_bindir}/mysqladmin
587 %attr(755,root,root) %{_bindir}/mysqltest
588 %{_mandir}/man1/mysql.1*
589 %{_mandir}/man1/mysqladmin.1*
590 %{_mandir}/man1/mysqldump.1*
591 %{_mandir}/man1/mysqlshow.1*
592
593 %files libs
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/lib*.so.*.*
596
597 %files devel
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_bindir}/mysql_config
600 %attr(755,root,root) %{_libdir}/lib*.so
601 %{_libdir}/lib*.la
602 %{_libdir}/lib*[!tr].a
603 %{_includedir}/mysql
604
605 %files static
606 %defattr(644,root,root,755)
607 %{_libdir}/lib*[tr].a
608
609 %files bench
610 %defattr(644,root,root,755)
611 %dir %{_datadir}/sql-bench
612 %{_datadir}/sql-bench/[CDRl]*
613 %attr(755,root,root) %{_datadir}/sql-bench/[bcgrst]*
614
615 %files doc
616 %defattr(644,root,root,755)
617 %doc Docs/manual.html Docs/manual_toc.html
This page took 0.07683 seconds and 4 git commands to generate.