]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
- up to 1.5.0
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
a7d444e9 4%bcond_without doc # don't build doc
ecadc52c 5%bcond_with tests # build tests (not useful, creates libgtest.a)
5f38e725
ER
6%bcond_without ssse3 # use SSSE3 instructions (Intel since Core2, Via Nano)
7
30fcd8a5 8%ifnarch %{ix86} %{x8664} x32
f2369026
ER
9%undefine with_asm
10%endif
11
5f38e725
ER
12%if "%{pld_release}" == "ac"
13# not supported by compiler
14%undefine with_ssse3
15%endif
3c828a1d 16
bccc9f86 17Summary: VP8, a high-quality video codec
d5d82930 18Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 19Name: libvpx
05641fc7
AM
20Version: 1.5.0
21Release: 1
bccc9f86
AM
22License: BSD
23Group: Libraries
05641fc7
AM
24Source0: https://storage.googleapis.com/downloads.webmproject.org/releases/webm/%{name}-%{version}.tar.bz2
25# Source0-md5: 49e59dd184caa255886683facea56fca
bccc9f86 26URL: http://www.webmproject.org/
a28e5963 27BuildRequires: doxygen
71ced3dc 28%{?with_tests:BuildRequires: libstdc++-devel}
efdc9f5e 29BuildRequires: pkgconfig
a7d444e9 30BuildRequires: rpmbuild(macros) >= 1.673
9026bd8c 31BuildRequires: sed >= 4.0
3c828a1d 32%{?with_asm:BuildRequires: yasm >= 0.8}
a7d444e9
ER
33%if %{with doc}
34BuildRequires: %{php_name}-pcre
35BuildRequires: %{php_name}-program
36%endif
bccc9f86
AM
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
e1331b3a
ER
39%define generic_target generic-gnu
40%define vpxtarget %{generic_target}
41%ifarch %{x8664}
42%define vpxtarget x86_64-linux-gcc
43%endif
44%ifarch %{ix86}
45%define vpxtarget x86-linux-gcc
46%endif
47%ifarch ppc
48%define vpxtarget ppc32-linux-gcc
49%endif
50%ifarch ppc64
51%define vpxtarget ppc64-linux-gcc
52%endif
53
bccc9f86
AM
54%description
55VP8, a high-quality video codec.
56
d5d82930
JB
57%description -l pl.UTF-8
58VP8 - kodek obrazu wysokiej jakości.
59
bccc9f86 60%package devel
d5d82930
JB
61Summary: Header files for libvpx
62Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 63Group: Development/Libraries
d5d82930 64Requires: %{name} = %{version}-%{release}
bccc9f86
AM
65
66%description devel
d5d82930
JB
67Header files for libvpx library.
68
69%description devel -l pl.UTF-8
70Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
71
72%package static
73Summary: Static libvpx library
d5d82930 74Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 75Group: Development/Libraries
d5d82930 76Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
77
78%description static
79Static libvpx library.
80
d5d82930
JB
81%description static -l pl.UTF-8
82Statyczna biblioteka libvpx.
83
bccc9f86 84%prep
aa7aed28 85%setup -q
bccc9f86
AM
86
87%build
d5d82930
JB
88install -d obj
89cd obj
bccc9f86 90# not autoconf configure
2f02a711
JB
91CC="%{__cc}" \
92CXX="%{__cxx}" \
16ab9c5e 93CFLAGS="%{rpmcflags} %{rpmcppflags} %{!?with_asm:-DYUV_DISABLE_ASM}" \
bccc9f86 94../configure \
7b991969 95%if %{with asm}
dcde509e 96 --as=yasm \
61956466 97%endif
e1331b3a 98 --target=%{vpxtarget} \
6c7c0f8b 99 --enable-shared \
5f38e725 100 %{!?with_ssse3:--disable-ssse3} \
0257ab6e 101 --disable-optimizations \
2f397753 102 --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
f0a288d6
ER
103 --%{!?with_doc:dis}%{?with_doc:en}able-docs \
104 --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
bccc9f86 105 --enable-vp8 \
2f02a711 106 --enable-vp8 \
bccc9f86
AM
107 --enable-postproc \
108 --enable-runtime-cpu-detect
0257ab6e 109
0257ab6e 110%{__make} verbose=true target=libs \
938aec6f 111 HAVE_GNU_STRIP=no \
6c7c0f8b 112 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
113
114%{__make} verbose=true target=examples \
dcde509e 115 LDFLAGS="%{rpmldflags} -L."
a7d444e9
ER
116
117%if %{with doc}
0257ab6e 118%{__make} verbose=true target=docs
a7d444e9 119%endif
0257ab6e 120
bccc9f86
AM
121%install
122rm -rf $RPM_BUILD_ROOT
464fefd2 123install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 124
6c7c0f8b 125%{__make} -C obj verbose=true install \
938aec6f
ER
126 LIBSUBDIR=%{_lib} \
127 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 128
05641fc7 129%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.3.0
9026bd8c
JB
130
131# adjust prefix and libdir
3c828a1d 132%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
2f397753 137%post -p /sbin/ldconfig
bccc9f86
AM
138%postun -p /sbin/ldconfig
139
140%files
141%defattr(644,root,root,755)
d5d82930
JB
142%doc AUTHORS CHANGELOG LICENSE PATENTS README
143%attr(755,root,root) %{_bindir}/vpxdec
144%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 145%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
05641fc7 146%attr(755,root,root) %ghost %{_libdir}/libvpx.so.3
bccc9f86
AM
147
148%files devel
149%defattr(644,root,root,755)
47f853c3 150%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 151%{_includedir}/vpx
9026bd8c 152%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
153
154%files static
155%defattr(644,root,root,755)
0257ab6e 156%{_libdir}/libvpx.a
This page took 0.063748 seconds and 4 git commands to generate.