]> git.pld-linux.org Git - packages/libvpx.git/blame - libvpx.spec
enable shared now works for generic target as well
[packages/libvpx.git] / libvpx.spec
CommitLineData
c9ee805b
ER
1#
2# Conditional build:
d5d82930 3%bcond_without asm # x86 assembler
a7d444e9 4%bcond_without doc # don't build doc
2f397753 5%bcond_without tests # build without tests
5f38e725
ER
6%bcond_without ssse3 # use SSSE3 instructions (Intel since Core2, Via Nano)
7
f2369026
ER
8%ifnarch %{ix86} %{x8664}
9%undefine with_asm
10%endif
11
5f38e725
ER
12%if "%{pld_release}" == "ac"
13# not supported by compiler
14%undefine with_ssse3
15%endif
3c828a1d 16
bccc9f86 17Summary: VP8, a high-quality video codec
d5d82930 18Summary(pl.UTF-8): VP8 - kodek obrazu wysokiej jakości
bccc9f86 19Name: libvpx
1e757208 20Version: 1.3.0
1c3357c1 21Release: 1
bccc9f86
AM
22License: BSD
23Group: Libraries
1e757208
JB
24#Source0Download: http://code.google.com/p/webm/downloads/list
25#Source0: https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
488ced65
JB
26# source, but regenerated on each fetch
27#Source0: https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
28Source0: %{name}-%{version}.tar.gz
1e757208 29# Source0-md5: dcf436a5dc8b56bdfb4aec63b2fe6729
bccc9f86 30URL: http://www.webmproject.org/
a28e5963 31BuildRequires: doxygen
a7d444e9 32BuildRequires: rpmbuild(macros) >= 1.673
9026bd8c 33BuildRequires: sed >= 4.0
3c828a1d 34%{?with_asm:BuildRequires: yasm >= 0.8}
a7d444e9
ER
35%if %{with doc}
36BuildRequires: %{php_name}-pcre
37BuildRequires: %{php_name}-program
38%endif
bccc9f86
AM
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
e1331b3a
ER
41%define generic_target generic-gnu
42%define vpxtarget %{generic_target}
43%ifarch %{x8664}
44%define vpxtarget x86_64-linux-gcc
45%endif
46%ifarch %{ix86}
47%define vpxtarget x86-linux-gcc
48%endif
49%ifarch ppc
50%define vpxtarget ppc32-linux-gcc
51%endif
52%ifarch ppc64
53%define vpxtarget ppc64-linux-gcc
54%endif
55
bccc9f86
AM
56%description
57VP8, a high-quality video codec.
58
d5d82930
JB
59%description -l pl.UTF-8
60VP8 - kodek obrazu wysokiej jakości.
61
bccc9f86 62%package devel
d5d82930
JB
63Summary: Header files for libvpx
64Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libvpx
bccc9f86 65Group: Development/Libraries
d5d82930 66Requires: %{name} = %{version}-%{release}
bccc9f86
AM
67
68%description devel
d5d82930
JB
69Header files for libvpx library.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki libvpx.
bccc9f86
AM
73
74%package static
75Summary: Static libvpx library
d5d82930 76Summary(pl.UTF-8): Statyczna biblioteka libvpx
bccc9f86 77Group: Development/Libraries
d5d82930 78Requires: %{name}-devel = %{version}-%{release}
bccc9f86
AM
79
80%description static
81Static libvpx library.
82
d5d82930
JB
83%description static -l pl.UTF-8
84Statyczna biblioteka libvpx.
85
bccc9f86 86%prep
1e757208 87#%setup -q -n %{name}-v%{version}
5f38e725 88%setup -qc
bccc9f86
AM
89
90%build
d5d82930
JB
91install -d obj
92cd obj
bccc9f86 93# not autoconf configure
d5d82930 94CFLAGS="%{rpmcflags} %{rpmcppflags}" \
bccc9f86 95../configure \
7b991969 96%if %{with asm}
dcde509e 97 --as=yasm \
61956466 98%endif
e1331b3a 99 --target=%{vpxtarget} \
6c7c0f8b 100 --enable-shared \
5f38e725 101 %{!?with_ssse3:--disable-ssse3} \
0257ab6e 102 --disable-optimizations \
2f397753 103 --%{!?with_tests:dis}%{?with_tests:en}able-unit-tests \
f0a288d6
ER
104 --%{!?with_doc:dis}%{?with_doc:en}able-docs \
105 --%{!?with_doc:dis}%{?with_doc:en}able-install-docs \
bccc9f86
AM
106 --enable-vp8 \
107 --enable-postproc \
108 --enable-runtime-cpu-detect
0257ab6e 109
0257ab6e 110%{__make} verbose=true target=libs \
938aec6f 111 HAVE_GNU_STRIP=no \
6c7c0f8b 112 CC="%{__cc}" \
7fb20346 113 LD="%{__cc}" \
6c7c0f8b 114 LDFLAGS="%{rpmldflags}"
0257ab6e
AM
115
116%{__make} verbose=true target=examples \
6c7c0f8b 117 CC="%{__cc}" \
7fb20346 118 LD="%{__cc}" \
dcde509e 119 LDFLAGS="%{rpmldflags} -L."
a7d444e9
ER
120
121%if %{with doc}
0257ab6e 122%{__make} verbose=true target=docs
a7d444e9 123%endif
0257ab6e 124
bccc9f86
AM
125%install
126rm -rf $RPM_BUILD_ROOT
464fefd2 127install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
0257ab6e 128
6c7c0f8b 129%{__make} -C obj verbose=true install \
938aec6f
ER
130 LIBSUBDIR=%{_lib} \
131 DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
0257ab6e 132
1e757208 133%{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
9026bd8c
JB
134
135# adjust prefix and libdir
3c828a1d 136%{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
2f397753 141%post -p /sbin/ldconfig
bccc9f86
AM
142%postun -p /sbin/ldconfig
143
144%files
145%defattr(644,root,root,755)
d5d82930 146%doc AUTHORS CHANGELOG LICENSE PATENTS README
1c3357c1 147%attr(755,root,root) %{_bindir}/vp8_scalable_patterns
1e757208 148%attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
d5d82930
JB
149%attr(755,root,root) %{_bindir}/vpxdec
150%attr(755,root,root) %{_bindir}/vpxenc
47f853c3 151%attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
1c3357c1 152%attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
bccc9f86
AM
153
154%files devel
155%defattr(644,root,root,755)
47f853c3 156%attr(755,root,root) %{_libdir}/libvpx.so
464fefd2 157%{_includedir}/vpx
9026bd8c 158%{_pkgconfigdir}/vpx.pc
bccc9f86
AM
159
160%files static
161%defattr(644,root,root,755)
0257ab6e 162%{_libdir}/libvpx.a
This page took 0.145676 seconds and 4 git commands to generate.