]> git.pld-linux.org Git - packages/libskk.git/blob - libskk.spec
- fixed download URL
[packages/libskk.git] / libskk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  fep             # fep client
6
7 Summary:        Library to deal with Japanese kana-to-kanji conversion method
8 Summary(pl.UTF-8):      Biblioteka obsługi metody konwersji tekstu japońskiego kana do kanji
9 Name:           libskk
10 Version:        1.0.2
11 Release:        5
12 License:        GPL v3+
13 Group:          Libraries
14 #Source0Download: https://github.com/ueno/libskk/releases
15 Source0:        https://github.com/ueno/libskk/releases/download/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  26d5fedd29add95faae53dc90487330d
17 URL:            https://github.com/ueno/libskk/
18 BuildRequires:  gettext-tools
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  gobject-introspection-devel >= 0.9.0
21 BuildRequires:  json-glib-devel
22 BuildRequires:  libgee-devel
23 BuildRequires:  pkgconfig
24 # not needed for releases
25 #BuildRequires: vala >= 2:0.14.0
26 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
27 %if %{with fep}
28 BuildRequires:  libfep-devel >= 0.0.7
29 BuildRequires:  vala-libfep >= 0.0.7
30 %endif
31 BuildRequires:  vala-libgee
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libskk is a library to deal with Japanese kana-to-kanji conversion
36 method.
37
38 %description -l pl.UTF-8
39 libskk to biblioteka do obsługi metody konwersji tekstu japońśkiego
40 kana do kanji.
41
42 %package fep
43 Summary:        skkfep - Japanese SKK input method on text terminal
44 Summary(pl.UTF-8):      skkfep - metoda wprowadzania znaków japońskich SKK z terminala tekstowego
45 Group:          Applications/Text
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libfep >= 0.0.7
48
49 %description fep
50 skkfep is a tool that allows to use Japanese input method called SKK
51 (Simple Kana to Kanji conversion program) on ANSI compliant text
52 terminals.
53
54 %description fep -l pl.UTF-8
55 skkfep to narzędzie pozwalające na używanie metody wprowadzania znaków
56 japońskich SKK (Simple Kana to Kanji - konwersja uproszczonego kana do
57 kanji) na terminalach tekstowych zgodnych z ANSI.
58
59 %package devel
60 Summary:        Header files for libskk library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libskk
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 2.0
65 Requires:       json-glib-devel
66 Requires:       libgee-devel
67
68 %description devel
69 Header files for libskk library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki libskk.
73
74 %package static
75 Summary:        Static libskk library
76 Summary(pl.UTF-8):      Statyczna biblioteka libskk
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libskk library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libskk.
85
86 %package -n vala-libskk
87 Summary:        Vala API for libskk library
88 Summary(pl.UTF-8):      API języka Vala do biblioteki libskk
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Requires:       vala >= 2:0.14.0
92 Requires:       vala-libgee
93 %if "%{_rpmversion}" >= "5"
94 BuildArch:      noarch
95 %endif
96
97 %description -n vala-libskk
98 Vala API for libskk library.
99
100 %description -n vala-libskk -l pl.UTF-8
101 API języka Vala do biblioteki libskk.
102
103 %package apidocs
104 Summary:        libskk API documentation
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki libskk
106 Group:          Documentation
107 %if "%{_rpmversion}" >= "5"
108 BuildArch:      noarch
109 %endif
110
111 %description apidocs
112 API and internal documentation for libskk library.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API biblioteki libskk.
116
117 %prep
118 %setup -q
119
120 %build
121 # pass fake VALADOC_* args to avoid requiring valadoc-devel
122 # (only utility is needed here, but configure checks for development package)
123 %configure \
124         VALADOC_CFLAGS=fake \
125         VALADOC_LIBS=fake \
126         %{?with_apidocs:--enable-docs} \
127         %{?with_fep:--enable-fep} \
128         %{?with_static_libs:--enable-static}
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT \
136         libskkgtkdocdir=%{_gtkdocdir}/libskk
137
138 # obsoleted by pkg-config
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libskk.la
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc ChangeLog NEWS README
152 %attr(755,root,root) %{_bindir}/skk
153 %attr(755,root,root) %{_libdir}/libskk.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libskk.so.0
155 %{_libdir}/girepository-1.0/Skk-1.0.typelib
156 %{_datadir}/libskk
157 %{_mandir}/man1/skk.1*
158
159 %if %{with fep}
160 %files fep
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/skkfep
163 %attr(755,root,root) %{_libdir}/skkfep-client
164 %{_mandir}/man1/skkfep.1*
165 %endif
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libskk.so
170 %{_datadir}/gir-1.0/Skk-1.0.gir
171 %{_includedir}/libskk
172 %{_pkgconfigdir}/libskk.pc
173
174 %if %{with static_libs}
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/libskk.a
178 %endif
179
180 %files -n vala-libskk
181 %defattr(644,root,root,755)
182 %{_datadir}/vala/vapi/skk-1.0.deps
183 %{_datadir}/vala/vapi/skk-1.0.vapi
184
185 %if %{with apidocs}
186 %files apidocs
187 %defattr(644,root,root,755)
188 %{_gtkdocdir}/libskk
189 # should it be here?
190 %{_datadir}/devhelp/references/libskk
191 %endif
This page took 0.660688 seconds and 3 git commands to generate.