]> git.pld-linux.org Git - packages/libskk.git/blob - libskk.spec
- added valadoc patch (adjust for valadoc 0.52+, producing svg files instead of png)
[packages/libskk.git] / libskk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # valadoc/devhelp based API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  fep             # fep client
6
7 Summary:        Library to deal with Japanese kana-to-kanji conversion method
8 Summary(pl.UTF-8):      Biblioteka obsługi metody konwersji tekstu japońskiego kana do kanji
9 Name:           libskk
10 Version:        1.0.5
11 Release:        2
12 License:        GPL v3+
13 Group:          Libraries
14 #Source0Download: https://github.com/ueno/libskk/releases
15 Source0:        https://github.com/ueno/libskk/releases/download/%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  683c5a2dd23171297132453afd62e3c4
17 Patch0:         %{name}-valadoc.patch
18 URL:            https://github.com/ueno/libskk/
19 BuildRequires:  autoconf >= 2.63
20 BuildRequires:  automake >= 1:1.11.1
21 BuildRequires:  gettext-tools >= 0.19.8
22 BuildRequires:  glib2-devel >= 1:2.36
23 BuildRequires:  gobject-introspection-devel >= 0.9.0
24 BuildRequires:  json-glib-devel
25 BuildRequires:  libgee-devel >= 0.8
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpm-build >= 4.6
29 # not needed for releases
30 #BuildRequires: vala >= 2:0.14.0
31 %{?with_apidocs:BuildRequires:  valadoc >= 2:0.52}
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xorg-lib-libxkbcommon-devel
34 BuildRequires:  xz
35 %if %{with fep}
36 BuildRequires:  libfep-devel >= 0.0.7
37 BuildRequires:  vala-libfep >= 0.0.7
38 %endif
39 BuildRequires:  vala-libgee >= 0.8
40 Requires:       glib2 >= 1:2.36
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 libskk is a library to deal with Japanese kana-to-kanji conversion
45 method.
46
47 %description -l pl.UTF-8
48 libskk to biblioteka do obsługi metody konwersji tekstu japońśkiego
49 kana do kanji.
50
51 %package fep
52 Summary:        skkfep - Japanese SKK input method on text terminal
53 Summary(pl.UTF-8):      skkfep - metoda wprowadzania znaków japońskich SKK z terminala tekstowego
54 Group:          Applications/Text
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       libfep >= 0.0.7
57
58 %description fep
59 skkfep is a tool that allows to use Japanese input method called SKK
60 (Simple Kana to Kanji conversion program) on ANSI compliant text
61 terminals.
62
63 %description fep -l pl.UTF-8
64 skkfep to narzędzie pozwalające na używanie metody wprowadzania znaków
65 japońskich SKK (Simple Kana to Kanji - konwersja uproszczonego kana do
66 kanji) na terminalach tekstowych zgodnych z ANSI.
67
68 %package devel
69 Summary:        Header files for libskk library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libskk
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       glib2-devel >= 1:2.36
74 Requires:       json-glib-devel
75 Requires:       libgee-devel >= 0.8
76
77 %description devel
78 Header files for libskk library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki libskk.
82
83 %package static
84 Summary:        Static libskk library
85 Summary(pl.UTF-8):      Statyczna biblioteka libskk
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static libskk library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka libskk.
94
95 %package -n vala-libskk
96 Summary:        Vala API for libskk library
97 Summary(pl.UTF-8):      API języka Vala do biblioteki libskk
98 Group:          Development/Libraries
99 Requires:       %{name}-devel = %{version}-%{release}
100 Requires:       vala >= 2:0.14.0
101 Requires:       vala-libgee >= 0.8
102 BuildArch:      noarch
103
104 %description -n vala-libskk
105 Vala API for libskk library.
106
107 %description -n vala-libskk -l pl.UTF-8
108 API języka Vala do biblioteki libskk.
109
110 %package apidocs
111 Summary:        libskk API documentation
112 Summary(pl.UTF-8):      Dokumentacja API biblioteki libskk
113 Group:          Documentation
114 BuildArch:      noarch
115
116 %description apidocs
117 API and internal documentation for libskk library.
118
119 %description apidocs -l pl.UTF-8
120 Dokumentacja API biblioteki libskk.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125
126 %build
127 # pass fake VALADOC_* args to avoid requiring valadoc-devel
128 # (only utility is needed here, but configure checks for development package)
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         VALADOC_CFLAGS=fake \
136         VALADOC_LIBS=fake \
137         %{?with_apidocs:--enable-docs} \
138         %{?with_fep:--enable-fep} \
139         %{?with_static_libs:--enable-static}
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT \
147         libskkgtkdocdir=%{_gtkdocdir}/libskk
148
149 # obsoleted by pkg-config
150 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libskk.la
151
152 %find_lang %{name}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc ChangeLog NEWS README
163 %attr(755,root,root) %{_bindir}/skk
164 %attr(755,root,root) %{_libdir}/libskk.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libskk.so.0
166 %{_libdir}/girepository-1.0/Skk-1.0.typelib
167 %{_datadir}/libskk
168 %{_mandir}/man1/skk.1*
169
170 %if %{with fep}
171 %files fep
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/skkfep
174 %attr(755,root,root) %{_libexecdir}/skkfep-client
175 %{_mandir}/man1/skkfep.1*
176 %endif
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libskk.so
181 %{_datadir}/gir-1.0/Skk-1.0.gir
182 %{_includedir}/libskk
183 %{_pkgconfigdir}/libskk.pc
184
185 %if %{with static_libs}
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libskk.a
189 %endif
190
191 %files -n vala-libskk
192 %defattr(644,root,root,755)
193 %{_datadir}/vala/vapi/skk-1.0.deps
194 %{_datadir}/vala/vapi/skk-1.0.vapi
195
196 %if %{with apidocs}
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/libskk
200 # should it be here?
201 %{_datadir}/devhelp/references/libskk
202 %endif
This page took 0.121691 seconds and 4 git commands to generate.