]> git.pld-linux.org Git - packages/libparserutils.git/commitdiff
fix install on lib64 systems
authorElan Ruusamäe <glen@delfi.ee>
Sat, 27 Apr 2013 13:35:29 +0000 (16:35 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 27 Apr 2013 13:35:29 +0000 (16:35 +0300)
lib.patch [new file with mode: 0644]
libparserutils.spec

diff --git a/lib.patch b/lib.patch
new file mode 100644 (file)
index 0000000..29d2a44
--- /dev/null
+++ b/lib.patch
@@ -0,0 +1,18 @@
+--- libparserutils-0.1.2/Makefile~     2013-04-19 21:06:57.000000000 +0300
++++ libparserutils-0.1.2/Makefile      2013-04-27 16:34:18.203838178 +0300
+@@ -32,6 +32,7 @@
+ include $(NSBUILD)/Makefile.top
+ # Extra installation rules
++lib := lib
+ Is := include/parserutils
+ I := /include/parserutils
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$(Is)/errors.h;$(Is)/functypes.h;$(Is)/parserutils.h;$(Is)/types.h
+@@ -48,5 +49,5 @@
+ I := /include/parserutils/utils
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$(Is)/buffer.h;$(Is)/stack.h;$(Is)/vector.h
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /lib/pkgconfig:lib$(COMPONENT).pc.in
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
++INSTALL_ITEMS := $(INSTALL_ITEMS) /$(lib)/pkgconfig:lib$(COMPONENT).pc.in
++INSTALL_ITEMS := $(INSTALL_ITEMS) /$(lib):$(OUTPUT)
index a3dd6dc6af089513a9e1a8f5d448fcec76c21c86..b2e38c5f60666e292b0a84fbd52959cebf8380c0 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
 %bcond_without static_libs     # don't build static library
-#
+
 Summary:       Library for building efficient parsers
 Name:          libparserutils
 Version:       0.1.2
@@ -10,6 +10,7 @@ License:      MIT
 Group:         Libraries
 Source0:       http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
 # Source0-md5: 11c2b4ff17406b57dcb718d4fad022bb
+Patch0: lib.patch
 URL:           http://www.netsurf-browser.org/projects/libparserutils/
 BuildRequires: netsurf-buildsystem
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -20,27 +21,15 @@ C. It was developed as part of the NetSurf project and is available
 for use by other software under the MIT licence.
 
 Features:
-
-* No mandatory dependencies (iconv() implementation optional
-for enhanced charset support)
-* A number of built-in character set converters
-* Mapping of character set names to/from MIB enum values
-* UTF-8 and UTF-16 (host endian) support functions
-* Various simple data structures (resizeable buffer, stack, vector)
-* A UTF-8 input stream
-* Simple C API
-* Portable
-* Shared library
-
-Charset support
-
-LibParserUtils has the following built-in charset converters.
-
-* UTF-8
-* UTF-16 (platform-native endian)
-* ISO-8859-n
-* Windows-125n
-* US-ASCII
+- No mandatory dependencies (iconv() implementation optional for
+  enhanced charset support)
+- A number of built-in character set converters
+- Mapping of character set names to/from MIB enum values
+- UTF-8 and UTF-16 (host endian) support functions
+- Various simple data structures (resizeable buffer, stack, vector)
+- A UTF-8 input stream
+- Simple C API
+- Portable
 
 %package devel
 Summary:       libparserutils library headers
@@ -70,10 +59,12 @@ Statyczna biblioteka libparserutils.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
        CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
+
 %if %{with static_libs}
 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
        CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
@@ -81,19 +72,18 @@ Statyczna biblioteka libparserutils.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} install Q='' \
+       lib=%{_lib} \
        PREFIX=%{_prefix} \
        COMPONENT_TYPE=lib-shared \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 
 %if %{with static_libs}
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
+%{__make} install Q='' \
+       lib=%{_lib} \
        PREFIX=%{_prefix} \
        COMPONENT_TYPE=lib-static \
-       Q=''
+       DESTDIR=$RPM_BUILD_ROOT
 %endif
 
 %clean
This page took 0.114434 seconds and 4 git commands to generate.