]> git.pld-linux.org Git - packages/libparserutils.git/blob - libparserutils.spec
a3dd6dc6af089513a9e1a8f5d448fcec76c21c86
[packages/libparserutils.git] / libparserutils.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Library for building efficient parsers
6 Name:           libparserutils
7 Version:        0.1.2
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  11c2b4ff17406b57dcb718d4fad022bb
13 URL:            http://www.netsurf-browser.org/projects/libparserutils/
14 BuildRequires:  netsurf-buildsystem
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 LibParserUtils is a library for building efficient parsers, written in
19 C. It was developed as part of the NetSurf project and is available
20 for use by other software under the MIT licence.
21
22 Features:
23
24 * No mandatory dependencies (iconv() implementation optional
25 for enhanced charset support)
26 * A number of built-in character set converters
27 * Mapping of character set names to/from MIB enum values
28 * UTF-8 and UTF-16 (host endian) support functions
29 * Various simple data structures (resizeable buffer, stack, vector)
30 * A UTF-8 input stream
31 * Simple C API
32 * Portable
33 * Shared library
34
35 Charset support
36
37 LibParserUtils has the following built-in charset converters.
38
39 * UTF-8
40 * UTF-16 (platform-native endian)
41 * ISO-8859-n
42 * Windows-125n
43 * US-ASCII
44
45 %package devel
46 Summary:        libparserutils library headers
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libparserutils
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 This is the libraries, include files and other resources you can use
53 to incorporate libparserutils into applications.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe pozwalające na używanie biblioteki libparserutils w
57 swoich programach.
58
59 %package static
60 Summary:        libparserutils static libraries
61 Summary(pl.UTF-8):      Statyczne biblioteki libparserutils
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 This is package with static libparserutils libraries.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libparserutils.
70
71 %prep
72 %setup -q
73
74 %build
75 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
76         CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
77 %if %{with static_libs}
78 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
79         CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT \
87         PREFIX=%{_prefix} \
88         COMPONENT_TYPE=lib-shared \
89         Q=''
90
91 %if %{with static_libs}
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT \
94         PREFIX=%{_prefix} \
95         COMPONENT_TYPE=lib-static \
96         Q=''
97 %endif
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/lib*.so
112 %{_includedir}/parserutils
113 %{_pkgconfigdir}/*pc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/lib*.a
119 %endif
This page took 0.069411 seconds and 2 git commands to generate.