]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- new
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        libfilezilla
7 Summary(pl.UTF-8):      libfilezilla
8 Name:           libfilezilla
9 Version:        0.3.1
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/filezilla/%{name}-%{version}.tar.bz2
14 # Source0-md5:  b38566adef2f9f72f7feb45108d80b0c
15 URL:            http://lib.filezilla-project.org/
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  rpmbuild(macros) >= 1.583
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 libfilezilla is a free, open source C++ library, offering some basic
22 functionality to build high-performing, platform-independent programs.
23 Some of the highlights include:
24
25 - A typesafe, multi-threaded event system that's very simple to use
26   yet extremely efficient
27 - Timers for periodic events
28 - A datetime class that not only tracks timestamp but also their
29   accuracy, which simplifies dealing with timestamps originating from
30   different sources
31 - Simple process handling for spawning child processes with redirected
32   I/O
33
34 #%description -l pl.UTF-8
35
36 %package devel
37 Summary:        Header files for %{name} library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for %{name} library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki %{name}.
47
48 %package static
49 Summary:        Static %{name} library
50 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static %{name} library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka %{name}.
59
60 %package apidocs
61 Summary:        %{name} API documentation
62 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
63 Group:          Documentation
64
65 %description apidocs
66 API documentation for %{name} library.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API biblioteki %{name}.
70
71 %prep
72 %setup -q
73
74 %build
75 %configure \
76         %{!?with_static_libs:--disable-static}
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS NEWS README
96 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.0
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/%{name}.so
102 %{_includedir}/%{name}
103 %{_pkgconfigdir}/%{name}.pc
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/%{name}.a
109 %endif
110
111 %if 0
112 %files apidocs
113 %defattr(644,root,root,755)
114 %doc doc/*
115 %endif
This page took 0.171375 seconds and 4 git commands to generate.