]> git.pld-linux.org Git - packages/libfilezilla.git/commitdiff
- new auto/th/libfilezilla-0.3.1-1
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 20 Feb 2016 09:50:40 +0000 (10:50 +0100)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Sat, 20 Feb 2016 09:50:40 +0000 (10:50 +0100)
libfilezilla.spec [new file with mode: 0644]

diff --git a/libfilezilla.spec b/libfilezilla.spec
new file mode 100644 (file)
index 0000000..ef2f56b
--- /dev/null
@@ -0,0 +1,115 @@
+#
+# Conditional build:
+%bcond_without apidocs         # do not build and package API docs
+%bcond_without static_libs     # don't build static libraries
+#
+Summary:       libfilezilla
+Summary(pl.UTF-8):     libfilezilla
+Name:          libfilezilla
+Version:       0.3.1
+Release:       1
+License:       GPL v2
+Group:         Libraries
+Source0:       http://downloads.sourceforge.net/filezilla/%{name}-%{version}.tar.bz2
+# Source0-md5: b38566adef2f9f72f7feb45108d80b0c
+URL:           http://lib.filezilla-project.org/
+BuildRequires: libstdc++-devel
+BuildRequires: rpmbuild(macros) >= 1.583
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+libfilezilla is a free, open source C++ library, offering some basic
+functionality to build high-performing, platform-independent programs.
+Some of the highlights include:
+
+- A typesafe, multi-threaded event system that's very simple to use
+  yet extremely efficient
+- Timers for periodic events
+- A datetime class that not only tracks timestamp but also their
+  accuracy, which simplifies dealing with timestamps originating from
+  different sources
+- Simple process handling for spawning child processes with redirected
+  I/O
+
+#%description -l pl.UTF-8
+
+%package devel
+Summary:       Header files for %{name} library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description devel
+Header files for %{name} library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki %{name}.
+
+%package static
+Summary:       Static %{name} library
+Summary(pl.UTF-8):     Statyczna biblioteka %{name}
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static %{name} library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka %{name}.
+
+%package apidocs
+Summary:       %{name} API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki %{name}
+Group:         Documentation
+
+%description apidocs
+API documentation for %{name} library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki %{name}.
+
+%prep
+%setup -q
+
+%build
+%configure \
+       %{!?with_static_libs:--disable-static}
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS NEWS README
+%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/%{name}.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}.so
+%{_includedir}/%{name}
+%{_pkgconfigdir}/%{name}.pc
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/%{name}.a
+%endif
+
+%if 0
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/*
+%endif
This page took 0.289946 seconds and 4 git commands to generate.