]> git.pld-linux.org Git - packages/kp5-kde-gtk-config.git/blob - kp5-kde-gtk-config.spec
- updated to 5.24.2
[packages/kp5-kde-gtk-config.git] / kp5-kde-gtk-config.spec
1 %define         kdeplasmaver    5.24.2
2 %define         qtver           5.9.0
3 %define         kpname          kde-gtk-config
4 Summary:        GTK2 and GTK3 Configurator for KDE
5 Name:           kp5-%{kpname}
6 Version:        5.24.2
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Libraries
10 Source0:        http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
11 # Source0-md5:  3cd5ace074dc3130fc3feb8b21b96d02
12 Patch0:         x32.patch
13 %define         specflags       -I/usr/include/harfbuzz
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel >= %{qtver}
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  gsettings-desktop-schemas
18 BuildRequires:  gsettings-desktop-schemas-devel
19 BuildRequires:  gtk+2-devel
20 BuildRequires:  gtk+3-devel
21 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
22 BuildRequires:  kf5-karchive-devel
23 BuildRequires:  kf5-kauth-devel
24 BuildRequires:  kf5-kbookmarks-devel
25 BuildRequires:  kf5-kcmutils-devel
26 BuildRequires:  kf5-kcmutils-devel
27 BuildRequires:  kf5-kconfigwidgets-devel
28 BuildRequires:  kf5-kconfigwidgets-devel
29 BuildRequires:  kf5-ki18n-devel
30 BuildRequires:  kf5-kiconthemes-devel
31 BuildRequires:  kf5-kio-devel
32 BuildRequires:  kf5-kio-devel
33 BuildRequires:  kf5-knewstuff-devel
34 BuildRequires:  kf5-knewstuff-devel
35 BuildRequires:  kf5-kxmlgui-devel
36 BuildRequires:  kp5-kdecoration-devel >= 5.23.0
37 BuildRequires:  ninja
38 BuildRequires:  qt5-build >= %{qtver}
39 BuildRequires:  rpmbuild(macros) >= 1.164
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GTK2 and GTK3 Configurator for KDE.
46
47 %prep
48 %setup -q -n %{kpname}-%{version}
49 #%%patch0 -p1
50
51 %build
52 install -d build
53 cd build
54 %cmake -G Ninja \
55         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
56         -DHTML_INSTALL_DIR=%{_kdedocdir} \
57         ..
58 %ninja_build
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %ninja_install -C build
63
64 sed -i -e 's|/usr/bin/env sh|/bin/bash|' $RPM_BUILD_ROOT/usr/share/kconf_update/remove_window_decorations_from_gtk_css.sh
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_prefix}/libexec/gtk3_preview
75 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/gtkconfig.so
76 %attr(755,root,root) %{_libdir}/kconf_update_bin/gtk_theme
77 %{_datadir}/kconf_update/gtkconfig.upd
78 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libcolorreload-gtk-module.so
79 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libwindow-decorations-gtk-module.so
80 %attr(755,root,root) %{_datadir}/kconf_update/remove_window_decorations_from_gtk_css.sh
81 %{_datadir}/themes/Breeze/window_decorations.css
82 %dir %{_datadir}/kcm-gtk-module
83 %{_datadir}/kcm-gtk-module/preview.ui
84 %attr(755,root,root) %{_libdir}/kconf_update_bin/remove_deprecated_gtk4_option
This page took 0.248536 seconds and 4 git commands to generate.