]> git.pld-linux.org Git - packages/kp5-kde-gtk-config.git/blob - kp5-kde-gtk-config.spec
- updated to 5.27.11
[packages/kp5-kde-gtk-config.git] / kp5-kde-gtk-config.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeplasmaver    5.27.11
5 %define         qtver           5.15.2
6 %define         kpname          kde-gtk-config
7 Summary:        GTK2 and GTK3 Configurator for KDE
8 Name:           kp5-%{kpname}
9 Version:        5.27.11
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
14 # Source0-md5:  1b83e41e34b91f06efff8f6c0b855043
15 Patch0:         x32.patch
16 %define         specflags       -I/usr/include/harfbuzz
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  cmake >= 3.16.0
20 BuildRequires:  gsettings-desktop-schemas
21 BuildRequires:  gsettings-desktop-schemas-devel
22 BuildRequires:  gtk+2-devel
23 BuildRequires:  gtk+3-devel
24 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
25 BuildRequires:  kf5-karchive-devel
26 BuildRequires:  kf5-kauth-devel
27 BuildRequires:  kf5-kbookmarks-devel
28 BuildRequires:  kf5-kcmutils-devel
29 BuildRequires:  kf5-kcmutils-devel
30 BuildRequires:  kf5-kconfigwidgets-devel
31 BuildRequires:  kf5-kconfigwidgets-devel
32 BuildRequires:  kf5-ki18n-devel
33 BuildRequires:  kf5-kiconthemes-devel
34 BuildRequires:  kf5-kio-devel
35 BuildRequires:  kf5-kio-devel
36 BuildRequires:  kf5-knewstuff-devel
37 BuildRequires:  kf5-knewstuff-devel
38 BuildRequires:  kf5-kxmlgui-devel
39 BuildRequires:  kp5-kdecoration-devel >= 5.23.0
40 BuildRequires:  ninja
41 BuildRequires:  qt5-build >= %{qtver}
42 BuildRequires:  rpmbuild(macros) >= 1.164
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GTK2 and GTK3 Configurator for KDE.
49
50 %prep
51 %setup -q -n %{kpname}-%{version}
52 #%%patch0 -p1
53
54 %build
55 %cmake -B build \
56         -G Ninja \
57         %{!?with_tests:-DBUILD_TESTING=OFF} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         -DHTML_INSTALL_DIR=%{_kdedocdir}
60 %ninja_build -C build
61
62 %if %{with tests}
63 ctest
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %ninja_install -C build
69
70 sed -i -e 's|/usr/bin/env sh|/bin/bash|' $RPM_BUILD_ROOT/usr/share/kconf_update/remove_window_decorations_from_gtk_css.sh
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_prefix}/libexec/gtk3_preview
81 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/kded/gtkconfig.so
82 %attr(755,root,root) %{_libdir}/kconf_update_bin/gtk_theme
83 %{_datadir}/kconf_update/gtkconfig.upd
84 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libcolorreload-gtk-module.so
85 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libwindow-decorations-gtk-module.so
86 %attr(755,root,root) %{_datadir}/kconf_update/remove_window_decorations_from_gtk_css.sh
87 %{_datadir}/themes/Breeze/window_decorations.css
88 %dir %{_datadir}/kcm-gtk-module
89 %{_datadir}/kcm-gtk-module/preview.ui
90 %attr(755,root,root) %{_libdir}/kconf_update_bin/remove_deprecated_gtk4_option
This page took 0.091004 seconds and 4 git commands to generate.