]> git.pld-linux.org Git - packages/ka5-dolphin.git/blob - ka5-dolphin.spec
- 24.01.95
[packages/ka5-dolphin.git] / ka5-dolphin.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      24.01.95
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          dolphin
8 Summary:        File manager
9 Name:           ka5-%{kaname}
10 Version:        24.01.95
11 Release:        0.1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/unstable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  f97f50fda774efc3abf4140a9426c54e
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt6Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.20
19 BuildRequires:  kf6-extra-cmake-modules >= %{kframever}
20 BuildRequires:  kf6-kbookmarks-devel >= %{kframever}
21 BuildRequires:  kf6-kcmutils-devel >= %{kframever}
22 BuildRequires:  kf6-kcompletion-devel >= %{kframever}
23 BuildRequires:  kf6-kconfig-devel >= %{kframever}
24 BuildRequires:  kf6-kconfigwidgets-devel >= %{kframever}
25 BuildRequires:  kf6-kcoreaddons-devel >= %{kframever}
26 BuildRequires:  kf6-kdoctools-devel >= %{kframever}
27 BuildRequires:  kf6-kguiaddons-devel >= %{kframever}
28 BuildRequires:  kf6-ki18n-devel >= %{kframever}
29 BuildRequires:  kf6-kiconthemes-devel >= %{kframever}
30 BuildRequires:  kf6-kio-devel >= %{kframever}
31 BuildRequires:  kf6-kitemmodels-devel >= %{kframever}
32 BuildRequires:  kf6-knewstuff-devel >= %{kframever}
33 BuildRequires:  kf6-knotifications-devel >= %{kframever}
34 BuildRequires:  kf6-knotifyconfig-devel >= %{kframever}
35 BuildRequires:  kf6-kparts-devel >= %{kframever}
36 BuildRequires:  kf6-kpty-devel >= %{kframever}
37 BuildRequires:  kf6-kservice-devel >= %{kframever}
38 BuildRequires:  kf6-ktextwidgets-devel >= %{kframever}
39 BuildRequires:  kf6-kwidgetsaddons-devel >= %{kframever}
40 BuildRequires:  kf6-kwindowsystem-devel >= %{kframever}
41 BuildRequires:  kf6-kxmlgui-devel >= %{kframever}
42 BuildRequires:  ninja
43 BuildRequires:  qt6-build >= %{qtver}
44 BuildRequires:  rpmbuild(macros) >= 1.164
45 BuildRequires:  ruby-test-unit
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Dolphin is a lightweight file manager. It has been designed with ease
52 of use and simplicity in mind, while still allowing flexibility and
53 customisation. This means that you can do your file management exactly
54 the way you want to do it.
55
56 Features
57
58 • Navigation (or breadcrumb) bar for URLs, allowing you to quickly
59 navigate through the hierarchy of files and folders. • Supports
60 several different kinds of view styles and properties and allows you
61 to configure the view exactly how you want it. • Split view, allowing
62 you to easily copy or move files between locations. • Additional
63 information and shortcuts are available as dock-able panels, allowing
64 you to move them around freely and display exactly what you want. •
65 Multiple tab support • Informational dialogues are displayed in an
66 unobtrusive way. • Undo/redo support • Transparent network access
67 through the KIO system.
68
69 %description -l pl.UTF-8
70 Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w użyciu,
71 choć zapewniający elastyczność i możliwości konfiguracji. To znaczy,
72 że możesz go używać dokładnie, tak jakbyś chciał.
73
74 Cechy
75
76 • Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
77 się wśród hierarchi plików i folderów • Wspiera wiele różnych rodzajów
78 przeglądania plików pozwalając skonfigurować podgląd tak jak sobie
79 tego życzysz • Podzielony widok do łatwego kopiowania i przenoszenia
80 plików między lokacjami • Dodatkowe informacje i skróty klawiszowe są
81 dostępne jako dokowalne panele, pozwalając przemieszczać się do woli i
82 wyświetlać to co chcesz • Wiele kart • Informacyjne okna dialogowe nie
83 drażnią użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
84 dostęp do sieci korzystający z systemu KIO.
85
86 %package devel
87 Summary:        Header files for %{kaname} development
88 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
89 Group:          X11/Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       cmake >= 2.6.0
92
93 %description devel
94 Header files for %{kaname} development.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe dla programistów używających %{kaname}.
98
99 %prep
100 %setup -q -n %{kaname}-%{version}
101
102 %build
103 RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
104 export RUBYLIB
105 %cmake \
106         -B build \
107         -G Ninja \
108         %{!?with_tests:-DBUILD_TESTING=OFF} \
109         -DHTML_INSTALL_DIR=%{_kdedocdir} \
110         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
111 %ninja_build -C build
112
113 %if %{with tests}
114 ctest --test-dir build
115 %endif
116
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %ninja_install -C build
121
122 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
123 rm -rf $RPM_BUILD_ROOT%{_localedir}/ie
124 %find_lang %{kaname} --all-name --with-kde
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f %{kaname}.lang
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/dolphin
135 %attr(755,root,root) %{_bindir}/servicemenuinstaller
136 %{systemduserunitdir}/plasma-dolphin.service
137 %attr(755,root,root) %{_libdir}/libdolphinprivate.so.24.01.95
138 %ghost %{_libdir}/libdolphinprivate.so.6
139 %attr(755,root,root) %{_libdir}/libdolphinvcs.so.24.01.95
140 %ghost %{_libdir}/libdolphinvcs.so.6
141 %dir %{_libdir}/qt6/plugins/dolphin
142 %dir %{_libdir}/qt6/plugins/dolphin/kcms
143 %attr(755,root,root) %{_libdir}/qt6/plugins/dolphin/kcms/kcm_dolphingeneral.so
144 %attr(755,root,root) %{_libdir}/qt6/plugins/dolphin/kcms/kcm_dolphinviewmodes.so
145 %attr(755,root,root) %{_libdir}/qt6/plugins/kf6/parts/dolphinpart.so
146 %{_desktopdir}/org.kde.dolphin.desktop
147 %{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
148 %{_datadir}/config.kcfg/dolphin_contentdisplaysettings.kcfg
149 %{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
150 %{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
151 %{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
152 %{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
153 %{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
154 %{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
155 %{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
156 %{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
157 %{_datadir}/dolphin/dolphinpartactions.desktop
158 %{_datadir}/kconf_update/dolphin_detailsmodesettings.upd
159 %{_datadir}/kglobalaccel/org.kde.dolphin.desktop
160 %{_datadir}/knsrcfiles/servicemenu.knsrc
161 %{_datadir}/metainfo/org.kde.dolphin.appdata.xml
162 %{_datadir}/qlogging-categories6/dolphin.categories
163 %{zsh_compdir}/_dolphin
164
165 %files devel
166 %defattr(644,root,root,755)
167 %{_includedir}/Dolphin
168 %{_includedir}/dolphin_export.h
169 %{_includedir}/dolphinvcs_export.h
170 %{_libdir}/cmake/DolphinVcs
171 %{_libdir}/libdolphinvcs.so
This page took 0.100437 seconds and 3 git commands to generate.