]> git.pld-linux.org Git - packages/ka5-dolphin.git/blob - ka5-dolphin.spec
- updated to 23.08.5
[packages/ka5-dolphin.git] / ka5-dolphin.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.5
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          dolphin
8 Summary:        File manager
9 Name:           ka5-%{kaname}
10 Version:        23.08.5
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  965793c9a6ff04766de7977f5e972614
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.20
19 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
20 BuildRequires:  kf5-kbookmarks-devel >= %{kframever}
21 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
22 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
23 BuildRequires:  kf5-kconfig-devel >= %{kframever}
24 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
25 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
26 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
27 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
28 BuildRequires:  kf5-kemoticons-devel >= %{kframever}
29 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
30 BuildRequires:  kf5-ki18n-devel >= %{kframever}
31 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
32 BuildRequires:  kf5-kinit-devel >= %{kframever}
33 BuildRequires:  kf5-kio-devel >= %{kframever}
34 BuildRequires:  kf5-kitemmodels-devel >= %{kframever}
35 BuildRequires:  kf5-knewstuff-devel >= %{kframever}
36 BuildRequires:  kf5-knotifications-devel >= %{kframever}
37 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
38 BuildRequires:  kf5-kparts-devel >= %{kframever}
39 BuildRequires:  kf5-kpty-devel >= %{kframever}
40 BuildRequires:  kf5-kservice-devel >= %{kframever}
41 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
42 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
43 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
44 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
45 BuildRequires:  ninja
46 BuildRequires:  qt5-build >= %{qtver}
47 BuildRequires:  rpmbuild(macros) >= 1.164
48 BuildRequires:  ruby-test-unit
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Dolphin is a lightweight file manager. It has been designed with ease
55 of use and simplicity in mind, while still allowing flexibility and
56 customisation. This means that you can do your file management exactly
57 the way you want to do it.
58
59 Features
60
61 • Navigation (or breadcrumb) bar for URLs, allowing you to quickly
62 navigate through the hierarchy of files and folders. • Supports
63 several different kinds of view styles and properties and allows you
64 to configure the view exactly how you want it. • Split view,
65 allowing you to easily copy or move files between locations. •
66 Additional information and shortcuts are available as dock-able
67 panels, allowing you to move them around freely and display exactly
68 what you want. • Multiple tab support • Informational dialogues
69 are displayed in an unobtrusive way. • Undo/redo support •
70 Transparent network access through the KIO system.
71
72 %description -l pl.UTF-8
73 Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w
74 użyciu, choć zapewniający elastyczność i możliwości
75 konfiguracji. To znaczy, że możesz go używać dokładnie, tak
76 jakbyś chciał.
77
78 Cechy
79
80 • Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
81 się wśród hierarchi plików i folderów • Wspiera wiele różnych
82 rodzajów przeglądania plików pozwalając skonfigurować podgląd
83 tak jak sobie tego życzysz • Podzielony widok do łatwego
84 kopiowania i przenoszenia plików między lokacjami • Dodatkowe
85 informacje i skróty klawiszowe są dostępne jako dokowalne panele,
86 pozwalając przemieszczać się do woli i wyświetlać to co chcesz
87 • Wiele kart • Informacyjne okna dialogowe nie drażnią
88 użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
89 dostęp do sieci korzystający z systemu KIO.
90
91 %package devel
92 Summary:        Header files for %{kaname} development
93 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
94 Group:          X11/Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       cmake >= 2.6.0
97
98 %description devel
99 Header files for %{kaname} development.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe dla programistów używających %{kaname}.
103
104 %prep
105 %setup -q -n %{kaname}-%{version}
106
107 %build
108 RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
109 export RUBYLIB
110 %cmake \
111         -B build \
112         -G Ninja \
113         %{!?with_tests:-DBUILD_TESTING=OFF} \
114         -DHTML_INSTALL_DIR=%{_kdedocdir} \
115         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
116 %ninja_build -C build
117
118 %if %{with tests}
119 ctest --test-dir build
120 %endif
121
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 %ninja_install -C build
126
127 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
128 rm -rf $RPM_BUILD_ROOT%{_localedir}/ie
129 %find_lang %{kaname} --all-name --with-kde
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %files -f %{kaname}.lang
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/dolphin
140 %attr(755,root,root) %{_bindir}/servicemenuinstaller
141 %ghost %{_libdir}/libdolphinprivate.so.5
142 %{_libdir}/libdolphinprivate.so.5.*.*
143 %ghost %{_libdir}/libdolphinvcs.so.5
144 %{_libdir}/libdolphinvcs.so.5.*.*
145 %{_desktopdir}/org.kde.dolphin.desktop
146 %{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
147 %{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
148 %{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
149 %{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
150 %{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
151 %{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
152 %{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
153 %{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
154 %{_datadir}/metainfo/org.kde.dolphin.appdata.xml
155 %{_datadir}/kglobalaccel/org.kde.dolphin.desktop
156 %{_datadir}/qlogging-categories5/dolphin.categories
157 %{_datadir}/knsrcfiles/servicemenu.knsrc
158 %{systemduserunitdir}/plasma-dolphin.service
159 %{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
160 %{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
161 %dir %{_libdir}/qt5/plugins/dolphin
162 %dir %{_libdir}/qt5/plugins/dolphin/kcms
163 %{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphingeneral.so
164 %{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinnavigation.so
165 %{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinviewmodes.so
166 %{_datadir}/kconf_update/dolphin_detailsmodesettings.upd
167 %dir %{_datadir}/dolphin
168 %{_datadir}/dolphin/dolphinpartactions.desktop
169 %{zsh_compdir}/_dolphin
170 %{_datadir}/config.kcfg/dolphin_contentdisplaysettings.kcfg
171
172 %files devel
173 %defattr(644,root,root,755)
174 %{_libdir}/libdolphinvcs.so
175 %{_includedir}/Dolphin
176 %{_includedir}/dolphin_export.h
177 %{_includedir}/dolphinvcs_export.h
178 %{_libdir}/cmake/DolphinVcs
This page took 0.172335 seconds and 4 git commands to generate.