]> git.pld-linux.org Git - packages/ka5-dolphin.git/blob - ka5-dolphin.spec
- removing unsupported locale: ie
[packages/ka5-dolphin.git] / ka5-dolphin.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.0
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          dolphin
8 Summary:        File manager
9 Name:           ka5-%{kaname}
10 Version:        22.12.0
11 Release:        2
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  83651c188a444ede478eebe2a30bb888
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
20 BuildRequires:  kf5-kbookmarks-devel >= %{kframever}
21 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
22 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
23 BuildRequires:  kf5-kconfig-devel >= %{kframever}
24 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
25 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
26 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
27 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
28 BuildRequires:  kf5-kemoticons-devel >= %{kframever}
29 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
30 BuildRequires:  kf5-ki18n-devel >= %{kframever}
31 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
32 BuildRequires:  kf5-kinit-devel >= %{kframever}
33 BuildRequires:  kf5-kio-devel >= %{kframever}
34 BuildRequires:  kf5-kitemmodels-devel >= %{kframever}
35 BuildRequires:  kf5-knewstuff-devel >= %{kframever}
36 BuildRequires:  kf5-knotifications-devel >= %{kframever}
37 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
38 BuildRequires:  kf5-kparts-devel >= %{kframever}
39 BuildRequires:  kf5-kpty-devel >= %{kframever}
40 BuildRequires:  kf5-kservice-devel >= %{kframever}
41 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
42 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
43 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
44 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
45 BuildRequires:  ninja
46 BuildRequires:  qt5-build >= %{qtver}
47 BuildRequires:  rpmbuild(macros) >= 1.164
48 BuildRequires:  ruby-test-unit
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Dolphin is a lightweight file manager. It has been designed with ease
55 of use and simplicity in mind, while still allowing flexibility and
56 customisation. This means that you can do your file management exactly
57 the way you want to do it.
58
59 Features
60
61 • Navigation (or breadcrumb) bar for URLs, allowing you to quickly
62 navigate through the hierarchy of files and folders. • Supports
63 several different kinds of view styles and properties and allows you
64 to configure the view exactly how you want it. • Split view,
65 allowing you to easily copy or move files between locations. •
66 Additional information and shortcuts are available as dock-able
67 panels, allowing you to move them around freely and display exactly
68 what you want. • Multiple tab support • Informational dialogues
69 are displayed in an unobtrusive way. • Undo/redo support •
70 Transparent network access through the KIO system.
71
72 %description -l pl.UTF-8
73 Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w
74 użyciu, choć zapewniający elastyczność i możliwości
75 konfiguracji. To znaczy, że możesz go używać dokładnie, tak
76 jakbyś chciał.
77
78 Cechy
79
80 • Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
81 się wśród hierarchi plików i folderów • Wspiera wiele różnych
82 rodzajów przeglądania plików pozwalając skonfigurować podgląd
83 tak jak sobie tego życzysz • Podzielony widok do łatwego
84 kopiowania i przenoszenia plików między lokacjami • Dodatkowe
85 informacje i skróty klawiszowe są dostępne jako dokowalne panele,
86 pozwalając przemieszczać się do woli i wyświetlać to co chcesz
87 • Wiele kart • Informacyjne okna dialogowe nie drażnią
88 użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
89 dostęp do sieci korzystający z systemu KIO.
90
91 %package devel
92 Summary:        Header files for %{kaname} development
93 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
94 Group:          X11/Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       cmake >= 2.6.0
97
98 %description devel
99 Header files for %{kaname} development.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe dla programistów używających %{kaname}.
103
104 %prep
105 %setup -q -n %{kaname}-%{version}
106
107 %build
108 install -d build
109 cd build
110 RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
111 export RUBYLIB
112 %cmake \
113         -G Ninja \
114         %{!?with_tests:-DBUILD_TESTING=OFF} \
115         -DHTML_INSTALL_DIR=%{_kdedocdir} \
116         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
117         ..
118 %ninja_build
119
120 %if %{with tests}
121 ctest
122 %endif
123
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 %ninja_install -C build
128
129 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{ie,sr}
130 %find_lang %{kaname} --all-name --with-kde
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files -f %{kaname}.lang
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/dolphin
141 %attr(755,root,root) %{_bindir}/servicemenuinstaller
142 %ghost %{_libdir}/libdolphinprivate.so.5
143 %{_libdir}/libdolphinprivate.so.5.*.*
144 %ghost %{_libdir}/libdolphinvcs.so.5
145 %{_libdir}/libdolphinvcs.so.5.*.*
146 %{_desktopdir}/org.kde.dolphin.desktop
147 %{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
148 %{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
149 %{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
150 %{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
151 %{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
152 %{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
153 %{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
154 %{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
155 %{_datadir}/metainfo/org.kde.dolphin.appdata.xml
156 %{_datadir}/kglobalaccel/org.kde.dolphin.desktop
157 %{_datadir}/qlogging-categories5/dolphin.categories
158 %{_datadir}/knsrcfiles/servicemenu.knsrc
159 %{systemduserunitdir}/plasma-dolphin.service
160 %{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
161 %{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
162 %dir %{_libdir}/qt5/plugins/dolphin
163 %dir %{_libdir}/qt5/plugins/dolphin/kcms
164 %{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphingeneral.so
165 %{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinnavigation.so
166 %{_libdir}/qt5/plugins/dolphin/kcms/kcm_dolphinviewmodes.so
167 %{_datadir}/kconf_update/dolphin_detailsmodesettings.upd
168 %dir %{_datadir}/dolphin
169 %{_datadir}/dolphin/dolphinpartactions.desktop
170
171 %files devel
172 %defattr(644,root,root,755)
173 %{_libdir}/libdolphinvcs.so
174 %{_includedir}/Dolphin
175 %{_includedir}/dolphin_export.h
176 %{_includedir}/dolphinvcs_export.h
177 %{_libdir}/cmake/DolphinVcs
This page took 0.078652 seconds and 3 git commands to generate.