]> git.pld-linux.org Git - packages/iwidgets.git/commitdiff
- updated to 4.1.1 release master auto/th/iwidgets-4.1.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Jan 2019 08:22:20 +0000 (09:22 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Jan 2019 08:22:20 +0000 (09:22 +0100)
- added nosrc patch (allow build without itcl/itk sources)
- examples are back

iwidgets-nosrc.patch [new file with mode: 0644]
iwidgets.spec

diff --git a/iwidgets-nosrc.patch b/iwidgets-nosrc.patch
new file mode 100644 (file)
index 0000000..52c76c7
--- /dev/null
@@ -0,0 +1,33 @@
+--- iwidgets-4.1.1/configure.in.orig   2018-03-22 17:18:19.000000000 +0100
++++ iwidgets-4.1.1/configure.in        2019-01-17 21:32:15.981219229 +0100
+@@ -38,27 +38,10 @@
+ #AC_ARG_WITH(itcl, [  --with-itcl=DIR         use Itcl 3.0 binaries from DIR],
+ #        itcl_search=$withval, itcl_search=`cd ${srcdir}/..; pwd`)
+-ITCL_LIB_DIR=""
+-if test -r $itcl_SRC_DIR/library/itcl.tcl; then
+-    ITCL_LIB_DIR=$itcl_SRC_DIR/library
+-fi
++ITCL_LIB_DIR="$itcl_SRC_DIR"
+-if test -z "$ITCL_LIB_DIR"; then
+-    AC_MSG_ERROR([Can't find Itcl source.  Use --with-itcl to specify the the toplevel [incr Tcl] directory on your system.  This directory should contain library/itcl.tcl.])
+-fi
+-
+-AC_ARG_WITH(itk, [  --with-itk=DIR         use Itk 3.0 binaries from DIR],
+-        itk_search=$withval, itk_search=`cd ${srcdir}/..; pwd`)
+-
+-ITK_LIB_DIR=""
+-if test -r $itk_search/library/itk.tcl; then
+-    ITK_LIB_DIR=$itk_search/library
+-    ITK_SRC_DIR=$itk_search
+-fi
+-
+-if test -z "$ITK_LIB_DIR"; then
+-    AC_MSG_ERROR([Can't find Itk source.  Use --with-itk to specify the the toplevel [incr Tk] directory on your system.  This directory should contain library/itk.tcl.])
+-fi
++ITK_LIB_DIR="$itcl_SRC_DIR"
++ITK_SRC_DIR="$itcl_SRC_DIR"
+ #--------------------------------------------------------------------
+ # Handle the --prefix=... option by defaulting to what Tcl gave.
index 48a7a4b1225be4358c170fd2ccd455e21dd85130..b4ca6a0a92b444471d85a0499ed7622e90e225ce 100644 (file)
@@ -1,28 +1,19 @@
-#
-# Conditional build:
-%bcond_with    examples        # examples (not present in 4.1 snapshots)
-#
 Summary:       [incr Widgets] - object-oriented widget set based in [incr Tcl] and [incr Tk]
 Summary(pl.UTF-8):     [incr Widgets] - zbiór obiektowo zorientowanych widgetów opartych na [incr Tcl] i [incr Tk]
 Name:          iwidgets
-Version:       4.1
-%define snap   20120928
-Release:       0.%{snap}.1
+Version:       4.1.1
+Release:       1
 License:       BSD-like
 Group:         Development/Languages/Tcl
-#Source0:      http://downloads.sourceforge.net/incrtcl/iwidgets%{iwidgets_version}.tar.gz
-# http://core.tcl.tk/iwidgets - iwidgets for itcl/itk 4
-Source0:       http://downloads.sourceforge.net/kbskit/iwidgets41.tgz
-# Source0-md5: 5a60ec284bd8095c665287215ff2a69f
+Source0:       http://downloads.sourceforge.net/incrtcl/%{name}-%{version}.tar.gz
+# Source0-md5: cca62e022b0d561a2bba19bd56ecc667
+Patch0:                %{name}-nosrc.patch
 URL:           http://incrtcl.sourceforge.net/iwidgets/index.html
 BuildRequires: autoconf >= 2.13
 BuildRequires: tcl >= 8.6
 BuildRequires: tk >= 8.6
 Requires:      itcl >= 4.0
 Requires:      itk >= 4.0
-%if %{without examples}
-Obsoletes:     iwidgets-examples
-%endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -68,21 +59,30 @@ Examples for iwidgets.
 Przykłady dla biblioteki iwidgets.
 
 %prep
-%setup -q -n %{name}%{version}
+%setup -q
+%patch0 -p1
+
+%build
+%{__autoconf}
+%configure \
+       --libdir=%{_ulibdir}
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}
 
-cp -p library/* $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 ln -sf %{_ulibdir}/iwidgets%{version} $RPM_BUILD_ROOT%{_ulibdir}/iwidgets
 
-%if %{with examples}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 %{__mv} $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}/demos/* \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-%endif
+
+# packaged as %doc
+%{__rm} $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}/license.terms
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -92,14 +92,11 @@ rm -rf $RPM_BUILD_ROOT
 %doc README license.terms
 %{_ulibdir}/iwidgets
 %dir %{_ulibdir}/iwidgets%{version}
-%{_ulibdir}/iwidgets%{version}/*.itcl
-%{_ulibdir}/iwidgets%{version}/*.itk
-%{_ulibdir}/iwidgets%{version}/unknownimage.gif
+%{_ulibdir}/iwidgets%{version}/scripts
+%{_ulibdir}/iwidgets%{version}/iwidgets.tcl
 %{_ulibdir}/iwidgets%{version}/pkgIndex.tcl
-%{_ulibdir}/iwidgets%{version}/tclIndex
+%{_mandir}/mann/iwidgets_*.n*
 
-%if %{with examples}
 %files examples
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
-%endif
This page took 0.189492 seconds and 4 git commands to generate.