]> git.pld-linux.org Git - packages/iwidgets.git/blob - iwidgets.spec
48a7a4b1225be4358c170fd2ccd455e21dd85130
[packages/iwidgets.git] / iwidgets.spec
1 #
2 # Conditional build:
3 %bcond_with     examples        # examples (not present in 4.1 snapshots)
4 #
5 Summary:        [incr Widgets] - object-oriented widget set based in [incr Tcl] and [incr Tk]
6 Summary(pl.UTF-8):      [incr Widgets] - zbiór obiektowo zorientowanych widgetów opartych na [incr Tcl] i [incr Tk]
7 Name:           iwidgets
8 Version:        4.1
9 %define snap    20120928
10 Release:        0.%{snap}.1
11 License:        BSD-like
12 Group:          Development/Languages/Tcl
13 #Source0:       http://downloads.sourceforge.net/incrtcl/iwidgets%{iwidgets_version}.tar.gz
14 # http://core.tcl.tk/iwidgets - iwidgets for itcl/itk 4
15 Source0:        http://downloads.sourceforge.net/kbskit/iwidgets41.tgz
16 # Source0-md5:  5a60ec284bd8095c665287215ff2a69f
17 URL:            http://incrtcl.sourceforge.net/iwidgets/index.html
18 BuildRequires:  autoconf >= 2.13
19 BuildRequires:  tcl >= 8.6
20 BuildRequires:  tk >= 8.6
21 Requires:       itcl >= 4.0
22 Requires:       itk >= 4.0
23 %if %{without examples}
24 Obsoletes:      iwidgets-examples
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _ulibdir        %{_prefix}/lib
30
31 %description
32 [incr Widgets] is an object-oriented mega-widget set which extends
33 Tcl/Tk and is based on [incr Tcl] and [incr Tk]. This set of
34 mega-widgets delivers many new, general purpose widgets like option
35 menus, comboboxes, selection boxes, and various dialogs whose
36 couterparts are found in Motif and Windows. Since [incr Widgets] is
37 based on the [incr Tk] extension, the Tk framework of configuration
38 options, widget commands, and default bindings is maintained. In other
39 words, each [incr Widgets] mega-widget seamlessly blends with the
40 standard Tk widgets. They look, act and feel like Tk widgets. In
41 addition, all [incr Widgets] mega-widgets are object oriented and may
42 themselves be extended, using either inheritance or composition.
43
44 %description -l pl.UTF-8
45 [incr Widgets] to zbiór zorientowanych obiektowo mega-widgetów
46 rozszerzający Tcl/Tk, oparty na [incr Tcl] i [incr Tk]. Ten zbiór
47 mega-widgetów zawiera wiele nowych widgetów ogólnego przeznaczenia,
48 takich jak menu opcji, kontrolki combobox, kontrolki wyboru oraz różne
49 okna dialogowe, których odpowiedniki można znaleźć w Motifie lub
50 Windows. Jako że [incr Widgets] jest oparty na rozszerzeniu [incr Tk],
51 zachowany jest szkielet Tk opcji konfiguracyjnych, polecenia widgetów
52 oraz domyślne powiązania. Innymi słowy, każdy mega-widget [incr
53 Widgets] komponują się idealnie ze standardowymi widgetami Tk.
54 Wyglądają i zachowują się tak samo, jak widgety Tk. Ponadto wszystkie
55 mega-widgety [incr Widgets] są zorientowane obiektowo i mogą być
56 rozszerzane - poprzez dziedziczenie lub składanie.
57
58 %package examples
59 Summary:        Examples for iwidgets
60 Summary(pl.UTF-8):      Przykłady dla biblioteki iwidgets
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description examples
65 Examples for iwidgets.
66
67 %description examples -l pl.UTF-8
68 Przykłady dla biblioteki iwidgets.
69
70 %prep
71 %setup -q -n %{name}%{version}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}
76
77 cp -p library/* $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}
78
79 ln -sf %{_ulibdir}/iwidgets%{version} $RPM_BUILD_ROOT%{_ulibdir}/iwidgets
80
81 %if %{with examples}
82 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83 %{__mv} $RPM_BUILD_ROOT%{_ulibdir}/iwidgets%{version}/demos/* \
84         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README license.terms
93 %{_ulibdir}/iwidgets
94 %dir %{_ulibdir}/iwidgets%{version}
95 %{_ulibdir}/iwidgets%{version}/*.itcl
96 %{_ulibdir}/iwidgets%{version}/*.itk
97 %{_ulibdir}/iwidgets%{version}/unknownimage.gif
98 %{_ulibdir}/iwidgets%{version}/pkgIndex.tcl
99 %{_ulibdir}/iwidgets%{version}/tclIndex
100
101 %if %{with examples}
102 %files examples
103 %defattr(644,root,root,755)
104 %{_examplesdir}/%{name}-%{version}
105 %endif
This page took 0.101886 seconds and 2 git commands to generate.